0.81: "cmd_showGrid" out-of-sync

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
XnTriq
Moderator & Librarian
Posts: 4819
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

0.81: "cmd_showGrid" out-of-sync

Postby XnTriq » Tue Jul 12, 2016 7:45 pm

The button on the crop toolbar for toggeling the grid overlay (cmd_showGrid) is not working and needs to be synced with the corresponding button on the main toolbar as well as the command in View » Show grid.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby Erixx haxx » Wed Jul 13, 2016 10:40 pm

Just an FYI:

This is showing up in 0.82 Beta 1 and 2 also..

Zoom select Shows a grid. I can't remember how to turn it off.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby Erixx haxx » Thu Jul 28, 2016 5:41 am

Another bit of info:

This does not happen in v0.79. It Seems to work fine in that version.

In the other versions it always defaults back to show grid after every restart.

User avatar
xnview
Author of XnView
Posts: 27030
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby xnview » Tue Aug 16, 2016 1:21 pm

XnTriq wrote:The button on the crop toolbar for toggeling the grid overlay (cmd_showGrid) is not working and needs to be synced with the corresponding button on the main toolbar as well as the command in View » Show grid.

this button is not show grid, but show grid inside the selection. I need to change the icon...
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 4819
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby XnTriq » Thu Aug 18, 2016 4:30 pm

xnview wrote:this button is not show grid, but show grid inside the selection. I need to change the icon...

Shame on me! I failed to realize that this important feature had already been implemented.

However, there still is an issue: The button on the main toolbar (cmd_showGrid) does not sync with the the command in View » Show grid if the crop toolbar is visible (pressed/unpressed state). Can someone please confirm this?

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby Erixx haxx » Thu Aug 18, 2016 7:06 pm

Hi:

Something is wacky here, Because "Show grid" is stuck ( ON ) for "Zoomed selection"

Inside Fullscreen and Viewer mode unless you bring out the crop menu.
Then every time you restart it defaults back to ( ON ).

Its real annoying inside fullscreen, you have to bring out the crop menu after every restart.


When you say "Main tool bar" (cmd_showGrid). Do you mean 1 inside the browser mode or somewhere else. I was going to try but didn't completely understand where you are refering to. Just plain "Show grid button" inside the viewer mode is working for me

User avatar
XnTriq
Moderator & Librarian
Posts: 4819
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby XnTriq » Thu Aug 18, 2016 9:00 pm

Thanks for checking.

Erixx haxx wrote:When you say "Main tool bar" (cmd_showGrid). Do you mean 1 inside the browser mode or somewhere else.

I'm referring to the toolbar in view mode (Ctrl+Shift+T).

Previews of animated screenshots:

p133676_1.gif
Standard view mode: The buttons for "Show grid" on the main toolbar and in the View menu are pressed, indicating that the grid overlay is active.

p133676_2.gif
Crop mode (buggy): Although the grid overlay is active, the buttons for "Show grid" on the main toolbar and in the View menu are in unpressed state.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby Erixx haxx » Fri Aug 19, 2016 7:10 am

Hi:

Ok, Yea I See it.

In View Mode, as soon as you enter 'Crop Mode' ( buggy zoom select ) See my post Above.
The "Show grid" button ( Mian Toolbar ) becomes unsynced.

As in button is unpressed, but the grid is still showing.


I guess we have two bugs here. Let me know if mine needs a new thread.

User avatar
XnTriq
Moderator & Librarian
Posts: 4819
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby XnTriq » Sat Aug 20, 2016 12:30 am

So there are actually two bugs in “Crop mode”:

  1. “Red grid”: Although the grid overlay is active, the buttons for "Show grid" (cmd_showGrid) on the main toolbar (Ctrl+Shift+T) and in the View menu remain in unpressed state.
  2. “White grid” (Rule-of-Thirds guidelines inside selected areas): Deactivation is not remembered between “crop sessions”.

User avatar
xnview
Author of XnView
Posts: 27030
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby xnview » Thu Mar 16, 2017 9:14 am

This problem is supposed to be fixed in XnView MP 0.85 beta 1. Please check and confirm the bug fix here.
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby Erixx haxx » Sat Mar 18, 2017 12:36 am

Hi:

I checked this "Red grid button sync" problem and it seems to work now.

Thanks

User avatar
helmut
Posts: 8084
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby helmut » Sat Mar 18, 2017 8:18 am

Erixx haxx wrote: I checked this "Red grid button sync" problem and it seems to work now.
Thank you for checking this, Erixx haxx. Before moving this to "Tested - Fixed" I'll wait for the feedback of the original poster (XnTriq).

User avatar
XnTriq
Moderator & Librarian
Posts: 4819
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: [v0.81] "cmd_showGrid" out-of-sync

Postby XnTriq » Sun Mar 19, 2017 2:45 am

helmut wrote:Before moving this to "Tested - Fixed" I'll wait for the feedback of the original poster (XnTriq).

Thanks helmut, but I'm just too busy :-|
I think we can trust our compadre and his thorough investigations, as he's doing a better job at beta testing than yours truly anyway!


Return to “Closed/Resolved”

Who is online

Users browsing this forum: No registered users and 1 guest