0.84: Folder filter should reset when we change the folder

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
m.Th.
XnThusiast
Posts: 1338
Joined: Wed Aug 16, 2006 6:31 am
Contact:

0.84: Folder filter should reset when we change the folder

Postby m.Th. » Thu Feb 16, 2017 5:18 pm

The Folder Filter (see below) should be „rebooted”/„updated” when we change the Folder.

Folder filter.png
Folder filter.png (16.77 KiB) Viewed 508 times


Steps:

1. Go to C:\f1
2. Tag 3 files
3. Go to c:\f2
4. Tag 6 files
5. Go to C:\f1
6. Click on the Folder Filter menu and select Tagged filter. The program correctly shows the 3 files tagged at step 2.
7. Go to c:\f2

Expected: The program should show the 6 files tagged at step 4 - OR- the filter should be reset and show ALL files. An On/Off option called „Keep filter between folders” would be very, very nice.

Actual: The program displays nothing which is wrong. (most probably it is a logical AND between the ImageIDs from step 2 and the newly selected folder).
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.84 64bit & XnView 2.00 x64 on Win7 x64 -

vertigo
Posts: 106
Joined: Wed Feb 15, 2017 3:49 pm

Re: 0.84: Folder filter should reset when we change the fold

Postby vertigo » Thu Feb 16, 2017 7:11 pm

Reproduced. Even if you go back to folder 1 it's still blank, as are all other folders. Closing and reopening the browser doesn't fix it, and in fact after doing so it's set back to 'Custom,' which I would expect it to still be set to 'Tagged,' and if it were truly set back to 'Custom' the folder contents should be visible again, since changing the filter (e.g Tagged > All/Custom > Tagged) fixes it. And changing it from 'Custom' to 'Tagged' doesn't fix it, so I really think it's still set to 'Tagged' despite showing 'Custom' selected. Selecting 'Custom' (even though it appears to already be selected) also fixes it, also indicating it wasn't actually selected. I would expect it to keep the 'Tagged' setting across folders, but I'm always for providing options so users can make it behave the way they want. Also, you get the same behavior if, instead of moving from folder 1 to folder 2, you just tag images in folder one, close the browser, and reopen it. Same for exiting XnView entirely, or going into any other folder. IOW, you don't even need to tag images in two folders, just in one, then leave that folder in any way. Also, clicking on the funnel icon fixes it (seems to revert to either 'Custom' or 'All') but 'Tagged' is still selected.

And it gets worse. The same thing happens when you select other filters. For example, select 'Videos' or 'Archives' and then switch folders. 'Custom' will be selected but there will be nothing displayed. Switching it or clicking the icon again fixes it. What's more interesting is that if you select one of these other filters, go to a different folder, then go back to your folder with tagged images, NOW selecting 'Tagged' fixes it. Not sure if this has anything to do with it, but with any of the filters besides 'Tagged' when a folder is selected all the files show very briefly then disappear (they take half a second or so to be filtered out) and folders still show, but with the 'Tagged' filter not even folders show and the filtering (assuming that's what's happening, which I question since even tagged files aren't showing) is immediate, with no flash of files.

User avatar
XnTriq
Moderator & Librarian
Posts: 4819
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.84: Folder filter should reset when we change the fold

Postby XnTriq » Fri Feb 17, 2017 6:45 pm

vertigo wrote:I would expect it to keep the 'Tagged' setting across folders, but I'm always for providing options so users can make it behave the way they want.

FYI: Never is the default for Tags must be cleared in ToolsSettings...BrowserTag.

User avatar
xnview
Author of XnView
Posts: 27030
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Folder filter should reset when we change the fold

Postby xnview » Mon Feb 27, 2017 12:27 pm

O.k., thank you, I can also reproduce the problem. Issue 1116 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 27030
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Folder filter should reset when we change the fold

Postby xnview » Thu Mar 16, 2017 8:54 am

This problem is supposed to be fixed in XnView MP 0.85 beta 1. Please check and confirm the bug fix here.
Pierre.

vertigo
Posts: 106
Joined: Wed Feb 15, 2017 3:49 pm

Re: 0.84: Folder filter should reset when we change the fold

Postby vertigo » Thu Mar 16, 2017 10:25 am

Confirmed MOSTLY fixed.

There is still one small, pretty inconsequential bug: If you select any filter (videos, tagged, etc), then click the filter icon (not the arrow for the dropdown), it resets the filter and all files show again, but if you now click the dropdown arrow, you'll see it still shows the filter you selected as being active. It switches back to having custom selected once you change folders.

User avatar
helmut
Posts: 8084
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Folder filter should reset when we change the fold

Postby helmut » Sat Mar 18, 2017 8:41 am

vertigo wrote:Confirmed MOSTLY fixed.
Thank you for checking, vertigo. Before moving this to "Tested - Fixed" I'll wait for the feedback of the original poster (m.Th.).

vertigo wrote:There is still one small, pretty inconsequential bug: If you select any filter (videos, tagged, etc), then click the filter icon (not the arrow for the dropdown), it resets the filter and all files show again, but if you now click the dropdown arrow, you'll see it still shows the filter you selected as being active. It switches back to having custom selected once you change folders.
@Pierre: Should we create a new bug report or do you want to fix this as part of this problem?

User avatar
xnview
Author of XnView
Posts: 27030
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Folder filter should reset when we change the fold

Postby xnview » Sat Mar 18, 2017 2:49 pm

helmut wrote:
vertigo wrote:There is still one small, pretty inconsequential bug: If you select any filter (videos, tagged, etc), then click the filter icon (not the arrow for the dropdown), it resets the filter and all files show again, but if you now click the dropdown arrow, you'll see it still shows the filter you selected as being active. It switches back to having custom selected once you change folders.
@Pierre: Should we create a new bug report or do you want to fix this as part of this problem?

yes please, it's another bug
Pierre.

vertigo
Posts: 106
Joined: Wed Feb 15, 2017 3:49 pm

Re: 0.84: Folder filter should reset when we change the fold

Postby vertigo » Sat Mar 18, 2017 4:51 pm

Done

User avatar
helmut
Posts: 8084
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Folder filter should reset when we change the fold

Postby helmut » Sat Mar 18, 2017 7:33 pm

vertigo wrote:Done
Thank you, vertigo.

This bug report will reside in "Retest - 0.85" for a while to give the original poster (m.Th.) the chance to also confirm the bug fix.

User avatar
m.Th.
XnThusiast
Posts: 1338
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: 0.84: Folder filter should reset when we change the fold

Postby m.Th. » Sun Mar 19, 2017 11:25 am

fixed
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.84 64bit & XnView 2.00 x64 on Win7 x64 -


Return to “Closed/Resolved”

Who is online

Users browsing this forum: No registered users and 1 guest