0.48 Win7 x64: Clipboard glitch (Essential!) and other bug

Bugs that are confirmed but cannot be fixed for some reasons.

Moderators: XnTriq, xnview, Dreamer

BK201
Posts: 27
Joined: Fri Apr 06, 2012 3:43 pm

0.48 Win7 x64: Clipboard glitch (Essential!) and other bug

Postby BK201 » Tue Apr 24, 2012 2:00 pm

0. Exiting the program will erase anything in the clipboard

1. Cannot remember the custom toolbar setting

2. File said it's edited when undo all the changes (still a * mark on the file name)

User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: MP 0.48 Win7 x64 Clipboard glitch (Essential!) and other

Postby budz45 » Thu Apr 26, 2012 2:51 am

BK201 wrote:2. File said it's edited when undo all the changes (still a * mark on the file name)


Yes I have also myself discovered a similar or same bug regarding the ' * ' of unsaved view tab in which next/prev temporarily stops working...I am trying to make a reproduction for this bug
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

User avatar
xnview
Author of XnView
Posts: 27349
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.48 Win7 x64 Clipboard glitch (Essential!) and other

Postby xnview » Wed May 09, 2012 9:56 am

BK201 wrote:0. Exiting the program will erase anything in the clipboard

Currently a bug with Qt, i contact them...

1. Cannot remember the custom toolbar setting

I can't reproduce, you load your toolbar file, and not restored at next startup?

2. File said it's edited when undo all the changes (still a * mark on the file name)

Ok, right
Pierre.

raina
Posts: 2
Joined: Wed Jan 18, 2017 8:32 am

Re: MP 0.83 Win10 x64 Clipboard wipe on exit

Postby raina » Wed Jan 18, 2017 8:38 am

xnview wrote:
BK201 wrote:0. Exiting the program will erase anything in the clipboard

Currently a bug with Qt, i contact them...


Has anything happened with this? Just ran into the issue with current versions of XnViewMP and Windows.

JMM72
Posts: 26
Joined: Wed Feb 10, 2016 2:16 pm

Re: MP 0.48 Win7 x64 Clipboard glitch (Essential!) and other

Postby JMM72 » Wed Jan 18, 2017 2:54 pm

This doesn't happen with current 0.83 64bit under Win7. Actually the clipboard is untouched on exit since I started using XnView and switched to XnViewMP around 0.6x, so I guess you better give more indications about your version, environment, and how do you trigger the bug, and if it ever doesn't trigger.

raina
Posts: 2
Joined: Wed Jan 18, 2017 8:32 am

Re: MP 0.83 Win10 x64 Clipboard wipe on exit

Postby raina » Thu Jan 19, 2017 12:37 pm

JMM72 wrote:I guess you better give more indications about your version, environment, and how do you trigger the bug, and if it ever doesn't trigger.

Thanks for your reply, I'll gladly provide. I'm running MP 0.83 x64 on Windows 10 Pro x64. I've been unable to NOT trigger the bug, the clipboard is cleared reliably every time MP exits.

Steps to reproduce:
  1. Copy an image to clipboard.
  2. Pasting to other programs (IrfanView, GIMP) works.
  3. Start XnView MP.
  4. (Pasting to XnView MP and other programs still works. This step doesn't matter in terms of being able to reproduce the bug.)
  5. Exit XnView MP.
  6. Pasting to other programs (or a reopened XnView MP) no longer works.

User avatar
xnview
Author of XnView
Posts: 27349
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.83 Win10 x64 Clipboard wipe on exit

Postby xnview » Thu Jan 19, 2017 1:19 pm

raina wrote:Steps to reproduce:
  1. Copy an image to clipboard.
  2. Pasting to other programs (IrfanView, GIMP) works.
  3. Start XnView MP.
  4. (Pasting to XnView MP and other programs still works. This step doesn't matter in terms of being able to reproduce the bug.)
  5. Exit XnView MP.
  6. Pasting to other programs (or a reopened XnView MP) no longer works.

currently this problem is not resolved in QT API
Pierre.

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: MP 0.83 Win10 x64 Clipboard wipe on exit

Postby helmut » Tue Feb 21, 2017 10:58 pm

xnview wrote:... currently this problem is not resolved in QT API

Thank you for the info, Pierre. The original poster and I consider this quite essential, so I put it on the list of Must fixes. Would be good if The Qt Company would provide a fixed version of Qt, soon.


Return to “Postponed”

Who is online

Users browsing this forum: No registered users and 1 guest