MacOS: Add HiDPI format/ Retina support

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

User avatar
xnview
Author of XnView
Posts: 27084
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Request : add HiDPI format/ Retina support

Postby xnview » Wed May 25, 2016 8:55 am

raysar wrote:Est-ce que vous avez le temps de trouver une solution?

j'espere trouver une solution pour la prochaine version
Pierre.

grgr
Posts: 14
Joined: Tue Apr 07, 2015 3:42 pm

Re: Request : add HiDPI format/ Retina support

Postby grgr » Fri Jul 01, 2016 5:40 pm

xnview wrote:j'espere trouver une solution pour la prochaine version


Still no changes (0.80 & 0.81)?

User avatar
xnview
Author of XnView
Posts: 27084
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Request : add HiDPI format/ Retina support

Postby xnview » Fri Jul 01, 2016 7:31 pm

grgr wrote:
xnview wrote:j'espere trouver une solution pour la prochaine version

Still no changes (0.80 & 0.81)?

i have some problem for a full support...
Pierre.

raysar
Posts: 11
Joined: Sat May 30, 2015 8:24 pm

Re: Request : add HiDPI format/ Retina support

Postby raysar » Sat Oct 22, 2016 5:45 am

Hello :p I come back here.

XnviewMP for mac 0,83 always don't support retina display for images. (image resolution is divided by 4)

Have you find a solution to implement it?
Which QT version is used on XNviewMP?
http://stackoverflow.com/questions/3446 ... t5-on-os-x

Without retina support it's unusable on retina display :/

Thank you.

example on 2650*1600 pixel display in retina mode (1280*800)
http://reho.st/self/5135c559a9a89b4443a ... c2d691.jpg

OmarTheBest
Posts: 3
Joined: Wed Oct 26, 2016 8:31 pm

Re: Request : add HiDPI format/ Retina support

Postby OmarTheBest » Wed Oct 26, 2016 8:38 pm

I must say this is really important feature. I love this program and as someone here already pointed out it doesn't have competition. I can confirm that becaus recently because of that retina support missing I downloaded ACDSee demo to try it as an alternative and find out that their software is not compatible with MacOS Sierra and basically unusable (it was about two weeks after the release of the gold version, not any beta testing or so).
So I wish the feature will soon finds its way to the software and make it awesome again!

User avatar
xnview
Author of XnView
Posts: 27084
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Request : add HiDPI format/ Retina support

Postby xnview » Wed Mar 08, 2017 9:07 am

Issue 902 is fixed in next version.
Pierre.

andrelmsantos
Posts: 6
Joined: Sun Aug 10, 2014 6:05 pm

Re: Add HiDPI format/ Retina support

Postby andrelmsantos » Wed Mar 08, 2017 11:20 am

Great news! I'm eager to check the next version then! Let's cross our fingers!

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Add HiDPI format/ Retina support

Postby helmut » Wed Mar 08, 2017 11:26 am

andrelmsantos wrote:Great news! I'm eager to check the next version then! Let's cross our fingers!
Would be great if you could verify the bug fix, andrelmsantos.

@Pierre: Looks like we'll need a test version on MacOS...

User avatar
xnview
Author of XnView
Posts: 27084
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Add HiDPI format/ Retina support

Postby xnview » Thu Mar 16, 2017 8:43 am

This problem is supposed to be fixed in XnView MP 0.85 beta 1. Please check and confirm the bug fix here.
Pierre.

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Add HiDPI format/ Retina support

Postby helmut » Mon Mar 20, 2017 5:00 pm

I guess this can be checked on a MacOS with Retina display, only. There's no beta version for MacOS, though.

grgr
Posts: 14
Joined: Tue Apr 07, 2015 3:42 pm

Re: MacOS: Add HiDPI format/ Retina support

Postby grgr » Mon Mar 27, 2017 12:28 pm

Check the new beta: viewtopic.php?f=93&t=35218

It fixed the issue on my retina macbook.

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: MacOS: Add HiDPI format/ Retina support

Postby helmut » Mon Mar 27, 2017 8:23 pm

Thank you for your checking and confirming the bug fix, grgr.

This bug report will be closed once 0.85 final is available. I've split your problem/suggestion regarding the small 100% view for further discussion and handling into a sperate topic, see viewtopic.php?t=35269

andrelmsantos
Posts: 6
Joined: Sun Aug 10, 2014 6:05 pm

Re: MacOS: Add HiDPI format/ Retina support

Postby andrelmsantos » Fri Apr 07, 2017 6:23 pm

helmut wrote:Thank you for your checking and confirming the bug fix, grgr.

This bug report will be closed once 0.85 final is available.


Edited: At first I thought the bug remained as the 100% view still showed pixelated images. But now I checked the HiDPI option and it's great!
Perfect job you guys! My next step now is purchasing a 26€ licence.

Way to go! Thanks!

OmarTheBest
Posts: 3
Joined: Wed Oct 26, 2016 8:31 pm

Re: MacOS: Add HiDPI format/ Retina support

Postby OmarTheBest » Wed Apr 12, 2017 4:33 pm

Thanks for the fix, but it still doesn't work in the full-screen view. Otherwise it seems it works well. Also for some reason my Tool Bar keeps turning itself off.
Edit: Ok, so it also doesn't work on a second monitors. When I moved XnView on my HDPi monitor, the quality of the picture got back to LDPi.
Edit2: Ok so it seems the problem occures when the picture reach or surpass 100% of its size. Then it somehow switches to LDPi again. But when its only 99% it is still smooth and HDPi. Might also be the same problem with the full screen since I was testing only pictures, which would go over 100% when shown full screen

User avatar
xnview
Author of XnView
Posts: 27084
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MacOS: Add HiDPI format/ Retina support

Postby xnview » Thu Apr 13, 2017 8:43 am

OmarTheBest wrote:Thanks for the fix, but it still doesn't work in the full-screen view. Otherwise it seems it works well. Also for some reason my Tool Bar keeps turning itself off.
Edit: Ok, so it also doesn't work on a second monitors. When I moved XnView on my HDPi monitor, the quality of the picture got back to LDPi.
Edit2: Ok so it seems the problem occures when the picture reach or surpass 100% of its size. Then it somehow switches to LDPi again. But when its only 99% it is still smooth and HDPi. Might also be the same problem with the full screen since I was testing only pictures, which would go over 100% when shown full screen

yes a known issue
Pierre.


Return to “Closed/Resolved”

Who is online

Users browsing this forum: No registered users and 1 guest