confusion under XGL/compiz-fusion/KDE

Questions, suggestions, and answers for XnView on all Un*x platforms (Linux, HP-UX, AIX, ...)

Moderators: helmut, XnTriq, xnview

confusion under XGL/compiz-fusion/KDE

Postby compiz-fusion-user » Wed Aug 22, 2007 12:49 pm

Howdy XNview-Crew :)

First of all I have to thank you for your great job. Been using XNview for years now, both
on Windows- and Linux-Systems.

Now I took off for XGL & compiz-fusion & KDE & ATI-fglrx driver on OpenSUSE 10.2.
Unfortunately XNview is almost unuseable on this constellation. The whole GUI is
somehow transparent and looks like small resolution, the pictures to be viewed are kind
transparent, one can see the background and background-apps shinning through.

To verify this I also installed openSuse 10.2 x86_64 on my Desktop-PC yesterday.
Again with XGL & compiz-fusion & KDE & ATI-fglrx driver. Just downloaded XNview .rpm,
installed and kicked it off...looks like this again:

XNview - http://freenet-homepage.de/alienjones/x ... photo1.png
XNview-Browser - http://freenet-homepage.de/alienjones/x ... photo2.png

This is my setup:
Code: Select all
XnView-1.70-1
xgl-cvs_060522-39
xgl-hardware-list 060526-33
kdebase3-3.5.5-102.6
compiz 0.5.2-17.1
compiz-bcop 0.5.2-2.1
compizconfig-settings-manager 0.5.2-10.1
compiz-emerald 0.5.2-6.2
compiz-emerald-themes 0.5.2-2.1
compiz-fusion-plugins-extra 0.5.2-6.4
compiz-fusion-plugins-main 0.5.2-7.1
compiz-fusion-plugins-unsupported 0.5.2-5.1
compiz-kde 0.5.2-17.1
libcompizconfig 0.5.2-5.2
libcompizconfig-backend-kconfig 0.5.2-2.2
python-compizconfig 0.5.2-4.2

#fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series
OpenGL version string: 1.2 (2.0.6747 (8.40.4))


Best regards from Germany

Sascha
compiz-fusion-user
 

Postby Bull-DoG » Tue Sep 18, 2007 8:33 pm

Same problem.
OpenSUSE 10.2 [ 2.6.18.8-0.5-default ]

Latest Compiz, KDE, nvidia drivers

XnView 1.70

All colours except white - transparent =(
Image
Bull-DoG
 
Posts: 1
Joined: Tue Sep 18, 2007 7:50 pm

Postby duke74 » Wed Oct 10, 2007 5:20 pm

hello (Bonne soir a tous)
i've managed to get it working under beryl
by using XnView-openmotif2.2.i386.rpm (v1.68 )
on PclinuxOS 2007 kernel 2.6.18.8.tex5
with nvidia 96xx drivers
Code: Select all
OpenGL version string: 1.5.8 NVIDIA 96.39

with openmotif 2.3.0,package: openmotif-2.3.0-1pclos2007
needed to symlink
ln -s /usr/lib/libXm.so.4.0.0 /usr/lib/libXm.so.3
at first there was transparent areas but after
xnview -help
Code: Select all
[homer@localhost]$ xnview -help
** XnView v1.68.1 Copyright 1991-2004 Pierre-E Gougelet (Feb 18 2004/15:44:44) **
        Version for Linux x86/Motif (All rights reserved)
** This is freeware software (for non commercial use)

Usage : xnview [options] file ...
        Options :
          -visualid <id> : Use this visual number
              Visual available :
                0x21 : TrueColor       /  24 planes
                0x22 : DirectColor     /  24 planes
                0x24 : TrueColor       /  24 planes
                0x25 : TrueColor       /  24 planes
                0x26 : TrueColor       /  24 planes
                0x27 : TrueColor       /  24 planes
                0x28 : TrueColor       /  24 planes
                0x29 : TrueColor       /  24 planes
                0x2a : TrueColor       /  24 planes
                0x2b : TrueColor       /  24 planes
                0x2c : TrueColor       /  24 planes
                0x2d : TrueColor       /  24 planes
                0x2e : TrueColor       /  24 planes
                0x2f : TrueColor       /  24 planes
                0x30 : TrueColor       /  24 planes
                0x31 : TrueColor       /  24 planes
                0x32 : TrueColor       /  24 planes
                0x33 : DirectColor     /  24 planes
                0x34 : DirectColor     /  24 planes
                0x35 : DirectColor     /  24 planes
                0x36 : DirectColor     /  24 planes
                0x37 : DirectColor     /  24 planes
                0x38 : DirectColor     /  24 planes
....etc...... 

i've started xnview with cmdline:
xnview -visualid 0x21
and the result is:
Image

Image

Image

its great program !please continue linux development
duke74
 
Posts: 3
Joined: Wed Oct 10, 2007 12:01 pm

Postby duke74 » Wed Oct 10, 2007 10:11 pm

aparently v1.70 static also working on pslos 2007 & beryl

Image

using same command line

./xnview -visualid 0x21

(i'm not shure if screen capture is working and there are some
minor glitches about scrollbars)
duke74
 
Posts: 3
Joined: Wed Oct 10, 2007 12:01 pm

Postby timebomb » Thu Oct 11, 2007 9:53 pm

starting it with

XLIB_SKIP_ARGB_VISUALS=1 xnview

should actually do the trick with any transparent window application.

anyway looking forward to the qt alpha.
timebomb
 
Posts: 1
Joined: Thu Oct 11, 2007 9:48 pm

opensuse 10.3 xnview OK ?

Postby terryxela » Thu Oct 18, 2007 12:12 pm

I had the same problem as all of you with xnview 1.70 linux and opensuse 10.2 running beryl both, in a system with intel video chip and in another one with nvidia 8800 series.

Now I installed opensuse 10.3 (32b) with compiz-fusion in an intel video chip system; XnView-static-fc4.i386.rpm is working very well. I just load it
$ xnview

As soon as I install opensuse 10.3 (64b) in the system with nvidia 8800 I will post it.

For me is a great news to have xnview linux running until the new version comes. Yes the windows version runs well under crossover (wine) but I did not use it as a default image program as I had it with the linux version, just use it once in a while. Now I can install it as default again.

-=terry(Denver)=-
terryxela
 
Posts: 7
Joined: Wed May 23, 2007 1:02 pm

Postby terryxela » Fri Oct 19, 2007 3:24 am

Guy,

I feel embarrassed about my previous message. Xnview under compiz-fusion has the problems as described. I was running the windows version under wine. So forget about the previous message.
-=terry=-
terryxela
 
Posts: 7
Joined: Wed May 23, 2007 1:02 pm


Return to XnView Un*x

Who is online

Users browsing this forum: No registered users and 1 guest