XnView can't read my .icl files

Questions, suggestions, and answers for XnView on all Un*x platforms (Linux, HP-UX, AIX, ...)

Moderators: helmut, XnTriq, xnview

XnView can't read my .icl files

Postby Seldon2k » Fri Jul 29, 2011 10:48 pm

Hi,
I have recently installed openSuSE v11.4 and while modifying the menu I needed to change a folders icon.
I then searched for some suitable icons and found them in an Icon Library.
I then realised that this distro didn't didn't contain an App to open the .icl files.
After a little research I discovered XnView and installed it from the RPM file.

I then tested it on some existing icon files and it displayed them correctly.
The problem I have is that every time I try to browse to an .icl Icon Library I get the following error message.
Don't know how to read
</home/user/path/filename.icl>
This is in the form of a Dialogue Box labelled 'Confirmation' with an OK button after the above text.

I hope this is some silly configuration issue as after hours of research I seem to be the only one with this problem.
I look forward to any help you can give,
Terry.

PS.
The openSuSE is 64 Bit running on an Intel I7 machine.
When I click on the OK, the icl file is displayed as a Hex file in a Box labelled 'Dump'
Just in case I had a corrupt or false icl file I downloaded another to test and this gave the same results.
Seldon2k
 
Posts: 2
Joined: Fri Jul 29, 2011 10:13 pm

Re: XnView can't read my .icl files

Postby XnTriq » Sat Jul 30, 2011 1:30 am

User avatar
XnTriq
Moderator & Librarian
 
Posts: 4744
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: XnView can't read my .icl files

Postby Seldon2k » Sat Jul 30, 2011 4:43 pm

Hi,
Thanks for bringing XnView MP 0.35 Beta to my attention.
I have removed my XnView 1.7 and installed XnView MP.
Well I say Installed, there was no RPM available so I had to open the archive and extract it to a convenient location.
I then edited the .desktop file to show the path and copied it to /usr/share/applications.
This seemed not to integrate it as I was expecting so I had to resort to running xnview.sh from a console.
This worked and the App launched.
I then browsed using the App to the folder containing Icons, these were correctly displayed, as the old XnView did.
I then browsed to the two .icl files and found that it treated them both as Text files.
No Images were shown in the preview area or under the test details on the lower left.
Clicking on the icl then launched the Internet Browser?

Al assistance gratefully received,
Terry.

P.S. I have just found the 'problems with OpenSuSE 11.4 thread' and have proceeded to download the missing 64 bit libraries.
These have been copied to the lib folder under XnView MP, now when I click on the .icl file it first says no associated file then when I click cancel
it launches and presents a plain white window that when I click on it then clears and shows XnView MP.
I then use this to brows to the icons and all is well, but it still refuses to handle .icl files with the same results as mentioned above.
Seldon2k
 
Posts: 2
Joined: Fri Jul 29, 2011 10:13 pm

Re: XnView can't read my .icl files

Postby XnTriq » Sat Jul 30, 2011 8:45 pm

Seldon2k wrote:These have been copied to the lib folder under XnView MP, now when I click on the .icl file it first says no associated file then when I click cancel it launches and presents a plain white window that when I click on it then clears and shows XnView MP.
I then use this to brows to the icons and all is well, but it still refuses to handle .icl files with the same results as mentioned above.

Terry, have you tried to view the file via File » Open?
(I'm not a Linux user, so don't know about the specifics of your OS.)
User avatar
XnTriq
Moderator & Librarian
 
Posts: 4744
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk


Return to XnView Un*x

Who is online

Users browsing this forum: No registered users and 1 guest