2.39: sort by exif date not working

Ask for help and post your question on how to use XnView Classic.

Moderators: helmut, XnTriq, xnview

2.39: sort by exif date not working

Postby midnightrambler » Sat Feb 04, 2017 10:34 pm

Some of my pictures are not sorting correctly when using "sort by EXIF date" in 2.39, and I can't figure out the precise source of the problem. The jpgs that were created from RAW files (using Canon's DPP) are arranged first together, while the RAW files themselves and the out-of-camera JPGs sort in the correct order. This seems to have happened only after I used ExifToolGUI to adjust the time (I had my camera's clock set wrong). However, they all sort correctly in both XnViewMP and Windows Explorer (using "Date Taken"), and I don't see any error introduced in the EXIF data (and other pics exported from DPP but without the EXIF modified also sort correctly), which makes me think there's some kind of incompatibility between XnView Classic and ExifTool.

Any ideas? I tried re-exporting from DPP and it still comes out in the wrong place, as do JPGs created from the same RAW file in Photoshop.
midnightrambler
 
Posts: 2
Joined: Sat Feb 04, 2017 10:22 pm

Re: sort by exif date not working

Postby midnightrambler » Sat Feb 04, 2017 11:45 pm

The mystery deepens - after resaving the pictures (using batch process, which I do because XnView does a far better job of compression than DPP), they now sort correctly. I guess that's one way to fix it, but even more baffling why it didn't work in the first place. It should be simply leaving the metadata as is when saving, no?
midnightrambler
 
Posts: 2
Joined: Sat Feb 04, 2017 10:22 pm

Re: sort by exif date not working

Postby XnTriq » Mon Feb 06, 2017 1:00 am

Welcome to the forum, midnightrambler.

Could you provide a sample?
The limit for attachments on the forum is currently at 2 MiB, but you can share larger files through a free hosting service (like WikiFortio or Wikisend).
User avatar
XnTriq
Moderator & Librarian
 
Posts: 4733
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: sort by exif date not working

Postby Philly5 » Sat Mar 18, 2017 12:11 pm

Unfortunately as a new user -- who would dearly wish to like XnView -- I'm completely baffled by this image sorting business. I wish to view image files in date order because that's the way I have them appear in Windows Explorer: "Date Created". When I click on an image file in that "Date created" Windows Explorer folder view on my Windows 7 PC, XnView certainly opens it -- but then, when I click on the righthand arrow to go forward, the next image to pop up isn't in sequence at all.

I can't find any way of accessing the simple, elementary sorting mechanism as found in everything from Irfanview to Faststone to Jpegger, each of which has an instantly available basic menu with options to sort by date, sort by size, sort by name, etc etc. I have XnView build 2.39, November 8, 2016. When I click on "View" in the top menu bar, a drop down list shows only the following:

Fullscreen
Auto Image Size
Real size
Zoom+
Zoom-
Lock Zoom
Zoom
File
Page
Video
Use transparent index
Use alpha channel
Show Mask
Show Grid
Grid settings
Show information
Stop Animation
Pause Animation
Tabs
Tool Bar
Status Bar
Display Colour Information

No mention at all of "Sort" in those options, yet the sorting -- the sequencing -- of viewed files in the order which the computer user wishes to see them, whether by name or date or size, is surely so important that I'd have expected it to be at the top of that list.

Help appreciated, because I'm finding this all very frustrating.
Philly5
 
Posts: 2
Joined: Sat Mar 18, 2017 11:47 am

Re: sort by exif date not working

Postby cday » Mon Mar 20, 2017 8:48 pm

@Philly5 :

Your problem is that sort options are in the Browser View menu, and you are looking in the Viewer View menu...

Depending on how your copy of XnView is configured, you may have a tab labeled 'Browser' you can click on to open the Browser, or possibly an icon at the left end of the toolbar, I'm not entirely sure of the default installation.
cday
XnThusiast
 
Posts: 1330
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: 2.39: sort by exif date not working

Postby Philly5 » Tue Mar 21, 2017 6:01 pm

@cday: BIG thanks for that . . . I wasn't aware of the browser options as I never use a browser when dealing with images: simply double click on an image and the default app then opens, etc etc. Thanks so-oo much for your help. I've 'sorted' my preferences now and hopefully, all will be well again. Again: many thanks!
Philly5
 
Posts: 2
Joined: Sat Mar 18, 2017 11:47 am


Return to Classic - General Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron