Newbie question: some PNGs don't show up in XnView browser?

Ask for help and post your question on how to use XnView Classic.

Moderators: helmut, XnTriq, xnview

Newbie question: some PNGs don't show up in XnView browser?

Postby arrivest » Sat Mar 11, 2017 12:04 am

Hello, I'm sorry if this question has been asked before. I discovered it by accident: I have a folder with 3 JPGs and 6 PNGs, but XnView 2.39's browser only shows 3 JPGs and 3 PNGs, the other 3 PNGs seem to be "hidden". (They aren't set to hidden as far as my Win10 is concerned).

The View Mode also displays only the 6 pictures when I cycle through them, however, I am able to open the "hidden" files by double clicking them in Win10 (XnView is my default picture viewer). Once I do that, I'm able to cycle through all 9 pictures. But if I return to browse mode, it's back to 6 again.

So what's my problem? Thanks!

I could upload the problematic PNGs if necessary.
arrivest
 
Posts: 4
Joined: Fri Mar 10, 2017 9:14 pm

Re: Newbie question: some PNGs don't show up in XnView brows

Postby XnTriq » Sat Mar 11, 2017 2:45 am

Welcome to the forum, arrivest.

What is you configuration for ViewFilter By?
User avatar
XnTriq
Moderator & Librarian
 
Posts: 4732
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Newbie question: some PNGs don't show up in XnView brows

Postby arrivest » Mon Mar 13, 2017 7:56 pm

Thanks XnTriq.
It's always been set to Filter by Images. I tested other filters after seeing your reply. If set to All, it does show all 9 images. If set to Images, then it shows 6. If set to any of the rest filters, it shows no files, which means the 3 missing PNGs are not videos, sounds, or archives.
arrivest
 
Posts: 4
Joined: Fri Mar 10, 2017 9:14 pm

Re: Newbie question: some PNGs don't show up in XnView brows

Postby XnTriq » Mon Mar 13, 2017 10:15 pm

arrivest wrote:If set to All, it does show all 9 images. If set to Images, then it shows 6. If set to any of the rest filters, it shows no files, which means the 3 missing PNGs are not videos, sounds, or archives.

Please try deactivating Recognize only by extension (ToolsOptions...File ListMisc.).
Note: You'll have to point the browser to another folder for this setting to take effect.

Could you please post a screenshot of your settings in ToolsOptions...File ListFile ListCustom files, if that doesn't help?
User avatar
XnTriq
Moderator & Librarian
 
Posts: 4732
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Newbie question: some PNGs don't show up in XnView brows

Postby arrivest » Mon Mar 13, 2017 10:26 pm

Thanks very much XnTriq. Deactivating "recognize only by extension" does help!

What's the reason for that? My PNGs didn't have strange file names. They were just xxxxxxx.PNG
arrivest
 
Posts: 4
Joined: Fri Mar 10, 2017 9:14 pm

Re: Newbie question: some PNGs don't show up in XnView brows

Postby XnTriq » Mon Mar 13, 2017 10:45 pm

arrivest wrote:What's the reason for that?

Sometimes images have a wrong file name extension: Your PNGs might in fact be JPEGs or GIFs.
Deactivating Recognize only by extension forces XnView to identify the image format by scanning the file header for a signature. This slows down thumbnail generation slightly.

Requests for automatically renaming files with wrong extensions: Classic | MP
User avatar
XnTriq
Moderator & Librarian
 
Posts: 4732
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Newbie question: some PNGs don't show up in XnView brows

Postby arrivest » Mon Mar 13, 2017 10:51 pm

Thanks!
arrivest
 
Posts: 4
Joined: Fri Mar 10, 2017 9:14 pm

Re: Newbie question: some PNGs don't show up in XnView brows

Postby XnTriq » Mon Mar 13, 2017 11:00 pm

You're welcome :-)
User avatar
XnTriq
Moderator & Librarian
 
Posts: 4732
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk


Return to Classic - General Support

Who is online

Users browsing this forum: No registered users and 1 guest