Page 1 of 1

Can't Open Files with Some Special Characters

PostPosted: Fri Jun 07, 2013 4:54 am
by realnabarl
When I opening an image with filename include a ”・” (Unicode Character 'KATAKANA MIDDLE DOT', U+30FB), it told me "error opening file <*.jpg>".
Can you fix this?

System: Win7 32-bit Simplified Chinese

Re: Can't Open Files with Some Special Characters

PostPosted: Fri Jun 07, 2013 6:47 am
by cday
XnView doesn't support Unicode.

XnViewMP and XnConvert -- both under development -- are cross-platform with Unicode support and so can be used if they have the functions you need.

Re: Can't Open Files with Some Special Characters

PostPosted: Wed Jul 03, 2013 6:51 am
by EuM_Expert
I am encountering the same problem at the moment.
Double-Clicking an Image file with Chinese Characters in its path from Windows Explorer brings up an xnView dialog with an error message that contains the ????? characters where the Chinese Characters should be.

This effect just happens on one computer!
The next computer handles it perfectly well and opens the same file.

Both Computers Win7 with German, English and Chinese Language installed, xnview 2.03 Full Version.

The problem is definitely not xnView itself, otherwise the first computer would not display the file.
Some system setting concerning language must be different on the second computer, which causes the problem.
Bot computers display chinese Characters well in the explorer, etc.
The problem must be located from the handler in windows explorer, which handsover the path to xnview. There the Chinese Characters are translated into ??????.

Any hint would be great to receive.
thanks.

Re: Can't Open Files with Some Special Characters

PostPosted: Thu Jul 04, 2013 10:10 am
by xnview
Only XnViewMP has native unicode support

Re: Can't Open Files with Some Special Characters

PostPosted: Fri Jul 05, 2013 8:35 pm
by manu_4bb9a
Is Xnview not MP aborted ?
Cause i've the same problem with that name : "eau 1∕2".
It's not a / but a ∕

Re: Can't Open Files with Some Special Characters

PostPosted: Mon Mar 20, 2017 4:26 pm
by stormy1777
Found via search, hit the same issue, in my case solution was go into Control Panel, Language Settings (region and language, etc.) click the ADMINISTRATIVE tab, click "Change system locale..." there it says:

"select which language (System locale) to use when displaying text in programs to do not support unicode."

select the local language here, click OK, reboot if needed, and xnview now able to open all the files it did not before. This also explains why it works on some PCs and not on others :)