UNC does not work in browser

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

HansS
Posts: 5
Joined: Sun Oct 02, 2011 6:27 pm

UNC does not work in browser

Postby HansS » Thu Jan 19, 2017 9:43 pm

I can start XnView browser for UNC path like \\Nbk-hs1\Backup\Pictures, but in the folder tree nothing of the UNC path is visible (and the tree jumps to top and nothing is selected). Some hosts are not shown under "Network", but even for shown hosts the tree does not jump to opened UNC folder - although Windows explorer and e.g. FreeCommander have no problem to show UNC same folders in there folder tree. I found some hint on ExpandUNC, so there may be an option to turn folder tree for UNC off or on, but could not find any option - did I miss something, or is this an error in XnView?

XnView v2.39, Win7-64-Ult-SP2

User avatar
XnTriq
Moderator & Librarian
Posts: 4904
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: UNC does not work in browser

Postby XnTriq » Fri Jan 20, 2017 12:45 am

HansS wrote:I found some hint on ExpandUNC, so there may be an option to turn folder tree for UNC off or on, but could not find any option - did I miss something, or is this an error in XnView?

  1. Go to Info » About... to find the INI file location.
  2. Quit XnView.
  3. Open xnview.ini in a text editor. (Windows Notepad will do.)
  4. Go to the [Browser] section and add the following lines:

    Code: Select all

    ExpandUNC=1
  5. Save the changes.
  6. Restart XnView.
XnViw Wiki (UI-less Settings » Browser) wrote:
    CheckNetFolder
      When enabled, XnView will check if subfolders exist on network drives when updating the folder tree pane in XnView's browser.
      Value: Boolean (1/0), disabled by default
      Regression ==> viewtopic.php?t=11011
      See also ExpandUNC setting
    ExpandUNC
      When enabled, XnView always expands UNC network paths in the folder tree pane in XnView's browser.
      Value: Boolean (1/0), disabled by default
      See also CheckNetFolder setting


Return to “Classic - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest