Slide Show crashes with recent Canon RAW files

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

DeusExMamiya
Posts: 8
Joined: Wed Jun 16, 2010 1:11 pm

Slide Show crashes with recent Canon RAW files

Postby DeusExMamiya » Tue Jan 24, 2017 3:17 pm

Hi,

I'm using the very latest version 2.39 of Xnview, but this has been a bug for a few versions, and on three different Windows 7/Windows 10 machines that I use.

To reproduce the bug:
Tools -> Create -> Slide Show -> Add Folder -> pick a folder containing Canon .CR2 raw & jpg files (I use an EOS 5DII) -> Go
...results in either an instant crash, or it will show a few images and then crash: "XnView for Windows has stopped working". A typical crash report is appended below.

You can see for yourself that it happens with even just a single RAW file in the folder. Here is a dropbox link to a zipped example folder which crashes for me (containing just 1 RAW file and the corresponding JPG file):
https://dl.dropboxusercontent.com/u/741 ... Layout.zip

There are two weird things about this:
(1) The images themselves are always fine, and can be viewed in Xnview. They only trip up the Slide Show mode.
(2) It only seems to happen on folders of images that were taken in the past year and a half, or so. Older ones from the same 5DII are ok, and all folders from my other cameras (Fuji, Kodak etc.) are also ok.

I ran a disk check to make sure that the filesystem structure was ok. In any case, the crashes occur with both an internal HDD and a separate copy of the folders on an external drive; it's very unlikely that both have the same corruption.

Ray


++++++++

Problem signature:
Problem Event Name: APPCRASH
Application Name: xnview.exe
Application Version: 2.39.0.0
Application Timestamp: 58218879
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.1.7601.23572
Fault Module Timestamp: 57fd0379
Exception Code: c0000091
Exception Offset: 0000c54f
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid= ... cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

User avatar
xnview
Author of XnView
Posts: 27580
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slide Show crashes with recent Canon RAW files

Postby xnview » Wed Jan 25, 2017 9:04 am

right i'll check
Pierre.

DeusExMamiya
Posts: 8
Joined: Wed Jun 16, 2010 1:11 pm

Re: Slide Show crashes with recent Canon RAW files

Postby DeusExMamiya » Fri Jun 09, 2017 1:37 pm

Hi PIerre,

Any progress with fixing this bug? It's been several months, so I thought I would check in about it.

Thanks,
Ray

User avatar
xnview
Author of XnView
Posts: 27580
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slide Show crashes with recent Canon RAW files

Postby xnview » Sat Jun 10, 2017 4:42 pm

Always the crash with lastest version? could you send me again the file?
Pierre.

DeusExMamiya
Posts: 8
Joined: Wed Jun 16, 2010 1:11 pm

Re: Slide Show crashes with recent Canon RAW files

Postby DeusExMamiya » Tue Jun 13, 2017 9:11 am

Yes, it is still crashing, with the latest version (2.40) on Windows 7.

Here is the Canon test image again:
https://www.dropbox.com/s/eky2mpnkei68lb0/2016_12_24_XmasLayout.zip?dl=0

It seems to be a problem with RAW files in general? Because I found that the Slideshow also has problems with Kodak (.DCR) and Fujifilm (.RAF) raw files (.RAF). These are the patterns of behaviour that I observed:

  • If I ask it to run a slideshow from a folder containing ONLY jpg files, it works fine.
  • If I ask it to run a slideshow from a folder containing ONLY .DCR or .RAF raw files, it does nothing (the slideshow doesn't even start when I click "Go")
  • If I ask it to run a slideshow from a folder containing ONLY .CRW files, it immediately crashes (goes directly to "Xnview for Windows has stopped working")
  • If I ask it to run a slideshow from a folder containing a MIX of .RAF and jpg files, it hangs before displaying the first photo; clicking onto it brings up "Xnview for Windows has stopped working".
  • If I ask it to run a slideshow from a folder containing a MIX of .DCR and jpg files, it works fine - but only displays the jpgs; it ignores the .DCR files.
  • If I ask it to run a slideshow from a folder containing a MIX of .CRW and jpg files, it works fine for a few jpgs; then crashes (goes directly to "Xnview for Windows has stopped working"), presumably on its first encounter with a .CRW file.

DeusExMamiya
Posts: 8
Joined: Wed Jun 16, 2010 1:11 pm

Re: Slide Show crashes with recent Canon RAW files

Postby DeusExMamiya » Tue Jun 13, 2017 9:16 am

BTW, an alternative and probably quick solution, would be to bypass the problem by adding an option, "Exclude RAW files", in the "More Options" section of Slide Show.

Even if the bug was not there, that is actually something I'd prefer to use: after all, in a slideshow, we want to see nicely finished images, not RAW ones.


Return to “Classic - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest