Inaccessible editing functions

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

blinkenlight
Posts: 2
Joined: Sun Feb 26, 2017 6:08 pm

Inaccessible editing functions

Postby blinkenlight » Sun Feb 26, 2017 6:28 pm

I have a problem where the "Adjust brightness/contrast/gamma/balance" dialog is appearing only partially (wrong window size) resulting in inability to use those functions due to them not being visible at all / the "ok" button being inaccessible. This is a huge problem for me since I normally use those functions all the time with my photo collection. This is what it looks like:

Cap1.bmp
Cap1.bmp (826.14 KiB) Viewed 320 times


Other dialogs (like the very similar "Adjust Hue/Lightness/Saturation" dialog) don't seem to have this problem at all:

Cap2.bmp
Cap2.bmp (1.26 MiB) Viewed 320 times


I suspect this may have something to do with that specific dialog's code not being adapted to accomodate screen sizing - I have a FullHD monitor that I have to set at "Medium - 125%" zoom in display preferences in order to read it at all. No other programs seem to have any issues due to this, indeed most of XnView's dialogs work fine too - except that one specific but very important exception. I'm running on Windows 7 ultimate SP1, where XnView had this problem right from the start. My previous XP SP2 OS didn't seem to trigger the same issue, but I had to move on and my current OS definitely triggers it. My XnView version is 2.39. Setting zoom back to 100% on a HiDPI monitor like this is not an option, unfortunately neither is using XnView without a brightness / contrast / balance function. This is most likely a trivial issue, but a fix would be very much appreciated indeed...

User avatar
xnview
Author of XnView
Posts: 27088
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Inaccessible editing functions

Postby xnview » Mon Feb 27, 2017 8:19 am

please check this topic
Pierre.

blinkenlight
Posts: 2
Joined: Sun Feb 26, 2017 6:08 pm

Re: Inaccessible editing functions

Postby blinkenlight » Mon Feb 27, 2017 5:48 pm

Thank you, that worked.


Return to “Classic - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest