Weird clipboard related bug

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
Drahken
Posts: 883
Joined: Sun Apr 10, 2005 4:29 pm

Weird clipboard related bug

Postby Drahken » Tue Mar 29, 2011 2:28 am

This one may be difficult for you to reproduce & thus difficult or impossible for you to fix, but here goes;
This bug requires firefox 3.6 (probably other versions too, but it definitely happens with 3.6) or opera 10 or 11 (again, probably happens with other versions, but definitely happens with 10 and 11). It also requires the DCE tools photoshop plugin (not sure if the trial version has the same effect or not, I have the full version): http://www.mediachance.com/plugins/dceessentials.html
This bug occurs in 1.98b2

The bug: Go to any image in firefox or opera, right click it & copy it, then go paste it int xnview. Now open up the dce filters and apply one. I believe all of them have the same effect, I know for certain that color corection, autoenhance, and exposure all do.
As soon as you hit the apply button, the top 2/3 of the pic gets all scrambled.
I have tried resizing the pic prior to applying the filter, but get the same result. I have tried several other photoshop filters & none have this issue.

Since this is clearly a clipboard related bug (it doesn't occur if I save the pic & open it in xnview, nor if I paste the pic into another image editor & then re-copy and re-paste into xnview, nor if I copy from internet explorer or chrome), I can't email you any examples.

I'm running windows XP, if that makes any difference.

This bug does NOT occur in xnview 1.97, so it's the result of something that got changed since then.

Due to the rather particular & specific factors involved in this bug, it may be too difficult or impossible for you to track down. Still, I hope that it can be fixed, as I frequently paste images from firefox & then tinker with them.



While I can't send you a sample, due to it being clipboard related, here is what the scrambled pic winds up looking like (hopefully seeing the effect will help you figure it out):
Image

...and this is what it looked like before:
Image
Oh the feuhrer, oh the feuhrer, oh the feuhrer's nipples bonk!

User avatar
xnview
Author of XnView
Posts: 27590
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Weird clipboard related bug

Postby xnview » Mon Apr 11, 2011 7:56 pm

Yes, something has changed in clipboard, support alpha channel.
So could you send me your email by PM?
Pierre.

User avatar
Drahken
Posts: 883
Joined: Sun Apr 10, 2005 4:29 pm

Re: Weird clipboard related bug

Postby Drahken » Wed Apr 13, 2011 9:15 pm

This bug is fixed in beta 3.
Oh the feuhrer, oh the feuhrer, oh the feuhrer's nipples bonk!


Return to “Classic - Resolved Bugs & Requests”

Who is online

Users browsing this forum: CrazyWebCrawler and 2 guests