GFL SDK v3.40

Discussions on GFL SDK, the graphic library for reading and writing graphic files

Moderators: XnTriq, xnview

User avatar
xnview
Author of XnView
Posts: 27694
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

GFL SDK v3.40

Postby xnview » Thu Jan 20, 2011 4:30 pm

Dear user of GFL SDK,

GFL SDK v3.40 for Windows 32&64 bits (+ unicode version), linux 32bits, linux 64bits & MacOSX is available

Direct download:
Windows:
http://download.xnview.com/GflSDK-win.zip

Linux x86:
http://download.xnview.com/GflSDK-Linux-x86.tgz

Linux x86 64bits:
http://download.xnview.com/GflSDK-Linux64-x86.tgz

MacOSX:
http://download.xnview.com/GflSDK-MacOSX.tgz
Pierre.

User avatar
madiazg
Posts: 82
Joined: Wed Jul 18, 2007 8:00 pm
Location: Tenerife - Islas Canarias
Contact:

Re: GFL SDK v3.40

Postby madiazg » Mon Jan 24, 2011 8:27 pm

Thank you very much Pierre.
Can you tell us which new features have this new version?

Best Regards ...
Miguel Angel

User avatar
fabrizio.carraro
Posts: 1
Joined: Fri Jun 22, 2012 8:40 pm

Re: GFL SDK v3.40

Postby fabrizio.carraro » Fri Jun 22, 2012 8:49 pm

Trying to compile the examples on a 10.6.8 osX I get a lot of errors:

$ make
cc -c -O2 -arch x86_64 -I../include -o gfl_example.o gfl_example.c
gfl_example.c: In function ‘Test10File’:
gfl_example.c:532: warning: passing argument 1 of ‘gflMerge’ from incompatible pointer type
c++ gfl_example.o -L../lib -lgfl -lgfle -o gfl_example
ld: warning: in ../lib/libgfl.dylib, file was built for i386 which is not the architecture being linked (x86_64)
ld: warning: in ../lib/libgfle.dylib, file was built for i386 which is not the architecture being linked (x86_64)
Undefined symbols:
"_gflChangeColorDepth", referenced from:
_Test7File in gfl_example.o
_Test5File in gfl_example.o
"_gflMemoryRealloc", referenced from:
.... and so on

Any suggestion?
Thanks a lot!

User avatar
xnview
Author of XnView
Posts: 27694
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: GFL SDK v3.40

Postby xnview » Sat Jun 23, 2012 8:04 am

Please send me your email by PM
Pierre.

Ben321
Posts: 39
Joined: Fri Jul 30, 2010 8:05 am

Re: GFL SDK v3.40

Postby Ben321 » Mon Sep 24, 2012 9:21 pm

While GFL SDK is updated in the official zip file download to version 3.40, the supplied GFLAX in that zip file is still back at version 3.00. Where can I get GFLAX version 3.40?

User avatar
xnview
Author of XnView
Posts: 27694
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: GFL SDK v3.40

Postby xnview » Tue Sep 25, 2012 7:13 am

Ben321 wrote:While GFL SDK is updated in the official zip file download to version 3.40, the supplied GFLAX in that zip file is still back at version 3.00. Where can I get GFLAX version 3.40?

GFLAx is no more supported, source code is available...
Do you have problems with GFLAx 3.0?
Pierre.

User avatar
omniplex
Posts: 122
Joined: Thu Feb 10, 2011 1:52 pm
Location: Hamburg
Contact:

Re: GFL SDK v3.40

Postby omniplex » Thu Dec 19, 2013 2:44 am


Hi, in the GFL ReadMe.txt you still have an old "LZW is patented" blurb for GIF. These patents expired worldwide a decade ago.

In another thread you wrote that I can get rid of an old xjp2.dll, this plugin was replaced by openjp2.dll. Apparently you still have the older plugin in the GFL SDK and in the ZIP distribution for XnView MP. I have an old Xdjvu.dll plugin (2009) for XnView classic, the GFL package contains an even older Xdjvu2.dll plugin (2006), now I wonder which is better.

I'm not planning to use the SDK, but Freeciv uses some ImageMagick stuff: The "magick wand" Freeciv map output on my 64bits Windows box magicallysomehow manages to render ocean tiles as green :mrgreen: instead of blue :bug:, that's why I looked into your GFL SDK.

Meanwhile the new XnView web page isn't that new anymore, maybe add the GFL SDK and the plugin creator SDK to the column for developers: At the moment only nconvert is listed there.

FrontierDK
Posts: 3
Joined: Sun Jul 13, 2014 10:50 am

Re: GFL SDK v3.40

Postby FrontierDK » Mon Oct 10, 2016 10:58 am

How does one register the component? If I use 2.80 - I can register using regsvr32 without any problems - but if I try to register libgfl340.dll - I get this error:

The DllRegister Server entry point was not found.

So how does one register this "new" version?


Return to “GFL SDK”

Who is online

Users browsing this forum: No registered users and 1 guest