With this thread I ask for 3 new textstrings in browser mode,
in order to really identify which rotate command is represented by a toolbar icon.
No change of functionality is required.
During the past days I did many tests with "rotate an image".
Here I have learned that XnViewMP (I worked with 0.79 and also 0.81) has 2 sets of commands:
- a set of commands that do lossless rotation with (internal commands): cmd_lrotate90, cmd_lrotate180, cmd_lrotate270
- a normal set with commands: cmd_rotate90, cmd_rotate180, cmd_rotate270 (without l in commandname)
that also depend on additional settings
Both sets of commands are available in browser-mode and also in viewer-mode.
But to my surprise different commands have identical textstrings/captions in GUI.
In order to get a better overview which command is really represented by a menu and/or by a toolbar icon,
I tried (within a private german translation) to modify the existings textstrings:
For test I added a sequence number at the end of existing strings.
All menu and toolbar icons used in VIEW-MODE now got different textstrings/captions.
(When a command only has an icon in toolbar, the helptext explained the correct command).
The original texts for cmd_rotateXXX and cmd_lrotateXXX are identical, but this can be modified for each translation.
From a programmers point of view: we have 6 string-variables/constants, but always 2 of them have identical content.
But in BROWSER-MODE there are only 3 different textstrings available (we have only 3 string variables/constants).
So it is not possible to use different captions for commands with "l" and without "l".
These 3 (modified) textstrings are different to those used in VIEW-MODE.
They are ok for all lossless-rotation commands used in menu and toolbar.
It would be very very helpful to have different captions for the different commands. Not to say that this is a must for me.
Please Pierre enhance XnViewMP and introduce another 3 textstrings in BROWSER-MODE that are used as captions for "normal rotate" commands without a "l" in internal name.
Please do it within the next release.
Thanks in advance