Cannot set XnView MP 0.85 as a default app on Windows 10 Creators Update

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

tf2_anon
Posts: 2
Joined: Fri Apr 14, 2017 2:48 pm

Cannot set XnView MP 0.85 as a default app on Windows 10 Creators Update

Postby tf2_anon » Fri Apr 14, 2017 3:01 pm

Hi, I did a clean installation of Windows for the newest update and now I cant find XnView MP on the default apps list. It used to work fine on the Anniversary Update.

One thing to note is that, if I manually switch the associated file extensions from the Photos app to XnView MP, it will show up immediately as the default viewer. However, if I click on the default viewer list, XnView MP will still not be there. Also, upon restarting, Windows will set the Photos app as default again.

As a side note, I used the complete x64 setup.

UPDATE:
Shutting down and turning the power back on solved the problem on one of my PCs. Simple restarts had no effects. However, the problem still persists (even after a shutdown) on my second PC. I did a clean install of Windows on both PCs.

User avatar
xnview
Author of XnView
Posts: 27557
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Cannot set XnView MP 0.85 as a default app on Windows 10 Creators Update

Postby xnview » Sat Apr 15, 2017 1:20 pm

and before the update you had XnViewMP in default app list?
Pierre.

User avatar
xnview
Author of XnView
Posts: 27557
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Cannot set XnView MP 0.85 as a default app on Windows 10 Creators Update

Postby xnview » Sun Apr 16, 2017 8:14 am

i have tried on a clean Windows 10 creators update, and XnViewMP is shown as default app
Pierre.

tf2_anon
Posts: 2
Joined: Fri Apr 14, 2017 2:48 pm

Re: Cannot set XnView MP 0.85 as a default app on Windows 10 Creators Update

Postby tf2_anon » Sun Apr 16, 2017 8:12 pm

It seems it happens when there are multiple user accounts.
I tried it on my laptop (clean install, single user): everything is fine.
I tried it on my sister's laptop and on my desktop PC (clean install, multiple users): it doesnt shows up in the default photo viewer list or it takes a while to show up (even on SSDs).

UPDATE:
Ok, found a solution. You have to run XnView MP as admin, then go to Settings, go to Integration and click on Set file associations...
It will show the message that you need to go to Windows Settings, but if you check, this time XnView MP will be in the default Photo Viewers list.
I dont know if this is an expected behavior but, as I told you, XnView MP wouldnt show up otherwise.


Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 1 guest