XnView MP 0.85 beta 1

Bugs found in XnView MP

Moderators: helmut, XnTriq, xnview, Dreamer

XnView MP 0.85 beta 1

Postby xnview » Thu Mar 16, 2017 8:31 am

**** Please do not post bugs or requests in this topic!

**** In this new test version 0.85 beta 1 various bugs have been fixed. All reported bugs that aren't listed in the changelog below will be fixed in a later release. Please do not re-report a bug which wasn't fixed yet.

XnView 0.85 beta 1 is available for beta testing. You can download XnView MP 0.85 beta 1 here:

Windows x64 ZIP version: http://www.xnview.com/beta/XnViewMP-win-x64-beta1.zip
Windows x32 ZIP version: http://www.xnview.com/beta/XnViewMP-win-x32-beta1.zip

If you have reported one or several bugs listed below, we'd kindly ask you to check with the latest version whether the bug really has been fixed and confirm this with a short note in the specific topic with the bug report.

Thank you for your help!

Changelog 0.85:

0114: [New] Create contact sheet
1052: [New] TWAIN 32bits support in 64bits
1082: [New] Shortcuts setting in 2 separate list
1087: [New] Template filename in Import&sort dialog - viewtopic.php?t=34729
1072: [New] Context menu of tree pane: Order of menu items - viewtopic.php?t=34688
1070: [New] UNC expand in folder tree - viewtopic.php?t=34673
1063: [New] Keep Histogram/grid/info state when view tab is closed - viewtopic.php?t=34641
1148: [New] Draw: Del key to remove item - viewtopic.php?t=35037
1040: [New] MacOSX drag&drop -> Move instead of Copy - viewtopic.php?t=34214
1159: [New] Read/Write settings in global settings dialog
1158: [New] Linux: copy and paste - viewtopic.php?t=35066
0490: [New] Filename in statusbar not elided - viewtopic.php?t=30717
1117: [New] Ask again message in dialog box - viewtopic.php?t=29221
1115: [New] useQtAV instead of videoMode setting
1114: [New] Icons for "Uncolored" and "Uncolored (Next image)" - viewtopic.php?t=34941
1141: [New] Shortcuts for page navigation - viewtopic.php?t=18514
1107: [New] Click on favorites star does nothing - viewtopic.php?t=34901
1097: [New] Menu entry "View»Info pane»Show" missing - viewtopic.php?t=24061
1095: [New] Custom filter - viewtopic.php?t=34778
0738: [New] Selection save/restore

1162: [Bug] Issues on HiDPi screen
1161: [Bug] Change timestamp: UI change when toggling checkbox - viewtopic.php?t=35086
1160: [Bug] Update catalogue from files causes heavy disk access - viewtopic.php?t=35052
0686: [Bug] Date problem - viewtopic.php?t=32019
1157: [Bug] Severe bug: photo overwritten without warning - viewtopic.php?t=35046
1156: [Bug] Linux: dot in folder name -> saveas bug - viewtopic.php?t=29099
0902: [Bug] Issues on Retina screen - viewtopic.php?t=27420
1155: [Bug] Resizing to large image fails silently - viewtopic.php?t=35060
1154: [Bug] Print -> Captions - viewtopic.php?t=33647
1153: [Bug] MacOS: Draw function generates unexpected crash & quits - viewtopic.php?t=35036
1152: [Bug] Search function - possible memory leak - viewtopic.php?t=32943
0641: [Bug] Sort by Aperture/Focal/Shutter - viewtopic.php?t=31496
1151: [Bug] Category Set: Can't remove category - viewtopic.php?t=30823
1150: [Bug] Copy & Paste of folder pastes as subfolder - viewtopic.php?t=35020
1149: [Bug] Tiff compression - viewtopic.php?t=32252
1103: [Bug] MacOSX: delete folder - not moved in trash can
1102: [Bug] Setup wizard - XnView folder by default
1146: [Bug] Batch convert, Same filename in hotfolder unrecognized after first run - viewtopic.php?t=35012
1145: [Bug] USB stick not detected - viewtopic.php?t=29313
1144: [Bug] Draw tool: No consecutive text drawing - viewtopic.php?t=34152
1143: [Bug] Page Numbers wrong when Thumb Printout - viewtopic.php?t=34396
0950: [Bug] Different ratio X/Y - viewtopic.php?t=33725
1122: [Bug] Browser: Change filter doesn't update statusbar - viewtopic.php?t=35026
1140: [Bug] Batch rename thumbnail enlarges constantly - viewtopic.php?t=32528
1139: [Bug] Wait cursor in "JPG lossless" warning message box - viewtopic.php?t=34994
1138: [Bug] Format colors isn't working - viewtopic.php?t=33870
0890: [Bug] Pan tool problem - viewtopic.php?t=33349
1137: [Bug] Set selection ratio - viewtopic.php?t=33671
1136: [Bug] Changing theme doesn't update XnView - viewtopic.php?t=34959
1135: [Bug] 'Auto play (video)' option doesn't affect current tab - viewtopic.php?t=34887
1134: [Bug] Updater logic - version compare logic typo - viewtopic.php?t=34574
1133: [Bug] Shortcut Alt+Enter doesn't open properties - viewtopic.php?t=34613
1132: [Bug] Disable dropdown while in crop mode - viewtopic.php?t=34946
0157: [Bug] Drag&drop in GPS pane - viewtopic.php?t=28982
1131: [Bug] Cropping is a bit off - viewtopic.php?t=34911
1130: [Bug] Kolor Crash reporter: Upload enabled after deletion - viewtopic.php?t=34988
1129: [Bug] Kolor Crash reporter: Upload button remains enabled - viewtopic.php?t=34766
1128: [Bug] Deleting files in fullscreen mode deleted all folders - viewtopic.php?t=29628
1127: [Bug] Categories on folder - viewtopic.php?t=33643
1126: [Bug] Category filter & base path - viewtopic.php?t=34881
1125: [Bug] Selection: 'W' key doesn't always swap - viewtopic.php?t=34984
1124: [Bug] No backup for lossless operations - viewtopic.php?t=34957
1123: [Bug] JPEG lossless cropping is completely off - viewtopic.php?t=34957
1121: [Bug] Some context menu items unavailable after making copy - viewtopic.php?t=34908
1118: [Bug] Selection: Swapping h/w doesn't update status - viewtopic.php?t=34983
1120: [Bug] Many disk accesses when canceling ITPC/IIM dialog - viewtopic.php?t=34992
1119: [Bug] Batch convert: ZIP files without .zip extension - viewtopic.php?t=34999
1116: [Bug] Folder filter should update when we change the folder - viewtopic.php?t=34915
1113: [Bug] Incorrect volume reading after restart when vol at 0 - viewtopic.php?t=34889
1112: [Bug] Category filter: Deselecting doesn't deselect children - viewtopic.php?t=34770
1111: [Bug] Searching twice returns no results - viewtopic.php?t=34920
1110: [Bug] Viewer: Selection lost when moving selection - viewtopic.php?t=34860
1109: [Bug] Tagging files by checking them causes strange behavior - viewtopic.php?t=34918
1105: [Bug] Always "Folder" after hiding data pane - posting.php?p=138489
1108: [Bug] # of object(s) selected doesn't clear properly - viewtopic.php?t=34917
1106: [Bug] .XnViewSort never shown - viewtopic.php?t=34906
1104: [Bug] Toolbar Command "Show" gone after adding and removing - viewtopic.php?t=34885
1101: [Bug] View»Data pane»Show unhides Folder tree - viewtopic.php?t=34868
1077: [Bug] Titlebar no longer hidden when switching mode - viewtopic.php?t=34711
1100: [Bug] ":\ not allowed in windows filename - viewtopic.php?t=29700
1099: [Bug] Viewer: "Page" in context menu not disabled - viewtopic.php?t=34864
1010: [Bug] Tree & browser sync issue - viewtopic.php?t=34016
1011: [Bug] Tree order - viewtopic.php?t=34017
1094: [Bug] Capture is not capturing the cursor - viewtopic.php?t=34578
1073: [Bug] Folder tree not updated when deleting folder - viewtopic.php?t=34687
1093: [Bug] "Show Alpha" doesn't toggle using "M" key - viewtopic.php?t=34466
1092: [Bug] can't remember auto image size in fullscreen - viewtopic.php?t=34747
1091: [Bug] Binary image zoom-in glitch - viewtopic.php?t=34746
1090: [Bug] Rating & Label not export in XMP Sidecar automatically - viewtopic.php?t=34728
1089: [Bug] Check for orphaned files/directories can wipe catalog info - viewtopic.php?t=30490
1088: [Bug] Category/rating cannot be used in create file listing
1086: [Bug] Fullscreen - Crazy Info Panel - viewtopic.php?t=34756
1085: [Bug] Browser: Filter by»Custom always checked - viewtopic.php?t=34769
0958: [Bug] Grid always selected in crop mode - viewtopic.php?t=33727
1084: [Bug] Fullscreen - No Crop Menu - viewtopic.php?t=34755
1080: [Bug] Switching mode: Only middle-doubleclick switches - viewtopic.php?t=34692
1078: [Bug] Copy to/Move to: Double-click on folder triggers - viewtopic.php?p=138018
1075: [Bug] Settings not saved in argument INI - viewtopic.php?t=34681
1074: [Bug] Export - Quality value not visible for WebP - viewtopic.php?t=34713
1071: [Bug] 'Tag' filter show always all files - viewtopic.php?t=34677
1069: [Bug] Moving files messes up categories & base path- viewtopic.php?t=34643
1065: [Bug] Crash when zooming out small image using grid - viewtopic.php?t=34656
1066: [Bug] .JP_ image deleted in JPEG lossless transformation - viewtopic.php?t=34660
1064: [Bug] File size&name not updated in statusbar - viewtopic.php?t=34646
1062: [Bug] Rename dialog template - viewtopic.php?t=34627
1061: [Bug] Video play/pause - viewtopic.php?t=34614
1060: [Bug] Filelist: 2 slashes - viewtopic.php?t=34619
Pierre.
User avatar
xnview
Author of XnView
 
Posts: 26806
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.85 beta 1

Postby helmut » Thu Mar 16, 2017 8:37 am

Thank you for very much for your effort in fixing many bugs and providing the 0.85 beta 1, Pierre! :)
User avatar
helmut
Moderator
 
Posts: 7888
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: XnView MP 0.85 beta 1

Postby grgr » Thu Mar 16, 2017 11:56 am

To check the issue 1162, an OSX-beta would be nice.
grgr
 
Posts: 12
Joined: Tue Apr 07, 2015 3:42 pm

Re: XnView MP 0.85 beta 1

Postby CameronD » Thu Mar 16, 2017 12:51 pm

You've been working hard! Thank you.

I'm a bit confused - the one I just downloaded reports on the help page as 0.85 beta1 (10 Mar 2017). Is this a different version from the previous "beta 1" that I downloaded to test for you?, or am I somehow running the wrong one?
I have already been reporting bugs against 0.85 beta 1, so that might get a bit confusing.
CameronD
 
Posts: 265
Joined: Wed Aug 01, 2007 1:28 pm
Location: Australia

Re: XnView MP 0.85 beta 1

Postby cday » Thu Mar 16, 2017 1:08 pm

CameronD wrote:You've been working hard! Thank you.

I'm a bit confused - the one I just downloaded reports on the help page as 0.85 beta1 (10 Mar 2017). Is this a different version from the previous "beta 1" that I downloaded to test for you?, or am I somehow running the wrong one?
I have already been reporting bugs against 0.85 beta 1, so that might get a bit confusing.

I think that when a preliminary build is sent to an individual member to test a particular fix, it would be better to refer to it as a 'test version' or something similar, avoiding the use of 'beta' or even 'pre-beta'... :?:
cday
XnThusiast
 
Posts: 1331
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: XnView MP 0.85 beta 1

Postby helmut » Thu Mar 16, 2017 1:25 pm

cday wrote:... I think that when a preliminary build is sent to an individual member to test a particular fix, it would be better to refer to it as a 'test version' or something similar, avoiding the use of 'beta' or even 'pre-beta'... :?:
Right, test versions have been sent to individual people for verifying a specific bug fix. 0.85 Beta 1 is available, now. All fixed bug reports should be checked against this first beta version.
User avatar
helmut
Moderator
 
Posts: 7888
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: XnView MP 0.85 beta 1

Postby CameronD » Thu Mar 16, 2017 2:32 pm

helmut wrote:
cday wrote:... I think that when a preliminary build is sent to an individual member to test a particular fix, it would be better to refer to it as a 'test version' or something similar, avoiding the use of 'beta' or even 'pre-beta'... :?:
Right, test versions have been sent to individual people for verifying a specific bug fix. 0.85 Beta 1 is available, now. All fixed bug reports should be checked against this first beta version.


Whatever I called it, it still needed to be identified - "test" is too vague. I used the identification in the about page - the bug is on that page, where the earlier build date (10 Mar 2017) was allowed to remain, even though this one was probably built on the 16th.

The zip file I downloaded was also labelled beta1.
CameronD
 
Posts: 265
Joined: Wed Aug 01, 2007 1:28 pm
Location: Australia

Re: XnView MP 0.85 beta 1

Postby cday » Thu Mar 16, 2017 3:01 pm

I think there are two different points:

1. When Pierre sends a test build to an individual to test a specific fix, it would be best to refer to it on the forum as a 'test build' or similar, to avoid confusion.

2. Ideally the test version would be identied in the file as something other than 'Beta 1' (in this case), but if that isn't practical for some reason, the person receiving it would understand that it is a development build and not the final version that will be released, and if necessary identify it from the file date.
cday
XnThusiast
 
Posts: 1331
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: XnView MP 0.85 beta 1

Postby iMiKE » Thu Mar 16, 2017 3:32 pm

Hello! Will 0.85 beta1 be available for Mac x64?
I'm experiencing bugs fixed in this beta :-(
iMiKE
 
Posts: 5
Joined: Thu Mar 16, 2017 3:20 pm

Re: XnView MP 0.85 beta 1

Postby Erixx haxx » Thu Mar 16, 2017 9:02 pm

Hello:

Can someone please tell me were to post new bugs to v0.85-beta-1. As in regressions.
I have 2 new bugs in 0.85 that don't seem to be in 0.84

Thanks
**Edit** I might just put them in new area for now and let a mod move them, because I don't think I'll be here tomorrow.
Windows 7 Ultimate, x64-bit (SP 1) XnViewMP x64 v0.85-b-2 Port
ASUSTek P8Z77-v
i5-3570K CPU @ 3.40GHz
Memory: x16.0 GB
Samsung SSD 840 EVO 250GB ATA
NVIDIA GeForce GTX 960 @ 1177 MHz
Dedicated: 4096 MB GDDR5
User avatar
Erixx haxx
 
Posts: 324
Joined: Tue Jul 28, 2015 10:37 am

Re: XnView MP 0.85 beta 1

Postby helmut » Thu Mar 16, 2017 9:17 pm

Erixx haxx wrote:Can someone please tell me were to post new bugs to v0.85-beta-1. As in regressions.
"New" is fine (we don't have a dedicated sub-forum for bugs introduced in beta versions yet and Pierre will see these new bug reports).

Just to make sure:
Please use the prefix "0.85b1" only for bugs that have been introduced in 0.85 beta 1 and place a note in the bug report that this problem has been introduced in the beta version. For all other new bug reports please use the prefix 0.84.
User avatar
helmut
Moderator
 
Posts: 7888
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: XnView MP 0.85 beta 1

Postby helmut » Fri Mar 17, 2017 7:53 am

@Pierre: The 0.85 beta 1 doesn't run on Windows XP at all, see viewtopic.php?f=95&t=35148
User avatar
helmut
Moderator
 
Posts: 7888
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: XnView MP 0.85 beta 1

Postby helmut » Fri Mar 17, 2017 10:59 am

I just start to realize that apart from many bug fixes there had been quite a number of new features. That's really great, Pierre! :)

xnview wrote:...
1052: [New] TWAIN 32bits support in 64bits
...
Does this mean that XnView 0.85 64 bit will work fine with all Twain Drivers?
User avatar
helmut
Moderator
 
Posts: 7888
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: XnView MP 0.85 beta 1

Postby xnview » Fri Mar 17, 2017 11:53 am

helmut wrote:I just start to realize that apart from many bug fixes there had been quite a number of new features. That's really great, Pierre! :)

xnview wrote:...
1052: [New] TWAIN 32bits support in 64bits
...
Does this mean that XnView 0.85 64 bit will work fine with all Twain Drivers?

yes
Pierre.
User avatar
xnview
Author of XnView
 
Posts: 26806
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.85 beta 1

Postby helmut » Fri Mar 17, 2017 11:57 am

xnview wrote:
helmut wrote:I just start to realize that apart from many bug fixes there had been quite a number of new features. That's really great, Pierre! :)

xnview wrote:...
1052: [New] TWAIN 32bits support in 64bits
...
Does this mean that XnView 0.85 64 bit will work fine with all Twain Drivers?

yes
Very good. That's a good and important improvement.
User avatar
helmut
Moderator
 
Posts: 7888
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany


Return to MP - Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest