0.85b1: Procedure "GetUserPreferredUILanguages"

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

0.85b1: Procedure "GetUserPreferredUILanguages"

Postby helmut » Thu Mar 16, 2017 8:02 pm

XnView: MP 0.85 beta 1 - 32 bit
OS: Windows XP - 32 bit

Note: This problem has been introduced in 0.85 beta 1; it worked fine in 0.84.

When trying to start XnView MP a message box is shown saying: The procedure entry point "GetUserPreferredUILanguages" wasn't found in the DLL "KERNEL32.dll".

Effect: XnView MP doesn not start and cannot be used at all.

To reproduce:
1. On Windows XP double-click on xnviewmp.exe

Actual behaviour (bug): Error message is displayed (see above) :bug:

Expected behaviour: XnView MP starts up. No error message

User avatar
XnTriq
Moderator & Librarian
Posts: 4865
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby XnTriq » Thu Mar 16, 2017 10:15 pm

Confirmed :bugconfirmed:

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby helmut » Fri Mar 17, 2017 7:42 am

XnTriq wrote:Confirmed :bugconfirmed:
:)

User avatar
xnview
Author of XnView
Posts: 27080
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby xnview » Fri Mar 17, 2017 8:58 am

it's seems that Qt 5.8.0 doesn't support anymore Windows XP, i ask to the support
Pierre.

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby helmut » Fri Mar 17, 2017 9:03 am

xnview wrote:it's seems that Qt 5.8.0 doesn't support anymore Windows XP, i ask to the support
O.k.. Actually, it would be bad news if Qt (and thus XnView MP) no longer supported Windows XP. There's still users out there with Windows XP.

User avatar
XnTriq
Moderator & Librarian
Posts: 4865
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby XnTriq » Fri Mar 17, 2017 12:00 pm

Kai Koehne (Qt 5.8 released) wrote:Windows XP isn’t supported anymore as a target since Qt 5.7. If you need to continue supporting Windows XP, you must unfortunately stay with Qt 5.6.

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby helmut » Fri Mar 17, 2017 12:02 pm

XnTriq wrote:
Kai Koehne (Qt 5.8 released) wrote:Windows XP isn’t supported anymore as a target since Qt 5.7. If you need to continue supporting Windows XP, you must unfortunately stay with Qt 5.6.
Uhhh! :( O.k., Windows XP users still have XnView Classic as an alternative. :)

User avatar
xnview
Author of XnView
Posts: 27080
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby xnview » Fri Mar 17, 2017 12:19 pm

XnTriq wrote:
Kai Koehne (Qt 5.8 released) wrote:Windows XP isn’t supported anymore as a target since Qt 5.7. If you need to continue supporting Windows XP, you must unfortunately stay with Qt 5.6.

but i think that we can use Qt 5.6.2 dll with 0.85
Pierre.

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby helmut » Fri Mar 17, 2017 12:35 pm

xnview wrote:
XnTriq wrote:
Kai Koehne (Qt 5.8 released) wrote:Windows XP isn’t supported anymore as a target since Qt 5.7. If you need to continue supporting Windows XP, you must unfortunately stay with Qt 5.6.

but i think that we can use Qt 5.6.2 dll with 0.85
This would be a good thing. :)

User avatar
xnview
Author of XnView
Posts: 27080
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby xnview » Sun Mar 19, 2017 6:57 am

helmut wrote:
but i think that we can use Qt 5.6.2 dll with 0.85
This would be a good thing. :)

i have the confirmation, QT 5.8.0 can't be used on Windows XP, i can perhaps make a QT 5.6.0 package for XP users?
If you copy xnview.exe in the 0.84 package, is it working?
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 4865
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby XnTriq » Sun Mar 19, 2017 8:30 am

xnview wrote:If you copy xnview.exe in the 0.84 package, is it working?

No joy :-|

xnviewmp.exe - Entry Point Not Found wrote:The procedure entry point ??0QDateTime@@QAE@$$QAV0@@Z could not be located in the dynamic link library Qt5Core.dll.

Tested with the DLLs from MP v0.84 and xnviewmp.exe form v0.85b1:

Code: Select all

\XnViewMP\xnviewmp.exe
\XnViewMP\qt.conf
\XnViewMP\avcodec-57.dll
\XnViewMP\avdevice-57.dll
\XnViewMP\avfilter-6.dll
\XnViewMP\avformat-57.dll
\XnViewMP\avresample-3.dll
\XnViewMP\avutil-55.dll
\XnViewMP\Qt5Concurrent.dll
\XnViewMP\Qt5Core.dll
\XnViewMP\Qt5Gui.dll
\XnViewMP\Qt5Multimedia.dll
\XnViewMP\Qt5MultimediaWidgets.dll
\XnViewMP\Qt5Network.dll
\XnViewMP\Qt5OpenGL.dll
\XnViewMP\Qt5Positioning.dll
\XnViewMP\Qt5PrintSupport.dll
\XnViewMP\Qt5Qml.dll
\XnViewMP\Qt5Quick.dll
\XnViewMP\Qt5Sensors.dll
\XnViewMP\Qt5Sql.dll
\XnViewMP\Qt5Svg.dll
\XnViewMP\Qt5WebChannel.dll
\XnViewMP\Qt5WebKit.dll
\XnViewMP\Qt5WebKitWidgets.dll
\XnViewMP\Qt5Widgets.dll
\XnViewMP\Qt5WinExtras.dll
\XnViewMP\Qt5Xml.dll
\XnViewMP\QtAV1.dll
\XnViewMP\QtAVWidgets1.dll
\XnViewMP\swresample-2.dll
\XnViewMP\swscale-4.dll
\XnViewMP\XMPCore.dll
\XnViewMP\XMPFiles.dll
\XnViewMP\plugins\platforms\qwindows.dll

User avatar
xnview
Author of XnView
Posts: 27080
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85b1: Procedure "GetUserPreferredUILanguages"

Postby xnview » Mon Mar 20, 2017 1:45 pm

so no more XP support :(
Pierre.


Return to “Closed/Resolved”

Who is online

Users browsing this forum: No registered users and 0 guests