0.87 b2: Duplicate video playback

Bugs which have been reproduced by a second user or the developer

Moderator: Dreamer

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

0.87 b2: Duplicate video playback

Postby Dreamer » Fri Jul 21, 2017 12:02 am

XnView: MP 0.87 beta 2 (and 3, not released yet) - 64-bit, and MP 0.86 - 64-bit (probably also in older versions)
OS: Windows 10 - 64-bit

I couldn't find any topic, but I think I mentioned this in some topic, but there is probably no official bug report, anyway, this bug has been fixed partially, it was worse in 0.86.

Effect: Video (and audio) is playing in background, or multiple videos are playing at the same time.

To reproduce:
A)
1. Play any video in browser.
2. Switch mode to viewer.
3. Video playback in browser is stopped (correct, probably fixed in 0.87, it was not stopped in 0.86).
4. Switch mode to browser.

Actual behaviour (bug): Video playback in viewer is NOT stopped, if you click play button in browser preview, playback is duplicated. :bug:

B)
1. Set option "Use middle click" to "Browser <> Viewer" (Interface > Switching mode).
2. Select any image in browser.
3. Middle click any video in browser to switch mode to viewer.
4. Video playback in browser is not stopped.

Actual behaviour (bug): Video playback in browser is NOT stopped, same video is playing in browser and viewer. :bug:

C)
1. Play any video in browser.
2. Switch mode to viewer.
3. Video playback in browser is stopped (correct).
4. Switch mode to browser.
5. Video playback in viewer is NOT stopped.
6. Now select another video in browser.

Actual behaviour (bug): Two (or more) different videos are playing at the same time (selected video in browser and video in viewer tab, in background, sound). :bug:

D)
1. Play any video in browser.
2. Switch mode to viewer.
3. Video playback in browser is stopped (correct).
4. Switch mode to browser.
5. Video playback in viewer is NOT stopped.
6. Now press F11 to go to fullscreen.

Actual behaviour (bug): Two different videos are playing at the same time (selected video in fullscreen and video in viewer tab, in background, sound). :bug:

E)
1. For option "Max of view tabs" set to 5 or more (Interface > Tabs).
2. Set option "Use middle click" to "Browser <> Viewer" (Interface > Switching mode).
3. Play the 1st video in browser.
4. Middle click 1st video in browser to go to viewer.
5. Video playback in browser is stopped (correct).
6. Middle click within the video in viewer to go to browser.
7. Video playback in viewer is NOT stopped.
8. Now middle click 2nd video in browser to go to viewer.
(You can repeat steps 4-8 with the new videos.)

Actual behaviour (bug): 1st video is playing in viewer, 2nd video is playing in browser preview and it the new viewer tab (3 videos are playing at time), if you repeat steps 4-8, more videos are playing at the same time. :bug:

Expected behaviour: Only one video should be played at time.
Dreamer

Return to “Reproduced”

Who is online

Users browsing this forum: No registered users and 1 guest