Search found 17 matches

by CaspianRoach
Thu Jun 25, 2020 8:14 am
Forum: Closed/Resolved
Topic: Zoom options race condition when scrolling through images of different types
Replies: 4
Views: 291

Re: Zoom options race condition when scrolling through images of different types

Tried to reproduce the bug with the same conditions, seems to be fixed.
by CaspianRoach
Thu May 07, 2020 8:30 pm
Forum: Closed/Resolved
Topic: Zoom options race condition when scrolling through images of different types
Replies: 4
Views: 291

Re: Zoom options race condition when scrolling through images of different types

A related bug, but with a Browser view here's what happens when you do the exact same thing: https://streamable.com/125o7v It is a bit weird because you don't see/hear my scroll wheel, but at the end there, I basically spam previous image\next image in a very quick succession with my mouse wheel. No...
by CaspianRoach
Thu May 07, 2020 8:29 pm
Forum: Closed/Resolved
Topic: Zoom options race condition when scrolling through images of different types
Replies: 4
Views: 291

Zoom options race condition when scrolling through images of different types

Xnview MP 0.96.2, Windows 10 64. When scrolling through images of multiple types (example: .jpg, .bmp) on a slow machine/extremely quickly, the zoom options are sometimes inherited from a previous image. My Xnview setting for handling images is 'Fit Image To Window, Large only'. Best explained with ...
by CaspianRoach
Thu May 07, 2020 7:37 pm
Forum: Reproduced - TODO
Topic: "High quality zoom" preview images are not aligned correctly
Replies: 2
Views: 223

Re: "High quality zoom" preview images are not aligned correctly

Note that this bug only happens when "High Quality Zoom" is actually doing something — as in, if it's "Zoom-out" then the image needs to be at lower than 100% resolution for the effect to appear, 90% for example. This does not happen otherwise.
by CaspianRoach
Thu May 07, 2020 7:20 pm
Forum: Reproduced - TODO
Topic: "High quality zoom" preview images are not aligned correctly
Replies: 2
Views: 223

"High quality zoom" preview images are not aligned correctly

Xnview 0.96.2, Windows 10 64. Setting the "High Quality Zoom" setting to "Zoom-out" (default setting) causes the quick preview versions of images to become misaligned up and to the left. By 'quick preview' images I mean the low quality version of the image that is loaded and displayed before the ful...
by CaspianRoach
Sat Mar 21, 2020 9:29 am
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

I've downloaded the new version and so far it behaves just like the debug versions you've sent me to test - that is, everything works perfectly fine and the performance is much improved. I haven't noticed anything breaking yet, but if it will, I will make sure to let you know. Thanks!
by CaspianRoach
Wed Feb 19, 2020 2:18 pm
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

948 subfolders. Tried moving subfolders to a different folder temporarily - didn't help.
by CaspianRoach
Wed Feb 19, 2020 2:13 pm
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

Here's a video starting in "Last" folder with 'Browser mode on startup' checkbox checked:

https://streamable.com/qq3de
by CaspianRoach
Wed Feb 19, 2020 2:11 pm
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

Here's a video of delay from starting Xnview on <Empty>, then pressing the 'Browser' button:

https://streamable.com/iqwvw
by CaspianRoach
Wed Feb 19, 2020 2:09 pm
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

No descript.ion in this folder. Also tried deleting Thumbs.db to no effect.
by CaspianRoach
Wed Feb 19, 2020 1:56 pm
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

If you mean start the program in browser mode - i checked the 'start in Fullscreen - Browser' mode and that didn't speed it up. If you mean going from the image to browser mode - then yes, there is still a similar delay in that folder as when you start the program from scratch. https://streamable.co...
by CaspianRoach
Tue Feb 18, 2020 4:46 pm
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

65k in the root of that folder, about 110k overall with subfolders. Images and videos mostly. But the bulk of the files in the root folder is JPEG files, yes:

https://i.imgur.com/YjFzKPi.png

Catalog is empty and off, tried turning it on - did nothing.

https://i.imgur.com/Q0Wd0u1.png
by CaspianRoach
Tue Feb 18, 2020 4:32 pm
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

I turned on "Catalog" and let it scan the whole folder but that didn't change anything for startup times, so that's probably not it.
by CaspianRoach
Tue Feb 18, 2020 4:09 pm
Forum: Closed/Resolved
Topic: Performance in single image mode
Replies: 16
Views: 2569

Re: Performance in single image mode

It is only noticeable on truly gigantic folders on HDDs. Here, I made a short video: https://streamable.com/1ezf9 On the left you can see the detailed information about the folder, 65k of those files are directly in the root of that folder. First, I open an image with a double click, which opens Xnv...
by CaspianRoach
Thu Feb 13, 2020 5:43 am
Forum: MP - Suggestions
Topic: Hide tabs bar when only one tab is open
Replies: 1
Views: 785

Re: Hide tabs bar when only one tab is open

I just realised that there's no Window dropdown Menu anymore, so if you have tabs bar hidden, you basically have no way of switching between the open documents. Then this option is a bigger deal than I thought, constantly switching tabs bar on and off based on my current task manually is going to ge...