Search found 303 matches

by CameronD
Tue Feb 25, 2020 1:27 pm
Forum: MP - General Support
Topic: HEIF plugin missing EXIF
Replies: 3
Views: 962

Re: HEIF plugin missing EXIF

[*] exif data is missing. - temporary solution below yes, currently not supported I thought that was the case, which is why I offered the workaround using exiftool in case anybody else could make use of it. [*]It is very slow - not sure this is a problem with xnviewMP or the plugin, or windows itse...
by CameronD
Tue Feb 25, 2020 4:04 am
Forum: MP - General Support
Topic: HEIF plugin missing EXIF
Replies: 3
Views: 962

HEIF plugin missing EXIF

I just installed the x64 heif plugin with XnViewMP 0.95 on window 10. I also installed the windows 10 support at the same time. I exported the .heic image files as jpeg and there are a couple of issues: exif data is missing. - temporary solution below It is very slow - not sure this is a problem wit...
by CameronD
Tue Sep 24, 2019 2:26 pm
Forum: Closed/Resolved
Topic: MP 0.72 search fails if using image base path
Replies: 15
Views: 3908

Re: MP 0.72 search fails if using image base path

... 'base path' should not be changed after scanning folders. It is a simple sql one-liner to update any old folders where the basepath has already been stored in full in pathnames. At a minimum, users should be warned that there are nn folders containing the new base path and this may cause proble...
by CameronD
Sat Sep 21, 2019 5:08 am
Forum: Closed/Resolved
Topic: MP 0.72 search fails if using image base path
Replies: 15
Views: 3908

Re: MP 0.72 search fails if using image base path

The good news is that I can no longer reproduce any of the previous problems. I am not sure how thoroughly I could test things, since there are a large number of permutations, but the issues I reported seem to be fixed. The not quite so good news is that there might have been another bug introduced ...
by CameronD
Sat Sep 21, 2019 2:22 am
Forum: Closed/Resolved
Topic: Saving the selected tab in the "Edit IPTC"
Replies: 5
Views: 1158

Re: Saving the selected tab in the "Edit IPTC"

Works well.

A minor change to the English wording ...
should say "Open last opened tab"

Alternatively, the following might be slightly clearer:
"Reopen at last opened tab"
by CameronD
Sat Sep 21, 2019 2:17 am
Forum: Closed/Resolved
Topic: Metadata is not saved in single-image mode
Replies: 12
Views: 1486

Re: Metadata is not saved in single-image mode

But what is the use of "Apply" button ? A good question. I have edited this reply, since my original comment was wrong. "Apply" saved your changes in the program's internal copy of the image metadata. You can even view one image next or previous and the changes are still there, but not yet saved to...
by CameronD
Mon Dec 03, 2018 12:12 pm
Forum: Closed/Resolved
Topic: MP 0.72 search fails if using image base path
Replies: 15
Views: 3908

Re: MP 0.72 search fails if using image base path

[*]I created a base path that was one folder down my tree : E:/Photos/Australia . None of these had already been scanned into the DB. [*] search with "use catalog", starting at E:/Photos for an entry in the caption finds the one outside the base path, but not the one within the Ok, right, mixing ab...
by CameronD
Mon Dec 03, 2018 2:09 am
Forum: Closed/Resolved
Topic: MP 0.72 search fails if using image base path
Replies: 15
Views: 3908

Re: MP 0.72 search fails if using image base path

I have just tested 0.93 beta1 that Pierre sent me. Summary : The new bug reported by michel038 (nothing is found by search "using catalog") has been fixed The problem with base path still exists - with slight differences from my first report. Edit: Update - I have also copied v0.93b1 over my main 0....
by CameronD
Fri Nov 30, 2018 2:16 am
Forum: Closed/Resolved
Topic: MP 0.72 search fails if using image base path
Replies: 15
Views: 3908

Re: MP 0.72 search fails if using image base path

I don't know if this bug was fixed, but there is a new bug in V0.92 Searches are ok when selecting categories in "categories filter" tab, but the option "use catalog" in search function gives always 0 files found, even if base path has default value. see https://newsgroup.xnview.com/viewtopic.php?f...
by CameronD
Mon Nov 26, 2018 11:11 pm
Forum: Closed/Resolved
Topic: MP 0.72 search fails if using image base path
Replies: 15
Views: 3908

Re: MP 0.72 search fails if using image base path

Hi, the fact that this is still listed under "new" probably means the bug has not been addressed. I have stopped using base path, so have not noticed it. I guess the way to make search still work is to use "My Computer" as the root of the search - or whatever is the appropriate selection for your OS...
by CameronD
Tue Jun 12, 2018 3:31 pm
Forum: New
Topic: Rotation and EXIF Orientation field
Replies: 24
Views: 4063

Re: Rotation and EXIF Orientation field

do you have some sample files? They are in the attached zip file two posts above: testcases-badorientation.zip . That longer post also describes conditions for reproducing. [*]There seem to be very different rules applied when saving after rotation in the Browser compared to single image view. Ther...
by CameronD
Sun Jun 10, 2018 9:17 am
Forum: New
Topic: Rotation and EXIF Orientation field
Replies: 24
Views: 4063

Re: Rotation and EXIF Orientation field

A short(er) summary : There were not as many orientation bugs as I initially thought, but the important factor is to test all variations of tag and actual orientation . Some were actual orientation bugs, and some were bugs in the way that XnViewMP generated or used the thumbnail. Because XnViewMP s...
by CameronD
Thu Jun 07, 2018 8:58 am
Forum: New
Topic: Rotation and EXIF Orientation field
Replies: 24
Views: 4063

Re: Rotation and EXIF Orientation field

Here is my set of test case images attached: testcases-badorientation.zip They are named mode- n _xxx where the mode number is defined in my post above. Modes 0 and 1 will display correctly with a viewer that obeys the Exif orientation tag. Modes 0 and 3 will display correctly with a viewer that ign...
by CameronD
Thu Jun 07, 2018 5:57 am
Forum: New
Topic: Rotation and EXIF Orientation field
Replies: 24
Views: 4063

Re: Rotation and EXIF Orientation field

Hi Cameron, I agree with tour recommendation, this is the way I use XnView for the reason you exposed. I wonder if you posted it in the wrong topic? This one is about a bug where the application forget to reset the orientation tag to 1. I explain how to reproduce. There is another topic about the o...
by CameronD
Wed Jun 06, 2018 2:58 pm
Forum: New
Topic: Rotation and EXIF Orientation field
Replies: 24
Views: 4063

Re: Rotation and EXIF Orientation field

No wonder this is hard to get right. I have just spent two days (not full time) accumulating test cases and testing under various conditions. I ended up with 26 test images, each tested under 4 different option conditions, under 3 different rotation operations. And that is by no means exhaustive, ex...