Search found 31 matches

by fireattack
Tue Jun 14, 2016 8:01 pm
Forum: Closed/Resolved
Topic: EXIF orientation info is wrong
Replies: 4
Views: 573

Re: EXIF orientation info is wrong

xnview wrote:
fireattack wrote:Example image: http://i.imgur.com/HvBwO16.jpg
this picture has no exif orientation
Sorry, didn't realize Imgur stripped out all the exif info.

Try this one: https://www.dropbox.com/s/cuxm42b1iltlu ... W.jpg?dl=0
by fireattack
Sat May 28, 2016 1:53 am
Forum: Closed/Resolved
Topic: EXIF orientation info is wrong
Replies: 4
Views: 573

EXIF orientation info is wrong

Example image: http://i.imgur.com/HvBwO16.jpg

It shows 1 (top left):

Image

It should be 6:

Image

Ironically the built-in addon Exiftool shows it correctly:

Image

XnView Classic has the same problem by the way.
by fireattack
Tue Mar 08, 2016 5:25 pm
Forum: XnView Shell Extension
Topic: Extended XnView has no XnViewShellExt64.dll
Replies: 2
Views: 886

Re: Extended XnView has no XnViewShellExt64.dll

I knew, but it doesn't make sense right? the "extended" version is supposed to have shell ex working without downloading additional files. And even if I downloaded XnViewShellExt64.dll by myself, I still cannot use that "F12-> System integration -> Use XnView Shell Extension" option to enable it (be...
by fireattack
Tue Mar 08, 2016 9:41 am
Forum: XnView Shell Extension
Topic: Extended XnView has no XnViewShellExt64.dll
Replies: 2
Views: 886

Extended XnView has no XnViewShellExt64.dll

The installer and zip of extended XnView don't ship with XnViewShellExt64.dll. Therefore that function (F12-> System integration -> Use XnView Shell Extension) doesn't work on 64 bit system.

The standalone version works fine.
by fireattack
Sat Dec 20, 2014 11:27 pm
Forum: New
Topic: 0.71 WebP lossless still bugged
Replies: 15
Views: 2160

Re: 0.71 WebP lossless still bugged

Hello, I registered to report this exact same thing. The files encoded with webp lossless also do not match their original for me. To determine that, I used the "search for similar files" tool, which shows crc of the images. If I save the image with XnView MP (version 0.72, Windows 8.1 64, both x64...
by fireattack
Sat Dec 20, 2014 3:45 am
Forum: New
Topic: 0.71 WebP lossless still bugged
Replies: 15
Views: 2160

Re: 0.71 WebP lossless still bugged

i've checked the file, and it's lossless but i don't understand why output size is different... OMG, it's not, I don't even know how you can tell it is lossless, compare by naked eyes? Just convert it back to png or bmp by xnview, and then subtract it from the original png by Photoshop or GIMP. The...
by fireattack
Sat Dec 13, 2014 10:19 am
Forum: New
Topic: 0.71 WebP lossless still bugged
Replies: 15
Views: 2160

Re: 0.71 WebP lossless still bugged

Are you sure the loss isn't introduced in converting from RGB to YUV and back? Some colors can be badly affected by that, especially in very light and dark regions. I don't think XnView uses RGB in WebP at all, so it's only lossless after the conversion to YUV. Hmm, I'm not sure I get your point. A...
by fireattack
Sat Dec 13, 2014 10:15 am
Forum: New
Topic: 0.71 WebP lossless still bugged
Replies: 15
Views: 2160

Re: 0.71 WebP lossless still bugged

you have not the same as cwebp?? Could you send me orignal file, and saved file, please I use the following command: cwebp -lossless original.png -o output.webp For xnview I use: http://snag.gy/5qSD7.jpg The results and original: https://www.dropbox.com/sh/poqmnuh6nb94a56/AAAwMGJ1wPw1RvbzX2GGjYPDa?...
by fireattack
Fri Dec 12, 2014 6:03 am
Forum: New
Topic: 0.71 WebP lossless still bugged
Replies: 15
Views: 2160

0.71 WebP lossless still bugged

Windows x64 zip

See: http://newsgroup.xnview.com/viewtopic.php?f=62&t=30793

I chose lossless, but the result is still a lossy file.
by fireattack
Thu Oct 23, 2014 12:22 am
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1972

Re: 0.69 still can't create lossless webP

I've tried and it works. the webp.dll has which file date? 2013/03/31 (in both XnViewMP-win-x64.zip and XnViewMP-win.zip downloaded from http://newsgroup.xnview.com/viewtopic.php?f=82&t=30761 ) And even if it could produce lossless image by setting q to 100.. it loses the ability to create q100 LOS...
by fireattack
Tue Oct 21, 2014 3:52 am
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1972

Re: 0.69 still can't create lossless webP

I didn't get your point, but I just read the parameters of cwebp. It separates lossy and lossless- with lossy, even you set the quality (-q) to 100 it's still lossy. Makes sense, but then what do you mean by "when quality=100, i use lossless"? cwebp has a lossless parameter?? If I read correctly, y...
by fireattack
Mon Oct 20, 2014 1:33 am
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1972

Re: 0.69 still can't create lossless webP

when quality=100, i use lossless. Which app do you use to create lossless webp? uh.. xnview MP 0.69? ok :) do you have tried official tools cwebp? I didn't get your point, but I just read the parameters of cwebp. It separates lossy and lossless- with lossy, even you set the quality (-q) to 100 it's...
by fireattack
Mon Oct 13, 2014 1:30 pm
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1972

Re: 0.69 still can't create lossless webP

xnview wrote:when quality=100, i use lossless. Which app do you use to create lossless webp?
uh.. xnview MP 0.69?
by fireattack
Sun Oct 12, 2014 8:18 am
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1972

0.69 still can't create lossless webP

It's related to an old bug: http://newsgroup.xnview.com/viewtopic.php?f=79&t=29875 I'm not very sure the meaning of that bug (and its fix). was it about merely "can't set to 100%" or "can't save as lossless" or both? (Because in JPEG 100%!=lossless, not sure if it's the case in WebP) Anyway, in 0.69...
by fireattack
Sat Jun 28, 2014 7:45 am
Forum: New
Topic: 0.68 JPEG unable to set 100% quality
Replies: 1
Views: 438

0.68 JPEG unable to set 100% quality

I've already read this thread: http://forum.xnview.com/viewtopic.php?f=79&t=23119 The mod there said XnViewMP used IJG's lib to convert JPEG, I'm not sure if it's still the case. If we're still using IJG's implementation, IJG's lib does have quality setting of 0-100, instead of 0-99: (Copied from us...