Search found 40 matches

by fireattack
Sat Dec 13, 2014 10:19 am
Forum: New
Topic: 0.71 WebP lossless still bugged
Replies: 15
Views: 2181

Re: 0.71 WebP lossless still bugged

Are you sure the loss isn't introduced in converting from RGB to YUV and back? Some colors can be badly affected by that, especially in very light and dark regions. I don't think XnView uses RGB in WebP at all, so it's only lossless after the conversion to YUV. Hmm, I'm not sure I get your point. A...
by fireattack
Sat Dec 13, 2014 10:15 am
Forum: New
Topic: 0.71 WebP lossless still bugged
Replies: 15
Views: 2181

Re: 0.71 WebP lossless still bugged

you have not the same as cwebp?? Could you send me orignal file, and saved file, please I use the following command: cwebp -lossless original.png -o output.webp For xnview I use: http://snag.gy/5qSD7.jpg The results and original: https://www.dropbox.com/sh/poqmnuh6nb94a56/AAAwMGJ1wPw1RvbzX2GGjYPDa?...
by fireattack
Fri Dec 12, 2014 6:03 am
Forum: New
Topic: 0.71 WebP lossless still bugged
Replies: 15
Views: 2181

0.71 WebP lossless still bugged

Windows x64 zip

See: http://newsgroup.xnview.com/viewtopic.php?f=62&t=30793

I chose lossless, but the result is still a lossy file.
by fireattack
Thu Oct 23, 2014 12:22 am
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1998

Re: 0.69 still can't create lossless webP

I've tried and it works. the webp.dll has which file date? 2013/03/31 (in both XnViewMP-win-x64.zip and XnViewMP-win.zip downloaded from http://newsgroup.xnview.com/viewtopic.php?f=82&t=30761 ) And even if it could produce lossless image by setting q to 100.. it loses the ability to create q100 LOS...
by fireattack
Tue Oct 21, 2014 3:52 am
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1998

Re: 0.69 still can't create lossless webP

I didn't get your point, but I just read the parameters of cwebp. It separates lossy and lossless- with lossy, even you set the quality (-q) to 100 it's still lossy. Makes sense, but then what do you mean by "when quality=100, i use lossless"? cwebp has a lossless parameter?? If I read correctly, y...
by fireattack
Mon Oct 20, 2014 1:33 am
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1998

Re: 0.69 still can't create lossless webP

when quality=100, i use lossless. Which app do you use to create lossless webp? uh.. xnview MP 0.69? ok :) do you have tried official tools cwebp? I didn't get your point, but I just read the parameters of cwebp. It separates lossy and lossless- with lossy, even you set the quality (-q) to 100 it's...
by fireattack
Mon Oct 13, 2014 1:30 pm
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1998

Re: 0.69 still can't create lossless webP

xnview wrote:when quality=100, i use lossless. Which app do you use to create lossless webp?
uh.. xnview MP 0.69?
by fireattack
Sun Oct 12, 2014 8:18 am
Forum: Retest
Topic: 0.69 still can't create lossless webP
Replies: 10
Views: 1998

0.69 still can't create lossless webP

It's related to an old bug: http://newsgroup.xnview.com/viewtopic.php?f=79&t=29875 I'm not very sure the meaning of that bug (and its fix). was it about merely "can't set to 100%" or "can't save as lossless" or both? (Because in JPEG 100%!=lossless, not sure if it's the case in WebP) Anyway, in 0.69...
by fireattack
Sat Jun 28, 2014 7:45 am
Forum: New
Topic: 0.68 JPEG unable to set 100% quality
Replies: 1
Views: 446

0.68 JPEG unable to set 100% quality

I've already read this thread: http://forum.xnview.com/viewtopic.php?f=79&t=23119 The mod there said XnViewMP used IJG's lib to convert JPEG, I'm not sure if it's still the case. If we're still using IJG's implementation, IJG's lib does have quality setting of 0-100, instead of 0-99: (Copied from us...
by fireattack
Sun Nov 10, 2013 8:05 am
Forum: XnConvert
Topic: "Rotate images accoridng to EXIF" option is unchangeable
Replies: 0
Views: 547

"Rotate images accoridng to EXIF" option is unchangeable

The title is kinda inexact. Instead of "unchangeable", every time you exited XnConvert this setting will be changed to "checked".