how to make "show people's region" persistent?

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
avidracer
Posts: 3
Joined: Fri Mar 26, 2021 11:05 pm

how to make "show people's region" persistent?

Post by avidracer »

I am unsure if there is a way to make the "show people's region" persistent in the viewer interface/mode. I have several images with face recognition carried out using digiKam - I believe digiKam saves the face data in the MGW XMP tag. When I open the photo in xnviewMP viewer, I have to manually enable View > "Show People's region" manually each time. I have mine setup to allow only one instance of xnviewMP to run at a time (Tools > Settings > General > Allow only one instance of Xnview).
Is there a way to make this setting stick or enabled all the time? Meaning I enable it once and whenever XnviewMP viewer is showing a image with the MGW XMP data, it automatically processes the data and shows the region and person tag?
User avatar
xnview
Author of XnView
Posts: 35269
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: how to make "show people's region" persistent?

Post by xnview »

right, must be persistent, See issue for current status and some details.
Pierre.
avidracer
Posts: 3
Joined: Fri Mar 26, 2021 11:05 pm

Re: how to make "show people's region" persistent?

Post by avidracer »

glad to hear next release will include this fix. Cannot wait to try it. Thanks!!
User avatar
xnview
Author of XnView
Posts: 35269
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: how to make "show people's region" persistent?

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.98.3. Please check and confirm the bug fix here.
Pierre.
avidracer
Posts: 3
Joined: Fri Mar 26, 2021 11:05 pm

Re: how to make "show people's region" persistent?

Post by avidracer »

xnview wrote: Thu May 06, 2021 2:09 pm This problem is supposed to be fixed in XnView MP 0.98.3. Please check and confirm the bug fix here.
Thanks for the fix. I am able to verify this to now work persistently when browsing photos with pre-determined face region. Confirmed with Mac XNView MP version 0.98.3 64bits.
Post Reply