0.98: When app is open - Clicking on same file doesn't bring XnView MP to front of others

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

stevehero
Posts: 27
Joined: Fri Feb 12, 2021 9:17 pm

Re: 0.98: When app is open - Clicking on same file doesn't bring XnView MP to front of others

Post by stevehero »

Hopefully, 0.98.4 has this resolved. Thanks for looking into this.
User avatar
xnview
Author of XnView
Posts: 35476
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98: When app is open - Clicking on same file doesn't bring XnView MP to front of others

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.98.4. Please check and confirm the bug fix here.
Pierre.
stevehero
Posts: 27
Joined: Fri Feb 12, 2021 9:17 pm

Re: 0.98: When app is open - Clicking on same file doesn't bring XnView MP to front of others

Post by stevehero »

xnview wrote: Tue Jun 01, 2021 12:32 pm This problem is supposed to be fixed in XnView MP 0.98.4. Please check and confirm the bug fix here.
Thanks very much Pierre. That seems to have done the trick.
EverGreen
Posts: 6
Joined: Wed Mar 03, 2021 7:15 pm

Re: 0.98: When app is open - Clicking on same file doesn't bring XnView MP to front of others

Post by EverGreen »

stevehero wrote: Tue Jun 01, 2021 12:45 pm
xnview wrote: Tue Jun 01, 2021 12:32 pm This problem is supposed to be fixed in XnView MP 0.98.4. Please check and confirm the bug fix here.
Thanks very much Pierre. That seems to have done the trick.
As stevehero said, bug isn't anymore.

Very very Thanks Pierre!!!
mattcro
Posts: 1
Joined: Thu Jul 08, 2021 9:25 am

Re: 0.98: When app is open - Clicking on same file doesn't bring XnView MP to front of others

Post by mattcro »

I have just installed XnView MP 0.98.4 64bit on a fresh install of Win10 and I seem to have this bug.

I have "only one instance" checked, and I have the XnViewMP window maximised (but not in fullscreen mode).
I open an image file from Explorer and XnViewMP opens as expected and shows the file.
I switch back to Explorer and open another file (or the same file again) and the XnViewMP tab flashes in the taskbar but the window stays in the background (behind Explorer).

However, if I "restore" the XnViewMP window so that is is NOT maximised, then it DOES appear correctly in the foreground when I open an image from Explorer. I noticed this only by chance, as I typically use XnViewMP with its window maximised.

Hope that helps!
Post Reply