mp 0.21 - Page upscrolling still partly broken

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Gerhard Mesenich
Posts: 20
Joined: Fri Oct 02, 2009 9:38 pm

mp 0.21 - Page upscrolling still partly broken

Post by Gerhard Mesenich » Tue Oct 27, 2009 10:48 pm

relates to the previous Bug report of oct. 5, 2009:
mp 0.20 win32 - document-files - Page scrolling broken

Page downscrolling in preview mode is now functional in mp 0.21. Upscrolling is still broken.

Page previous:
Works with menue only.
The Icon for PagePrevious is greyed out, no function.
Key PageUp no reaction.

But if PagePrevious is first set with the menue, then Icon and Key PageUp work correctly until the next document is chosen.

Page next:
Only downscrolling is now fully working with Menue, icon and key PageDown.
It still throws out the document after reaching the last page. The document should stay in the preview window until the next one is chosen.

-----
Bug/missing feature:
Mousewheel set to Scroll up/down:
no reaction with document views (pdf and office files).

Mousewheel scrolling should be functional in document previews.


Just a related feedback:
Text files look nice now in the preview window with the changed white background.
They scroll just fine with the mousewheel working.

Merci beaucoup,
Gerhard

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: mp 0.21 - Page upscrolling still partly broken

Post by xnview » Tue Dec 08, 2009 1:16 pm

Sorry but could you explain me more your problem?
Pierre.

Gerhard Mesenich
Posts: 20
Joined: Fri Oct 02, 2009 9:38 pm

Re: mp 0.21 - Page upscrolling still partly broken

Post by Gerhard Mesenich » Mon Dec 14, 2009 11:41 pm

Hi Pierre,

backscrolling does not work in the preview window with *pdf* files.

A pdf file can be viewed in the preview window just fine, you can also choose the next page with the menue or the toolbar icon. Forward scrolling is fixed now and works fine; it was also broken in the previous version.

But the backscrolling function is still broken; going back to the previous page is not possible with pdf file.

I just found out the following strange behaviour:
The following sequence makes backscrolling work for the current file:

1. Right-click in the preview window, context menue comes up
2. choose:
page - next page, always works
page - previous page, greyed out, does not work on first try

3. Do the same procedure again, choose:
page - next page, works
page - previous page, works now on the second try

After this sequence the Toolbar icon also works.

After going to another file, the trouble starts again.

Everything is repeatable. It may probably be a bug in Ghostscript, which seems to be used as pdf viewer.


With text files scrolling works fine by now, no problems there anymore.

Sorry for my late answer, I haven't looked into the forum for a while.

regards,
Gerhard

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: mp 0.21 - Page upscrolling still partly broken

Post by xnview » Tue Dec 15, 2009 2:02 pm

You use the context menu in Preview pane of browser, not viewer, right?
You click on a multipage PDF, you can use 'Next page', and after you can't use 'Previous page', right?
Pierre.

Gerhard Mesenich
Posts: 20
Joined: Fri Oct 02, 2009 9:38 pm

Re: mp 0.21 - Page upscrolling still partly broken

Post by Gerhard Mesenich » Tue Dec 15, 2009 3:50 pm

xnview wrote:You use the context menu in Preview pane of browser, not viewer, right?
Yes.
xnview wrote:You click on a multipage PDF, you can use 'Next page', and after you can't use 'Previous page', right?
Yes.

Only after giving the same pdf file focus a second time, then 'Previous page' works.

Gerhard

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: mp 0.21 - Page upscrolling still partly broken

Post by xnview » Wed Dec 16, 2009 8:12 am

I can't reproduce, could you send me your email by PM to send you a test version?
Pierre.

Gerhard Mesenich
Posts: 20
Joined: Fri Oct 02, 2009 9:38 pm

Re: mp 0.21 - Page upscrolling still partly broken

Post by Gerhard Mesenich » Fri Dec 18, 2009 4:21 pm

Just done.

Gerhard Mesenich
Posts: 20
Joined: Fri Oct 02, 2009 9:38 pm

Re: mp 0.21 - Page upscrolling still partly broken

Post by Gerhard Mesenich » Mon Dec 21, 2009 7:24 pm

Hi Pierre,

thanks for the test version. The behaviour is still unchanged.

Test:

Test version, without any configuration changes, everything standard, winXP:

1. Go to a pdf-folder, all pdfs show as thumbnails just fine.

2. Click a pdf-thumbnail, the first page of the chosen pdf shows up in the preview window, works fine.

3. Right click in the preview-window, select: page - next_page ==> next page shows just fine.

4. Showing the following pages the same way also works.

5. Now comes the bug:

Trying to go back and showing a previous page does not work.
Right click in the preview-window, select: page - previous_page
==> not possible, previous_page is greyed out ==> this is the bug

It should be possible to go back and preview the previous pages again.
The same happens, if you go through the View-Menue or if you install the page buttons in the toolbar.

If you now follow the same procedure a second time, then page - previous_page works! But you will never get there, if you don't know and give up after the first try. If you give focus to another application thereafter, then the trouble starts again.

The bug seems to be caused by a blocking of the page_previous procedure by viewing the first page, when of cause there is no previous page. But whenever you go forward in the document, this block must be removed.

Page_previous should be blocked on viewing the *first* page only.

Same behaviour also in the Linux (Ubuntu) version.

Thanks for your patience,
regards,
Gerhard

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: mp 0.21 - Page upscrolling still partly broken

Post by xnview » Mon Jan 04, 2010 3:40 pm

For me, 'previous page' is always enabled (only grayed when on first page)
Pierre.

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: mp 0.21 - Page upscrolling still partly broken

Post by xnview » Tue Mar 16, 2010 8:30 pm

Please, could you test XnViewMP 0.25
Pierre.

Gerhard Mesenich
Posts: 20
Joined: Fri Oct 02, 2009 9:38 pm

Re: mp 0.21 - Page upscrolling still partly broken

Post by Gerhard Mesenich » Wed Mar 17, 2010 2:20 pm

Problem solved, working fine now in MP 0.25 (winXP).

Excellent progress!

Under Linux (Ubuntu 9.10, fresh install), pdfs don't show as preview and thumbnails at all.
Ghostview is installed.

If I remember correctly, it used to work with Linux for me, maybe because I had installed AdobeReader.
It would be nice, if pdf preview would work under Linux 'out of the box' as well.

I get pdf thumbnails with the nautilus filemanager.

Thanks,
Gerhard

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: mp 0.21 - Page upscrolling still partly broken

Post by marsh » Wed Mar 17, 2010 2:34 pm

Gerhard Mesenich wrote: Under Linux (Ubuntu 9.10, fresh install), pdfs don't show as preview and thumbnails at all.
Ghostview is installed.
They appear perfectly here in Debian 6.0, when package named "ghostscript" is installed.

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: mp 0.21 - Page upscrolling still partly broken

Post by oops66 » Wed Mar 17, 2010 3:24 pm

marsh wrote:
Gerhard Mesenich wrote: Under Linux (Ubuntu 9.10, fresh install), pdfs don't show as preview and thumbnails at all.
Ghostview is installed.
They appear perfectly here in Debian 6.0, when package named "ghostscript" is installed.
Hello, FI, PDF works here into Ubuntu Karmic Koala v9.10 with the ghoscript package installed (MP linux v0.25).
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

Gerhard Mesenich
Posts: 20
Joined: Fri Oct 02, 2009 9:38 pm

Re: mp 0.21 - Page upscrolling still partly broken

Post by Gerhard Mesenich » Thu Mar 18, 2010 12:36 pm

pdf preview is and was working here under Linux too, which took quite a while for me to realize ;-).

The reason for not showing pdfs under Linux here is the unability to handle filemames with spaces. All my tested pdfs had spaces in their filenames and therefore did not show. Writing a new bug report.

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: mp 0.21 - Page upscrolling still partly broken

Post by oops66 » Thu Mar 18, 2010 12:54 pm

Ah, OK, and I can reproduce now.
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

Post Reply