anti-aliasing stop working after crop

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

xzr
Posts: 5
Joined: Tue May 26, 2015 7:09 am

anti-aliasing stop working after crop

Post by xzr » Wed May 27, 2015 8:05 am

Even before the actual crop action, just click the crop button in viewer the photo anti-aliasing stop working as soon as the crop bar appears.
I have to close viewer tab and reopen it every time I do a crop, very annoying.

User avatar
xnview
Author of XnView
Posts: 31876
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: anti-aliasing stop working after crop

Post by xnview » Thu May 28, 2015 7:55 am

i'm not able to reproduce this bug
Pierre.

xzr
Posts: 5
Joined: Tue May 26, 2015 7:09 am

Re: anti-aliasing stop working after crop

Post by xzr » Fri May 29, 2015 2:53 am

Really? I reset all setting but the issue still exists.

And, I do like the feature that I can zoom a picture to 100% by left click and hold in viewer. But this stops working as well once I click the crop button so I have to close the tab and reopen it every time I do a crop :(

User avatar
xnview
Author of XnView
Posts: 31876
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: anti-aliasing stop working after crop

Post by xnview » Fri May 29, 2015 2:38 pm

xzr wrote:Really? I reset all setting but the issue still exists.

And, I do like the feature that I can zoom a picture to 100% by left click and hold in viewer. But this stops working as well once I click the crop button so I have to close the tab and reopen it every time I do a crop :(
could you post a screenshot before and after?
Pierre.

xzr
Posts: 5
Joined: Tue May 26, 2015 7:09 am

Re: anti-aliasing stop working after crop

Post by xzr » Sat May 30, 2015 5:16 pm

1.png
2.png
You can see the aliasing of the transmission lines.

rmtk
Posts: 141
Joined: Tue Dec 07, 2010 2:04 am

Re: anti-aliasing stop working after crop

Post by rmtk » Sun May 31, 2015 4:17 am

I CAN CONFIRM THESE TWO BUGS RELATED TO CROP!
Actually I reported these bug long time ago but never fixed. http://newsgroup.xnview.com/viewtopic.php?f=62&t=27377
For me they are by far the most disagreeable bugs in XnviewMP.

User avatar
xnview
Author of XnView
Posts: 31876
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: anti-aliasing stop working after crop

Post by xnview » Thu Jun 04, 2015 12:48 pm

please send me the image file?
Pierre.

xzr
Posts: 5
Joined: Tue May 26, 2015 7:09 am

Re: anti-aliasing stop working after crop

Post by xzr » Sat Jun 06, 2015 5:33 am

How can I send you the image file? But this issue is not restricted to a specific image file but all files.
And as zxs said in http://newsgroup.xnview.com/viewtopic.php?f=62&t=27377 ,the issue seams to be only related to the crop bar. It will not occur if you first select an area and then click crop button (does not trigger the crop bar).

User avatar
xnview
Author of XnView
Posts: 31876
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: anti-aliasing stop working after crop

Post by xnview » Fri Jun 12, 2015 9:17 am

xzr wrote:How can I send you the image file? But this issue is not restricted to a specific image file but all files.
And as zxs said in http://newsgroup.xnview.com/viewtopic.php?f=62&t=27377 ,the issue seams to be only related to the crop bar. It will not occur if you first select an area and then click crop button (does not trigger the crop bar).
you can send it to me on contact at xnview dot com
Pierre.

User avatar
xnview
Author of XnView
Posts: 31876
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: anti-aliasing stop working after crop

Post by xnview » Mon Jun 22, 2015 9:15 am

See Issue 669 for current status and details.
Pierre.

xzr
Posts: 5
Joined: Tue May 26, 2015 7:09 am

Re: anti-aliasing stop working after crop

Post by xzr » Tue Jun 23, 2015 9:25 am

Great! Can't wait for the next release. :D

rmtk
Posts: 141
Joined: Tue Dec 07, 2010 2:04 am

Re: anti-aliasing stop working after crop

Post by rmtk » Mon Sep 21, 2015 1:51 pm

Unfortunately this bug seems NOT actually fixed in 0.75... :(

User avatar
xnview
Author of XnView
Posts: 31876
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: anti-aliasing stop working after crop

Post by xnview » Thu Sep 24, 2015 8:29 am

rmtk wrote:Unfortunately this bug seems NOT actually fixed in 0.75... :(
?? you have it always
Pierre.

rmtk
Posts: 141
Joined: Tue Dec 07, 2010 2:04 am

Re: anti-aliasing stop working after crop

Post by rmtk » Wed Oct 07, 2015 8:19 pm

Always, on both Linux and Windows, from clean installation.

User avatar
helmut
Posts: 8172
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: anti-aliasing stop working after crop

Post by helmut » Thu Mar 02, 2017 7:33 pm

@xzr, rmtk: Could you please test with current XnView MP v0.84 and let us know whether this problem still occurs? (I've tried various things but couldn't reproduce in 0.84).

Post Reply