Dull red colors in XnViewMP for Mac

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
litvin.dmitry
Posts: 2
Joined: Mon Jan 18, 2016 7:18 pm

Dull red colors in XnViewMP for Mac

Post by litvin.dmitry » Mon Jan 18, 2016 8:00 pm

Bonjour Pierre,

I have some weird-looking reds (dull, closer to orange) in my JPG file exported from RAW in Darktable 2.0, when I view them in XnViewMP 0.76.1 x64.

I noticed recently, that the photos (that I export from RAW via Darktable) lack some red color in XnViewMP on Mac - so what was initially red becomes closer to orange, etc. I was blaming Darktable, but then I noticed that the built-in Preview tool shows them with much better color, and they look good when uploaded to Picasa, for example. So it seems like something related to XnViewMP (maybe handling of color profiles?).
Please see attached the side-by-side screenshot of the same image in Preview and XnViewMP, and this is the URL for the original JPG image as is: https://goo.gl/photos/sG3Zu81ivD9mK9FZA
Screen Shot 2016-01-18 at 20.26.12.png
Side-by-side comparison 1
Screen Shot 2016-01-18 at 20.59.27.png
Side-by-side comparison 2
If needed, I also have raw Olympus ORF file and corresponding XMP file, too (see also the Darktable exporting settings screenshot).
Screen Shot 2016-01-18 at 20.27.16.png
Darktable export settings
Screen Shot 2016-01-18 at 20.27.16.png (43.36 KiB) Viewed 307 times
I haven't found any relevant topics in the forum, so I post my problem as a new topic.

Thank you!

User avatar
xnview
Author of XnView
Posts: 31272
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Dull red colors in XnViewMP for Mac

Post by xnview » Tue Jan 19, 2016 8:01 am

And if you enable color profile?
Pierre.

litvin.dmitry
Posts: 2
Joined: Mon Jan 18, 2016 7:18 pm

Re: Dull red colors in XnViewMP for Mac

Post by litvin.dmitry » Tue Jan 19, 2016 9:34 am

Thank you! I was looking yesterday in XnViewMP preferences for anything related to Color, bit I somehow missed ICC settings.
What I did now is open Preferences, General - ICC tab, and specified Custom ICC profile.
To obtain that, I went to Mac System Preferences - Displays - Color and clicked Open Profile, File - Save As... to see where it is.
On my system, it's in /Library/ColorSync/Profiles/Displays/Color LCD-{some uuid}.icc
So I specified that path in XnViewMP settings, restarted it, and it helped. Now I see exactly the same colors as in Preview application.

I still wonder why such other non-native applications like Chrome, Darktable etc., don't require such configuration to display the colors properly..
But, at least it solved my problem. Thanks again!

Post Reply