0.82: Constantly hangs when viewing videos (20.000+ videos)

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

jadO
Posts: 318
Joined: Wed Apr 29, 2015 6:36 am

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby jadO » Fri Dec 09, 2016 6:07 am

Now after some testing I can say: Instead of freezes now it often hangs for 30+ seconds. But I did not experience those nasty freezes like before that required to restart XnViewMP.
I don't know what the setting videomode does but it seems that there are issued related to it.

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby xnview » Fri Dec 09, 2016 7:47 am

jadO wrote:Now after some testing I can say: Instead of freezes now it often hangs for 30+ seconds. But I did not experience those nasty freezes like before that required to restart XnViewMP.
I don't know what the setting videomode does but it seems that there are issued related to it.

Starting with 0.80, XnView MP have his own video engine based on ffmpeg (QtAV). By using videoMode=true, you use the default engine which use DirectShow codecs from your OS
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby Erixx haxx » Fri Dec 09, 2016 8:51 am

Hello:

I strongly feel fixing Xnview's bugs using direct show is the best way forward.

1.) Full Screen windowed bug
2.) Full screen exit bug
3.) 4 thumbs per video bug, I think this is because 4 thumbs setting ingnors the percent setting for first thumb in return skips the rest. Maybe add a time for 4 thumbs to start.
( All videos will have 1 thumb upper left at 0% regardless where % is set to )

@ jado if you follow XnTriq's related links you will see why I feel this way. 2nd link has a link to a blog that explains codecs use pretty good.

jadO
Posts: 318
Joined: Wed Apr 29, 2015 6:36 am

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby jadO » Fri Dec 09, 2016 10:49 am

xnview wrote:
jadO wrote:Now after some testing I can say: Instead of freezes now it often hangs for 30+ seconds. But I did not experience those nasty freezes like before that required to restart XnViewMP.
I don't know what the setting videomode does but it seems that there are issued related to it.

Starting with 0.80, XnView MP have his own video engine based on ffmpeg (QtAV). By using videoMode=true, you use the default engine which use DirectShow codecs from your OS


Still I have to state that 0.80 did not show freezes and 0.81 did not show those freezes as well. But what does his setting mean? When setting to true don't use ffmpeg anymore? Why does it freeze with ffmpeg but not with DirectShow codex?

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby xnview » Fri Dec 09, 2016 11:51 am

You have problem with videoMode=false?

Erixx haxx wrote:1.) Full Screen windowed bug
2.) Full screen exit bug

which bugs?

3.) 4 thumbs per video bug, I think this is because 4 thumbs setting ingnors the percent setting for first thumb in return skips the rest. Maybe add a time for 4 thumbs to start.
( All videos will have 1 thumb upper left at 0% regardless where % is set to )

It's a problem with directshow codec, some codec don't allow to seek to a position
Pierre.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby Erixx haxx » Fri Dec 09, 2016 12:51 pm

xnview wrote:You have problem with videoMode=false?

2 Bugs using videoMode=True, It Makes using this mode very hard.
As reported Here:
0.81: VideoMode Set True Bug
0000931

I think maybe has been mentioned a couple other places also.

Using Videomode=False, When I enter certian folders, Xnviewmp locks up.
http://newsgroup.xnview.com/viewtopic.php?f=74&t=34255 My post in the thread
3.) 4 thumbs per video bug, I think this is because 4 thumbs setting ingnors the percent setting for first thumb in return skips the rest. Maybe add a time for 4 thumbs to start.
( All videos will have 1 thumb upper left at 0% regardless where % is set to )
It's a problem with directshow codec, some codec don't allow to seek to a position

Ok, I Understand. Bad news

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

0.84b2 freezes too when viewing 20.000+ video files

Postby xnview » Mon Dec 12, 2016 6:51 pm

Erixx haxx wrote:
XnView wrote:Do you have tried with VideoMode=true?

I just found some more troubled video file folders.
I tried this and it did indeed correct the problem I was having with xnview totally locking up.

Is it possible to have a folder that freezes XnViewMP (VideoMode=false)?
Pierre.

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby xnview » Mon Dec 12, 2016 6:52 pm

Erixx haxx wrote: Using Videomode=False, When I enter certian folders, Xnviewmp locks up.
http://newsgroup.xnview.com/viewtopic.php?f=74&t=34255 My post in the thread

Is it possible to have one of this folder?
Pierre.

jadO
Posts: 318
Joined: Wed Apr 29, 2015 6:36 am

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby jadO » Thu Dec 22, 2016 6:41 pm

jadO wrote:Now after some testing I can say: Instead of freezes now it often hangs for 30+ seconds. But I did not experience those nasty freezes like before that required to restart XnViewMP.
I don't know what the setting videomode does but it seems that there are issued related to it.

Now after some weeks of using it, I can say that I have no longer the freezes I have reported.

Erixx haxx
Posts: 330
Joined: Tue Jul 28, 2015 10:37 am

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby Erixx haxx » Fri Dec 23, 2016 6:09 am

Is it possible to have a folder that freezes XnViewMP (VideoMode=false)?

Hi:

I'm not able to get a video sample that causes this issue yet. None of my stuff is fit to send, and when I cut down its size and re- encode it fixes the problem.

@jado, is their any chance you would have a sample video that cause's xn to hang with (videoMode=false) you could send.

jadO
Posts: 318
Joined: Wed Apr 29, 2015 6:36 am

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby jadO » Fri Dec 23, 2016 11:43 am

Erixx haxx wrote:@jado, is their any chance you would have a sample video that cause's xn to hang with (videoMode=false) you could send.


Unfortunately no, as this issue was not tied to a specific video file as far as I have experienced.

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby helmut » Wed Mar 01, 2017 9:10 pm

jadO wrote:... Now after some weeks of using it, I can say that I have no longer the freezes I have reported.
@jadO: Is the problem still solved for you or did it occur, again?

@Erixx haxx: Your linked bug reports are solved. Is this problem solved for you?

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.82: Constantly hangs when viewing videos (20.000+ vide

Postby helmut » Tue Mar 14, 2017 2:59 pm

No feedback from original poster.

:arrow: Closed (Please post here if the problem still occurs. Please provide more info that allows for reproducing the problem, then)

User avatar
B.Douille
Posts: 167
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: 0.82: Constantly hangs when viewing videos (20.000+ videos)

Postby B.Douille » Sun Nov 12, 2017 11:45 pm

Issue is back, since version 0.87 & 0.88.

It happened to me many time, with multiple .MP4 files, just after reading.
It should be noted also that the sound is bad, a kind of loop, echoing and still after the video ended. We have to close XnView MP
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.82: Constantly hangs when viewing videos (20.000+ videos)

Postby xnview » Tue Nov 14, 2017 12:11 pm

B.Douille wrote:Issue is back, since version 0.87 & 0.88.

It happened to me many time, with multiple .MP4 files, just after reading.
It should be noted also that the sound is bad, a kind of loop, echoing and still after the video ended. We have to close XnView MP

Back? If you reinstall the 0.86, no more problem??
Pierre.


Return to “Closed/Resolved”

Who is online

Users browsing this forum: No registered users and 1 guest