0.84: .JP_ image deleted in JPEG lossless transformation

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

0.84: .JP_ image deleted in JPEG lossless transformation

Post by helmut » Thu Jan 26, 2017 10:41 pm

When applying JPEG lossless transformation to an image with extension ".jp_", the JPEG transformation fails. End result is loss of the image.

To reproduce:
1. Copy a JPEG file and rename the extension to ".jp_"
2. In XnView browser, use Tools » JPEG lossless transformations > Rotate Clockwise
3. Confirm the "Confirm" dialog.
:arrow: XnView displays an error message: "An error occured, the lossless rotation can't be executed." :bug:
4. Confirm the error message
:arrow: The ".jp_" file is deleted and there is nothing left of it.

Note: The special extension ".jp_" causes the conflict during JPEG lossless transformation. So this problem should occur in a test scenario, only. But: Loss of images must be avoided at any rate, so XnView MP should do better, here, i.e. the JPEG lossless transformation my fail but the file shouldn't be deleted.

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: .JP_ image deleted in JPEG lossless transformation

Post by xnview » Fri Jan 27, 2017 1:43 pm

See Issue 1066 for details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: .JP_ image deleted in JPEG lossless transformation

Post by xnview » Thu Mar 16, 2017 9:12 am

This problem is supposed to be fixed in XnView MP 0.85 beta 1. Please check and confirm the bug fix here.
Pierre.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: .JP_ image deleted in JPEG lossless transformation

Post by helmut » Thu Mar 16, 2017 8:45 pm

Original problem is confirmed fixed.

Minor issue left: Message box is displayed and mouse cursor is "Wait".

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: .JP_ image deleted in JPEG lossless transformation

Post by xnview » Thu Mar 23, 2017 10:04 am

This problem is supposed to be fixed in XnView MP 0.85 beta 2. Please check and confirm the bug fix here.
Pierre.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: .JP_ image deleted in JPEG lossless transformation

Post by helmut » Thu Mar 23, 2017 7:19 pm

Confirmed fixed in 0.85 beta 2.

Post Reply