0.85b2: Videos cannot be restarted once they ended

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

0.85b2: Videos cannot be restarted once they ended

Post by helmut » Sat Mar 25, 2017 5:45 pm

XnView: MP 0.85 beta 2 - 64 bit
OS: Windows 10 - 64bit

When using the internal video player (useQtav=true) and playing a video till the end, the video cannot be restarted.

Effect: Function doesn't work as expected.

To reproduce:
1. Exit XnView
2. Edit xnview.ini and set "useQtav=true" in section [%General]
3. Start XnView
4. Open a short video in XnView's viewer. Video can be AVI, MOV, or MTS
5. Wait till the video has played till the end.
3. Try to "rewind" the video to the start using the button on the bottom right.
Actual behaviour (bug): The video cannot be restarted. :bug:

Expected behaviour: Video can not be rewinded and played for a second time.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: 0.85b2: Videos cannot be restarted once they ended

Post by Dreamer » Sun Mar 26, 2017 6:44 am

XnView: MP 0.85 beta 2 - 64 bit
OS: Windows 10 - 64bit

Confirmed. :bugconfirmed:
Try to "rewind" the video to the start using the button on the bottom right.
What do you mean by "the button on the bottom right" - the slider?

Anyway, the rewind button (next to the play button) doesn't work either.
Dreamer

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85b2: Videos cannot be restarted once they ended

Post by xnview » Tue Mar 28, 2017 9:31 am

This problem is supposed to be fixed in XnView MP 0.85 beta 3. Please check and confirm the bug fix here.
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: 0.85b2: Videos cannot be restarted once they ended

Post by Dreamer » Tue Mar 28, 2017 7:41 pm

Fixed in beta 3, thanks, Pierre.
Dreamer

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b2: Videos cannot be restarted once they ended

Post by helmut » Tue Mar 28, 2017 9:16 pm

This is not fixed in beta 3:
Actual behaviour: :bug:
When video plays till the end and you press rewind nothing happens. The black, empty screen at the end of the video is still displayed and the slide remains at 100% position.

Expected behaviour: Slider is reset to 0% and the start image of the video is shown.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: 0.85b2: Videos cannot be restarted once they ended

Post by Dreamer » Tue Mar 28, 2017 11:21 pm

OK, confirmed, it works good only if moving slider to the end manually.
Dreamer

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b2: Videos cannot be restarted once they ended

Post by helmut » Wed Mar 29, 2017 1:47 pm

Pierre: Why is this bug report in "Retest - 0.85 beta"?

User avatar
xnview
Author of XnView
Posts: 31255
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85b2: Videos cannot be restarted once they ended

Post by xnview » Wed Mar 29, 2017 5:49 pm

helmut wrote:Pierre: Why is this bug report in "Retest - 0.85 beta"?
it's fixed in beta 4
Pierre.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b2: Videos cannot be restarted once they ended

Post by helmut » Wed Mar 29, 2017 8:03 pm

Confirmed fixed in beta 4. There's a minor issue left: When rewinding the ended video starts right away. A bit unexpected but could be considered as a feature. ;)

Post Reply