[SOLVED] 0.86 0.87b3 W10 - Problem of orientation of thumbnails with photos taken in portrait mode IF tag action

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
dreg
Posts: 34
Joined: Mon Aug 21, 2017 9:34 am
Location: France

[SOLVED] 0.86 0.87b3 W10 - Problem of orientation of thumbnails with photos taken in portrait mode IF tag action

Post by dreg » Mon Aug 21, 2017 7:31 pm

Hello everyone,

I posted in french XNVIEWMP forum but perhaps i'll be more read in english section : i'm a new french - sorry for my english :( - user of XNVIEWMP 0.86 for a few weeks for the cataloging of my photos, I encounter a small problem of orientation of the thumbnails for shots taken in portrait mode: I precise, no problem displaying images taken in portrait mode in 'Preview and in View mode (after double clicking on the thumbnail) only thumbnails are problematic

1 - If I copy the photos of my memory card in a windows folder: no worries of orientation of the thumbnails to the display in XNVIEWMP so everything is OK for the thumbnails of the photos in portrait mode as long as we only do the display

2 - if I edit the IPTC / XMP data to add captions (only way to have a metadata display in google photos ...), I have the impression that the automatic rotation of the thumbnail is lost and it Appears in landscape mode.

I can not get XNVIEWMP to correct the orientation of the thumbnails if I ask to rebuild the thumbnails (XNVIEWMP gives me plumbs but if I change folder in the explorer and returns to the folder with the photos In portrait mode, the thumbnails are back in landscape mode) even after clearing the cache

I also tried by unchecking the Settings / Thumbnails / Use the built-in thumbnail option but unsuccessfully.

3-
Accuracy 1: I tested with XNVIEWMP 0.86 and 0.87 beta 3 and XNVIEW 2.40 under Windows 10 and my camera incorporates EXIF ​​orientation metadata
Accuracy 2: No problem displaying images taken in portrait mode in Preview and in View mode (after double-clicking on the thumbnail) even after changing the metadata
Accuracy 3 IMPORTANT: test with XNVIEW (no MP): there is no problem displaying the orientation of thumbnails of photos taken in portrait mode even after the modification of the metadata by XNVIEWMP
Also, no worries with the Windows Explorer, ACDSee, the thumbnails remain oriented correctly even after a metadata modification

That's why I think this is an inherent problem with XNVIEWMP

So, I hope to have been "understood" ... Thank you in advance for a possible answer ;-)

And still bravo for this wonderful soft !!! And its management of categories that can be transformed into keywords.
A big thanks to the developer(s?) ;-)
Last edited by dreg on Sat Sep 09, 2017 8:05 pm, edited 3 times in total.

dreg
Posts: 34
Joined: Mon Aug 21, 2017 9:34 am
Location: France

Re: 0.86 0.87b3 W10 - Problem of orientation of thumbnails with photos taken in portrait mode IF tag action IF tag actio

Post by dreg » Wed Aug 23, 2017 6:43 pm

Hello,

Here is how to reproduce this "bug":
1 taking a picture in portrait mode
2 copy of the photo from the memory card to the windows photos directory
3 opening of XnView MP 0.86 or 0.87 beta 3 on the photo directory
=> The thumbnail is well oriented
4 right click on thumbnail then choose Edit IPTC / XMP
5 writing a "test" tag in the caption tab and clicking on Write

Result: the thumbnail is still well oriented but the fact of changing folder in the explorer and to return to the folder containing the photo => the thumbnail rotated in landscape mode

So, to reproduce the bug, you have to write a tag by editing IPTC / XMP in the caption field, validate, change folder in the XnViewMP explorer and return to the folder containing the tagged photo.

The only parade that I found: when the thumbnail is misaligned following the tag, click on "Rebuild thumbnails" from the menu Display, which puts the thumbnail of plumb, go in the "Options" of XnViewMP, options "Catalog" and clear the folder cache containing the photo in portrait mode and exit the options.

There, the thumbnail remains in portrait mode even if you change folder or if you open and reopen XnViewMP.

Here, I hope that you will be able to reproduce this "bug"

Thank you in advance and again bravo for this great app.

EDIT of 06/09/2017: in fact, even the previous manipulation does not work !

to put the vignettes in good direction, you must:
1- in the explorer, rebuild the thumbnails of the folder being displayed : they are in the goog direction
2- go to Options/Catalog and button Optimizations ... : check only delete the thumbnails and validate
3- Uncheck Use the thumbnails cache
4- Validate the Options window

But this permanently prevents us from using the thumbnail cache because if we re-activate the thumbnails turn in the wrong direction :(
Last edited by dreg on Wed Sep 06, 2017 9:52 am, edited 2 times in total.

dreg
Posts: 34
Joined: Mon Aug 21, 2017 9:34 am
Location: France

Re: 0.86 0.87b3 W10 - Problem of orientation of thumbnails with photos taken in portrait mode IF tag action

Post by dreg » Thu Aug 24, 2017 9:54 am

Last but not least, if you delete in XnViewMP, the photo with the wrongly oriented thumbnail (by right clicking on the thumbnail / delete) and restoring it from the windows bin, the thumbnail resumes its correct orientation ...
Last edited by dreg on Wed Sep 06, 2017 9:52 am, edited 1 time in total.

dreg
Posts: 34
Joined: Mon Aug 21, 2017 9:34 am
Location: France

Re: 0.86 0.87b3 W10 - Problem of orientation of thumbnails with photos taken in portrait mode IF tag action

Post by dreg » Wed Sep 06, 2017 9:51 am

EDIT of 06/09/2017: in fact, even the previous manipulation does not work !

to put the vignettes in good direction, you must:
1- in the explorer, rebuild the thumbnails of the folder being displayed : they are in the goog direction
2- go to Options/Catalog and button Optimizations ... : check only delete the thumbnails and validate
3- Uncheck Use the thumbnails cache
4- Validate the Options window

But this permanently prevents us from using the thumbnail cache because if we re-activate the thumbnails turn in the wrong direction :(

dreg
Posts: 34
Joined: Mon Aug 21, 2017 9:34 am
Location: France

Re: 0.86 0.87b3 W10 - Problem of orientation of thumbnails with photos taken in portrait mode IF tag action

Post by dreg » Sat Sep 09, 2017 8:03 pm

Problem solved in 0.87 final.
Thank you.

Post Reply