0.87: Ctrl-C doesn't copy in Viewer Mode

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
Daeva
Posts: 1
Joined: Tue Sep 12, 2017 3:10 am

0.87: Ctrl-C doesn't copy in Viewer Mode

Post by Daeva » Tue Sep 12, 2017 3:30 am

XnView: MP 0.87 - 64 bit
OS: Windows 10 Pro 64bit

Ctrl-C doesn't copy images in Viewer mode in 0.87 MP like it did in previous versions.

Effect: Instead of copying, it clears your current clipboard information.

To reproduce:
1. Select an image and go into Viewer mode.
2. Press Ctrl-C.
3. Try to paste anywhere, e.g. File explorer/Browser (uploading image)

Actual behaviour (bug): When you paste nothing happens, it doesn't copy the image or give you the file path if you're uploading the image. Instead it will clear your clipboard.

Expected behaviour: Copy image or give you file path if you're uploading the image.

User avatar
xnview
Author of XnView
Posts: 29493
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.87: Ctrl-C doesn't copy in Viewer Mode

Post by xnview » Tue Sep 12, 2017 9:51 am

O.k., thank you, I can also reproduce the problem. Issue 1301 is fixed in next version.

It's a problem with this fix
Pierre.

User avatar
deus-ex
Posts: 94
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: 0.87: Ctrl-C doesn't copy in Viewer Mode

Post by deus-ex » Wed Sep 13, 2017 7:36 am

Actually the copy function does work, it is the paste command that appears to be broken in v0.87.

When copying anything in View mode, the Edit menu entry "Paste" remains grayed out and you cannot paste the copied content anywhere in XnView. However switching (ALT+TAB) to any other image application, the copied content from XnView can be pasted there from the clipboard.
Best regards,
deus-ex

User avatar
xnview
Author of XnView
Posts: 29493
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.87: Ctrl-C doesn't copy in Viewer Mode

Post by xnview » Fri Nov 03, 2017 1:06 pm

This problem is supposed to be fixed in XnView MP 0.88. Please check and confirm the bug fix here.
Pierre.

User avatar
deus-ex
Posts: 94
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: 0.87: Ctrl-C doesn't copy in Viewer Mode

Post by deus-ex » Fri Nov 03, 2017 10:34 pm

I confirm that this problem is fixed in XnView MP 0.88. Thank you.
Best regards,
deus-ex

Post Reply