Page 1 of 1

0.87 / Win 10: "Open with" path parsing

Posted: Fri Oct 27, 2017 1:59 pm
by dergilbwillspam
XnView MP: Version 0.87 64bits (Sep 7 2017)
OS: Windows 10 Pro FCU 64bit

"Open with" fails if path contains percent sign followed by number.

Effect: Target program doesn't open file.

To reproduce:

1. Have a path like d:\%1\test.jpg
2. Have a program like MSPaint or Paint.NET configured in "Open with" in XnView
3. Try to open the file in target program with "Open with"

Actual behavior (bug): Target program doesn't open the file because path is not parsed correctly. :bug:

Expected behavior: Target program opens the file

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Sun Oct 29, 2017 2:40 pm
by xnview
:bugconfirmed: Thanks to your detailed description I can reproduce the problem.

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Fri Nov 03, 2017 1:04 pm
by xnview
This problem is supposed to be fixed in XnView MP 0.88. Please check and confirm the bug fix here.

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Tue Nov 14, 2017 1:55 am
by dergilbwillspam
This problem is supposed to be fixed in XnView MP 0.88. Please check and confirm the bug fix here.
Clicking the programs works now, but the "Open with" shortcuts (alt + number) still do not (same error as before: File not found.) :bug:

Sorry for not being able to respond sooner.

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Wed Nov 15, 2017 1:43 pm
by xnview
dergilbwillspam wrote: Clicking the programs works now, but the "Open with" shortcuts (alt + number) still do not (same error as before: File not found.) :bug:
No problem with shortcut in browser mode, but can't be opened in edit mode

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Wed Nov 15, 2017 4:08 pm
by dergilbwillspam
No problem with shortcut in browser mode, but can't be opened in edit mode
I didn't notice this, but you're right.

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Sat Dec 30, 2017 2:45 pm
by xnview
This problem is supposed to be fixed in XnView MP 0.89. Please check and confirm the bug fix here.

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Wed Aug 15, 2018 2:37 pm
by dergilbwillspam
xnview wrote:
Sat Dec 30, 2017 2:45 pm
This problem is supposed to be fixed in XnView MP 0.89. Please check and confirm the bug fix here.
Oops, sorry. There's still a problem. Trying to pinpoint it right now.

[Edit: Update to 0.90 fixed this second error I had with 0.89. Thank you!]

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Wed Aug 29, 2018 7:52 am
by xnview
dergilbwillspam wrote:
Wed Aug 15, 2018 2:37 pm
Oops, sorry. There's still a problem. Trying to pinpoint it right now.
which problem?

Re: 0.87 / Win 10: "Open with" path parsing

Posted: Wed Dec 05, 2018 10:48 pm
by dergilbwillspam
Sorry again for not being a regular here. You already fixed whatever problem there was left with 0.90, thank you.