0.89: don't read XMP keywords no more

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

User avatar
Sirio
Posts: 113
Joined: Tue Oct 13, 2015 3:22 pm

0.89: don't read XMP keywords no more

Post by Sirio » Tue Jan 23, 2018 1:52 pm

XnViewMP 0.89 64 bit
OS: Windows

Since the 0.89 XnViewMP version can not read the keywords from the XMP sidecar files.
In the info TAB at the XMP section, but when I select the files and I do:

Menu> View "Update catalog from files", no keywords are imported.
I Mean, in the Category Set window, in the tab "Assigned" there is nothing and neither in the "Filter Categories" tab.

Actual behaviour (bug): <Current wrong behaviour of XnViewMP> :bug:
Sirio

User avatar
michel038
Posts: 250
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: 0.89: don't read XMP keywords no more

Post by michel038 » Tue Jan 23, 2018 10:23 pm

That's right.
I tried it,
like Sirio, "Update catalog from files" doesn't assign categories, even if "import keywords in categories" is marked

But when using "settings, catalog, add files" , the catalog will be correctly updated, and categories are OK

Method:
I have a raw file pict01.ORF (olympus raw file)
I'll use a jpeg file DSC222.JPG , having categories animal and cat

I select DSC222.JPG and create a XMP sidecar using "open with" function in Xnviewmp:
( I prepared this feature to use exiftool with -o %d%f.xmp -xmp parameters)
exiftool -o %d%f.xmp -xmp
so I get a file DSC222.XMP containing :

Code: Select all

(other lines)
<dc:subject>
            <rdf:Bag>
               <rdf:li>animal</rdf:li>
               <rdf:li>cat</rdf:li>
            </rdf:Bag>
</dc:subject>
I rename this file pict01.xmp ,
Now pict01.ORF has a sidecar .

in "settings, catalog" , I delete the folder containing this picture, and then I "add" the folder.
Now, categories and keywords are correct.

User avatar
xnview
Author of XnView
Posts: 30283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.89: don't read XMP keywords no more

Post by xnview » Wed Jan 24, 2018 6:35 am

please send me a sample file
Pierre.

User avatar
Sirio
Posts: 113
Joined: Tue Oct 13, 2015 3:22 pm

Re: 0.89: don't read XMP keywords no more

Post by Sirio » Wed Jan 24, 2018 3:41 pm

Here the picture:
https://www.dropbox.com/s/5odojwsi19adk ... 0.JPG?dl=0
Here the XMP:
https://www.dropbox.com/s/6qrgcnkw5nchd ... 0.xmp?dl=0

I tested now, this problem was already present in the v89 Beta2
Sirio

User avatar
xnview
Author of XnView
Posts: 30283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.89: don't read XMP keywords no more

Post by xnview » Fri Jan 26, 2018 12:22 pm

I can't reproduce, if you put this file in a empty folder, same problem??
No problem with 0.88?
Attachments
Clipboard-1.jpg
Pierre.

User avatar
Sirio
Posts: 113
Joined: Tue Oct 13, 2015 3:22 pm

Re: 0.89: don't read XMP keywords no more

Post by Sirio » Fri Jan 26, 2018 2:59 pm

OK, I solved the problem, it's up to me:

I just do something that until now had worked for all previous versions and that apparently it doesn't works for this version:
In order to have my XnViewMP always as I like, I saved in a folder the content of Settings folder (%appdata%\XnViewMP), in a backup folder, then on a new installation or when something goes bad, I just copy my backup settings files and paste them, therefore replace all the files present in the settings folder of XnVieMP.
Apparently, this time the version 0.89 is not compatible with the 0.88 settings files and create this bug.

Solution: Make a clean installation from scratch.
I will try it soon.
Last edited by Sirio on Fri Jan 26, 2018 4:33 pm, edited 1 time in total.
Sirio

User avatar
Sirio
Posts: 113
Joined: Tue Oct 13, 2015 3:22 pm

Re: 0.89: don't read XMP keywords no more

Post by Sirio » Fri Jan 26, 2018 4:33 pm

I am sorry for the previous illusion that I could give you. :?
There is a problem and I have identified it:

If I go in -> Tools > Settings > Browser > Metadata
And the first option: "Import XMP subject or IPTC keyword to DB Categories." is unchecked, then no Categories are imported from the xmp sidecarfile doing nothing (it is normal), but even if I do manually -> "Update catalog from files" ! No Categories are imported.
This is not normal.

If I check the option: "Import XMP subject or IPTC keyword to DB Categories."
XnVieMP automatically import the Categories in the Categories panel and in the "Category Set" panel.
Well, but if I do again manually -> "Update catalog from files", the Categories disappear suddenly. Which is not normal, and this behaviour not happen in the previous versions.
Sirio

User avatar
xnview
Author of XnView
Posts: 30283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.89: don't read XMP keywords no more

Post by xnview » Mon Jan 29, 2018 9:45 am

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

User avatar
Sirio
Posts: 113
Joined: Tue Oct 13, 2015 3:22 pm

Re: 0.89: don't read XMP keywords no more

Post by Sirio » Mon Jan 29, 2018 1:11 pm

Thank you Pierre. :D
J'ai hâte de tester la version Beta.
Sirio

User avatar
xnview
Author of XnView
Posts: 30283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.89: don't read XMP keywords no more

Post by xnview » Mon Feb 12, 2018 10:12 am

This problem is supposed to be fixed in XnView MP 0.90. Please check and confirm the bug fix here.
Pierre.

User avatar
Sirio
Posts: 113
Joined: Tue Oct 13, 2015 3:22 pm

Re: 0.89: don't read XMP keywords no more

Post by Sirio » Mon Feb 12, 2018 3:12 pm

Problem not solved:
I have done: Select all JPG -> View > "Update catalog from files"
You can see as well in the "Categories" panel as in the Category set in Assigned, nothing has been imported.
XMP_not_read-01.png
With this configuration:
XMP_not_read-02.png
Sirio

User avatar
michel038
Posts: 250
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: 0.89: don't read XMP keywords no more

Post by michel038 » Mon Feb 12, 2018 9:13 pm

And if the first option is marked ? (import xmp subject ...to db categories)

User avatar
xnview
Author of XnView
Posts: 30283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.89: don't read XMP keywords no more

Post by xnview » Tue Feb 13, 2018 7:53 am

the 'import subject' must be checked
Pierre.

User avatar
Sirio
Posts: 113
Joined: Tue Oct 13, 2015 3:22 pm

Re: 0.89: don't read XMP keywords no more

Post by Sirio » Tue Feb 13, 2018 9:38 am

With the option "Import XMP subject or IPTC keyword to DB Categories" checked, it works.

The strange thing is that before it worked with this option UNchecked. May be the bug was before?
Anyway, now it works.
Thanks
Sirio

User avatar
xnview
Author of XnView
Posts: 30283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.89: don't read XMP keywords no more

Post by xnview » Tue Feb 13, 2018 9:56 am

Sirio wrote:With the option "Import XMP subject or IPTC keyword to DB Categories" checked, it works.

The strange thing is that before it worked with this option UNchecked. May be the bug was before?
Anyway, now it works.
Thanks
hum yes, i think. The bug was with settings checked, and categories disapear after using "Update catalog from files"
Pierre.

Post Reply