0.92: Searching by Image Width and Image Height Returns 0 Results

Moderators: XnTriq, helmut, cday, xnview, Dreamer

Post Reply
wolgan
Posts: 2
Joined: Thu Jun 22, 2017 6:18 am

0.92: Searching by Image Width and Image Height Returns 0 Results

Post by wolgan » Mon Oct 29, 2018 2:46 pm

XnView: MP 0.92 - 64 bit
OS: Windows 10 Home Ver. 1803 Build (17134.345) 64bit

Searching by Image Width and Image Height and selecting Use Catalog returns 0 results after upgrading from 0.90 to 0.92.
Tested this with existing db files as well as a newly created db file. Behavior was the same with both.

Effect: Unable to search a folder for images meeting a certain height/width criteria

To reproduce:
1. Enter a folder with images (test folder included GIF 89a, JPEG TrueColor 1.1, and PNG)
2. Enter Thumbnail mode and wait for scan to finish
3. Verify in Tools > Settings > Catalog that the folder has been populated in the database
4. Select Search (Used CTRL-F and also selected from Tools Menu)
5. Select Image Width and/or Image Height from the Add >> menu
6. Enter any criteria under the Conditions, select either Match All, or Match Any
7. Check the Use Catalog checkbox
8. Click Search

Actual behaviour (bug): Search returns 0 file(s) found :bug:

Expected behaviour: Search returns any images that meet the criteria selected

User avatar
xnview
Author of XnView
Posts: 30106
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Searching by Image Width and Image Height Returns 0 Results

Post by xnview » Mon Nov 05, 2018 12:13 pm

:bugconfirmed: Thanks to your detailed description I can reproduce the problem
Pierre.

Post Reply