Prev/Next not working with two or more opened tabs

Moderators: cday, XnTriq, helmut, xnview, Dreamer

Qrzysio
Posts: 10
Joined: Mon Jul 14, 2014 12:00 pm

Prev/Next not working with two or more opened tabs

Post by Qrzysio » Wed Feb 06, 2019 6:01 am

Why can't we move to the next/prev image, when two or more tabs are open? It works if there is only one image (tab) opened.
In the newest version we can use "space" to open the next picture, and it works even when two or more tabs opened.
Last edited by Qrzysio on Thu Feb 07, 2019 6:57 am, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 31109
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Prev/Next not working with two or more opened tabs

Post by xnview » Wed Feb 06, 2019 9:04 am

Which OS?
Pierre.

User avatar
deus-ex
Posts: 147
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: Prev/Next not working with two or more opened tabs

Post by deus-ex » Wed Feb 06, 2019 11:30 am

Just for the record, moving to the next/prev image using [Page-Up/Down] with two or more tabs open works fine here, running XnViewMP v0.93 64-bit on Windows 10 64-bit build 1809.
Best regards,
deus-ex

Qrzysio
Posts: 10
Joined: Mon Jul 14, 2014 12:00 pm

Re: Prev/Next not working with two or more opened tabs

Post by Qrzysio » Thu Feb 07, 2019 6:57 am

I work on Windows 10 Home, and this is not about Page-Up/Down keys. I use left/right arrows.

User avatar
deus-ex
Posts: 147
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: Prev/Next not working with two or more opened tabs

Post by deus-ex » Thu Feb 07, 2019 7:59 am

Qrzysio wrote:
Thu Feb 07, 2019 6:57 am
I work on Windows 10 Home, and this is not about Page-Up/Down keys. I use left/right arrows.
By default Page-up/down are the defined keys for the command 'Next/Previous file'. Assigning the left/right cursor-keys to that functions works as intended, too.
Best regards,
deus-ex

User avatar
xnview
Author of XnView
Posts: 31109
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Prev/Next not working with two or more opened tabs

Post by xnview » Thu Feb 07, 2019 8:08 am

you start XnView, open some tabs, and arrows are not working in any tab?
Pierre.

Qrzysio
Posts: 10
Joined: Mon Jul 14, 2014 12:00 pm

Re: Prev/Next not working with two or more opened tabs

Post by Qrzysio » Thu Feb 07, 2019 11:37 am

The scenario:
1. Open an image (double-click on a file and open XnViewMP).
2. Close XnViewMP by clicking the "X" button in the right top corner.
3. Go to a different folder on the disk and open a random file (double-click).
4. XnViewMP starts with two opened tabs: the first one with the previous file and the second one with a file I have opened just now. The second tab is active.

In this scenario, the left/right arrow keys are not working.

Keys start to work again when I switch to another tab and then switch back to the second one or I close the first tab.

This is not a new bug. I deal with it for a long time.

My settings:
- Open browser in "normal" mode,
- Startup directory: "Last".

User avatar
xnview
Author of XnView
Posts: 31109
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Prev/Next not working with two or more opened tabs

Post by xnview » Tue Feb 19, 2019 8:14 am

i've sent you a PM
Pierre.

User avatar
xnview
Author of XnView
Posts: 31109
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Prev/Next not working with two or more opened tabs

Post by xnview » Fri Feb 22, 2019 4:21 pm

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

Qrzysio
Posts: 10
Joined: Mon Jul 14, 2014 12:00 pm

Re: Prev/Next not working with two or more opened tabs

Post by Qrzysio » Sat Feb 23, 2019 4:11 am

Good job. Thank you.

User avatar
xnview
Author of XnView
Posts: 31109
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Prev/Next not working with two or more opened tabs

Post by xnview » Thu Mar 07, 2019 4:01 pm

This problem is supposed to be fixed in XnView MP 0.93.1. Please check and confirm the bug fix here.
Pierre.

potkoorok
Posts: 2
Joined: Tue Mar 12, 2019 9:38 pm

Re: Prev/Next not working with two or more opened tabs

Post by potkoorok » Tue Mar 12, 2019 9:45 pm

xnview wrote:
Thu Mar 07, 2019 4:01 pm
This problem is supposed to be fixed in XnView MP 0.93.1. Please check and confirm the bug fix here.
I confirm that even after installing this update (version 0.93.1) the issue still persists on my computer (Windows 10 Home). This issue started fairly recently with version 0.92, up until then this version worked OK.

User avatar
xnview
Author of XnView
Posts: 31109
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Prev/Next not working with two or more opened tabs

Post by xnview » Wed Mar 13, 2019 9:44 am

potkoorok wrote:
Tue Mar 12, 2019 9:45 pm
xnview wrote:
Thu Mar 07, 2019 4:01 pm
This problem is supposed to be fixed in XnView MP 0.93.1. Please check and confirm the bug fix here.
I confirm that even after installing this update (version 0.93.1) the issue still persists on my computer (Windows 10 Home). This issue started fairly recently with version 0.92, up until then this version worked OK.
how do you reproduce?
Pierre.

Qrzysio
Posts: 10
Joined: Mon Jul 14, 2014 12:00 pm

Re: Prev/Next not working with two or more opened tabs

Post by Qrzysio » Fri Mar 15, 2019 4:07 pm

I did a clean installation on freshly installed Windows OS. The newest version of XnViewMP is free of this bug. Thank you for your support.

potkoorok
Posts: 2
Joined: Tue Mar 12, 2019 9:38 pm

Re: Prev/Next not working with two or more opened tabs

Post by potkoorok » Tue Mar 19, 2019 11:22 pm

how do you reproduce?
  1. I double-click and open the first file. While only one tab is open, I can use my mouse wheel or the "Next" or "Previous" arrows on the menu to cycle through the files in that folder.
  2. I then open another tab, by dragging a file from this same folder, or another folder onto the program. In this tab, "Next" or "Previous" via the arrows or the mouse does not work.
  3. The original (first) tab that is open still works as before - next etc. working OK. If I close this first tab, the remaining (second) tab still does not work.
  4. Any other tabs that I now open (after the second non-working tab), also do not work.
:(

Post Reply