0.86: Fixed Ratio crop not working

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

richlux
Posts: 6
Joined: Fri Jun 30, 2017 12:14 am

0.86: Fixed Ratio crop not working

Postby richlux » Fri Jun 30, 2017 4:48 am

XnView: MP 0.86 - 64 bit
OS: Windows 7 64bit

Fixed ratio cropping does not seem to work. When dragging the selection box, it is locked to some ratio, but it is not the ratio of the current image. It gets worse if you work with multiple images with very different aspect ratios.

Effect: Selected area does not follow aspect ratio of image

To reproduce:
1. Open an image with a large difference between X and Y aspect ratio (e.g. 10:1)
2. Click on the crop icon to enter crop mode
3. Click the left mouse button and start selecting an area. you may notice the area is not locked to the aspect ratio of the image
4. Close the current image and open a new one with a large difference between X and Y aspect ratio opposite the first image (e.g. 1:10)
5. Click the left mouse button and start selecting an area. you may notice the area is still locked to the aspect ratio of the first image or it may not be locked to either of them.

Actual behaviour (bug): Selected area does not match current image aspect ratio

Expected behaviour: Selected area should match current image aspect ratio

Thanks,
Rich

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Fixed Ratio crop not working

Postby xnview » Fri Jun 30, 2017 12:02 pm

Ok, i'll set the ratio value with ratio of picture
Pierre.

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Fixed Ratio crop not working

Postby xnview » Sat Jul 08, 2017 12:12 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.

HanVroon
Posts: 176
Joined: Thu Jan 28, 2010 7:30 am

Re: 0.86: Fixed Ratio crop not working

Postby HanVroon » Fri Sep 01, 2017 12:09 pm

Tested with 0.87 beta 3, not fixed (if I understand the bug and the fix :wink: )

I never used "Fixed ratio" because I didn't understand what it was supposed to do, now I understand.

First of all, one step is missing in "To reproduce", you have to select "Fixed ratio" between step 2 and 3.

You replied with "Ok, i'll set the ratio value with ratio of picture".

I have tested with normal full frame camera images (3:2), portrait and landscape pictures.
In both case, when entering Crop mode and selecting Fixed ratio, I get a rectangle that is more widescreen, not covering the whole image.
As an example, when cropping a 3:2 image with Fixed ratio selected, dragging the box, when horizontal is at 1500, vertical should be at 1000, but it is at 819.

Found some pictures from another camera with aspect ratio 4:3, there Fixed ratio also doesn't work (when dragging horizontal to 2000, vertical should bet at 1500, but is at 1092).

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Fixed Ratio crop not working

Postby xnview » Sun Sep 03, 2017 2:12 pm

right
Pierre.

HanVroon
Posts: 176
Joined: Thu Jan 28, 2010 7:30 am

Re: 0.86: Fixed Ratio crop not working

Postby HanVroon » Mon Sep 11, 2017 3:45 pm

Tested with 0.87 final, partly fixed (I think)

Now, when entering Crop mode and choosing Fixed ratio, with landscape pictures the ratio follows the ratio of the picture.

But with portrait pictures, the ratio for the crop rectangle is also landscape, not portrait like the picture.

One can click on the <> button to change that, but is this how it should work?

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Fixed Ratio crop not working

Postby xnview » Tue Sep 12, 2017 9:26 am

HanVroon wrote:One can click on the <> button to change that, but is this how it should work?

right
Pierre.

HanVroon
Posts: 176
Joined: Thu Jan 28, 2010 7:30 am

Re: 0.86: Fixed Ratio crop not working

Postby HanVroon » Sat Sep 16, 2017 8:27 am

Hi Pierre,

What do you mean with "Right"?

That it is not possible to let Fixed ration always be the same as image ratio, so portrait when the image is portrait, landscape when the image is landscape? I thought that that is what you ment with "Ok, i'll set the ratio value with ratio of picture".
Like in Classic, where it was called "Same as image"?

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Fixed Ratio crop not working

Postby xnview » Sat Sep 16, 2017 9:19 am

right it's a bug :)
Pierre.

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Fixed Ratio crop not working

Postby xnview » Fri Nov 03, 2017 1:06 pm

This problem is supposed to be fixed in XnView MP 0.88. Please check and confirm the bug fix here.
Pierre.

HanVroon
Posts: 176
Joined: Thu Jan 28, 2010 7:30 am

Re: 0.86: Fixed Ratio crop not working

Postby HanVroon » Wed Nov 22, 2017 3:56 pm

Tested with version 0.88, fixed.

Portrait pictures cropping follows the aspect ratio of the picture when Fixed is selected.
I know I should'n mention it here, but it would be nice if the choosen aspect ratio is remembered, I think :D


Return to “Closed/Resolved”

Who is online

Users browsing this forum: No registered users and 0 guests