"ultralong" file names

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
bdragon
Posts: 107
Joined: Mon May 01, 2017 8:06 am

"ultralong" file names

Post by bdragon » Thu Sep 07, 2017 12:51 pm

Due to deep directory tree some of my files have ... Let's call it: an ultralong name.

There is a a way to enable them in windows. It is not enabled by default for compatibility.

I see that in the latest xnview this was "disabled".

What i ask is: does it check with the system what i the maximum length? (In my case i set it to 65535) or does it have an internal variable i would need to change?

I need to know before upgrading

User avatar
xnview
Author of XnView
Posts: 29916
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "ultralong" file names

Post by xnview » Thu Sep 07, 2017 12:57 pm

:( i don't know how to check if it's enabled or not, so currently it's 256 chars. I'll add a setting to disable this path checking
Pierre.

bdragon
Posts: 107
Joined: Mon May 01, 2017 8:06 am

Re: "ultralong" file names

Post by bdragon » Thu Sep 07, 2017 2:30 pm

By default it's 256 characters

However one can create a key named "LongPathsEnabled" in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem".

So just check for that one key and its value.

If there is no key, then it's 256 characters (for Windows NT compatibility), otherwise it's 65535 if it's set to 1.

It only works on windows 10 and "above" (i hope).

User avatar
xnview
Author of XnView
Posts: 29916
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "ultralong" file names

Post by xnview » Tue May 15, 2018 8:52 am

See issue for current status and some details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 29916
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "ultralong" file names

Post by xnview » Thu Jun 07, 2018 9:39 am

This problem is supposed to be fixed in XnView MP 0.91. Please check and confirm the bug fix here.
Pierre.

Post Reply