severe batch convert bug

Moderators: XnTriq, helmut, cday, xnview, Dreamer

Post Reply
User avatar
toyotadesigner
Posts: 25
Joined: Sun Apr 10, 2016 7:15 am

severe batch convert bug

Post by toyotadesigner » Wed Oct 17, 2018 12:20 pm

OS X 10.11.6 (15G31) El Capitan
Xn View MP 0.92

I have set up a process to convert JPEG images of a size of 1.500 x 1.000 pixels to a size of 660 x 440 pixels.

Set the 'Output Folder' to 'Source Folder'.

Saved this as 'blog.xbs'.

Now I open 'Batch Convert', select the 'blog.xbs', and the 'Source Folder' is no longer selected, but some weird folder:
Screen Shot 2018-10-17 at 07.35.27.png
No matter what I do, 'Batch Convert' always uses the weird folder instead of the 'Source Folder'

If I don't check all settings, my converted images end up somewhere, but never in the 'Source Folder'.

Would you please be so kind an correct this annoying bug?

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
xnview
Author of XnView
Posts: 30220
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: severe batch convert bug

Post by xnview » Fri Oct 19, 2018 1:17 pm

could you send the blog.xbs?
Pierre.

User avatar
toyotadesigner
Posts: 25
Joined: Sun Apr 10, 2016 7:15 am

Re: severe batch convert bug

Post by toyotadesigner » Sat Oct 20, 2018 12:32 pm

I try to post it here.
Attachments
blog.xbs.zip
(577 Bytes) Downloaded 5 times

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
xnview
Author of XnView
Posts: 30220
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: severe batch convert bug

Post by xnview » Mon Oct 22, 2018 8:20 am

the pathname in 'Folder' is an old used folder, it's not in the .xbs
But the bug is that 'source folder' should be selected
Pierre.

User avatar
toyotadesigner
Posts: 25
Joined: Sun Apr 10, 2016 7:15 am

Re: severe batch convert bug

Post by toyotadesigner » Wed Oct 24, 2018 4:55 am

I restarted Xnview.
I deleted all *.xbs files
I recreated the action
I selected 'Folder'
I saved the action

Problem is still there. Something must be stored somewhere in the programm, but I don't know where.

When I edit the *.xbs file with BBEDIT and remove in the line '<Output ' the element 'folder="" ', everything is ok.

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

User avatar
xnview
Author of XnView
Posts: 30220
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: severe batch convert bug

Post by xnview » Wed Oct 24, 2018 6:45 am

it's saved in ~/.config/xnview/xnview.ini
Pierre.

User avatar
toyotadesigner
Posts: 25
Joined: Sun Apr 10, 2016 7:15 am

Re: severe batch convert bug

Post by toyotadesigner » Wed Oct 24, 2018 8:55 pm

Pierre,

I've edited the xnview.ini - now everything seems to be perfect.

There were two paths to folders in History= which I deleted.

In the folder I've found a hidden .xnviewmp folder. I moved it to the desktop and restarted xnview - it still works. So it seems that the hidden folder is not needed any longer (from a previous version?).

hobbyists discuss new camera features
photographers discuss new software
masters discuss light

Post Reply