Wrong Collage

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
Lupus52
Posts: 3
Joined: Thu Jul 27, 2017 7:16 am

Wrong Collage

Post by Lupus52 » Thu Jul 27, 2017 8:53 am

Hello,

I found the following BUG.

I have 165 JPGs. (large geo-map). Collaged should this be a map with 10 Rows and 15 Columns.

The JPGs are squareformat. 700x700

Only the last colum and the last row have another sitze.

The most right pictures have the same hight like all. But only 200 in width

The lowest JPGs have full width like the other but only a hight of 400

And the absolute last is 200 x 400

XNVIEW adds the last JPG in a row correct. I have 14 and a half Pictures side by side

But the lowest row ist scrambeld. XNVIEW tries to stretch the absolute last JPG in 2 directions. Ans with the result ist deforms the othe in the last row.

I have reduced my 165 JPGs for testing to 15. It means 3 rows with 5 cols.

Image

Explorer shows the last picture stretched. It has only 200x400



When I use the collagefunktion the result looks like this:

Image

This is scrambeld too in the last row.

The 1. and the 2. Rows are ok. The last (3.) row starts correct. But the rest is stretched to 1 1/2 rows

I have placed these 15 JPGs in http://www.gerud.de/XNVIEW/Testmap.zip

It would nice if you can fix this bug (unnecessary stretching the last row/col picture)

Lupus52
Posts: 3
Joined: Thu Jul 27, 2017 7:16 am

Re: Wrong Collage

Post by Lupus52 » Thu Sep 21, 2017 11:53 am

No answer :x

User avatar
XnTriq
Moderator & Librarian
Posts: 5311
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Wrong Collage

Post by XnTriq » Thu Sep 21, 2017 10:45 pm

Confirmed :bugconfirmed:
p145414.gif
Expected result (Click on preview opens animation)

Lupus52
Posts: 3
Joined: Thu Jul 27, 2017 7:16 am

Re: Wrong Collage

Post by Lupus52 » Fri Sep 22, 2017 5:37 am

XnTriq wrote:Confirmed :bugconfirmed:

p145414.gif
Hello and thank you for the answer. But I don't understand it.

Is the bug report accepted or is the the bug fixed? You show a nice GIF with a correct displaying of te map. What do you want so say?

Best regards

User avatar
XnTriq
Moderator & Librarian
Posts: 5311
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Wrong Collage

Post by XnTriq » Fri Sep 22, 2017 11:30 am

Hello Lupus52

I'm sorry you had to wait for a response to your bug report. Pierre (the developer of XnView) will have to look into the problem.
I created that GIF animation to illustrate how these “tiles” need to be stitched together for the correct outcome.

User avatar
xnview
Author of XnView
Posts: 30018
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Wrong Collage

Post by xnview » Fri Sep 22, 2017 11:50 am

ok, the problem can be reproduced. Issue 1308 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 30018
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Wrong Collage

Post by xnview » Fri Nov 03, 2017 1:05 pm

This problem is supposed to be fixed in XnView MP 0.88. Please check and confirm the bug fix here.
Pierre.

User avatar
xnview
Author of XnView
Posts: 30018
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Wrong Collage

Post by xnview » Sat Dec 30, 2017 2:45 pm

This problem is supposed to be fixed in XnView MP 0.89. Please check and confirm the bug fix here.
Pierre.

HanVroon
Posts: 206
Joined: Thu Jan 28, 2010 7:30 am

Re: Wrong Collage

Post by HanVroon » Wed Jan 10, 2018 4:53 pm

Reproduced in 0.87 with the 15 provided images.
Tested with 0.88 and 0.89 beta 2, Fixed.
The collage is now correctly built.

User avatar
XnTriq
Moderator & Librarian
Posts: 5311
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Wrong Collage

Post by XnTriq » Mon Jan 15, 2018 9:45 pm

HanVroon wrote:Reproduced in 0.87 with the 15 provided images.
Tested with 0.88 and 0.89 beta 2, Fixed.
The collage is now correctly built.
Confirmed :bugfixed:

Post Reply