.NET Compact Framework problem

Discussions on XnView for PocketPC

Moderators: XnTriq, xnview

MioC310x
Posts: 3
Joined: Fri Dec 01, 2006 3:43 am

.NET Compact Framework problem

Postby MioC310x » Fri Dec 01, 2006 3:54 am

I bought a Mio C310x and hacked it so I can use it as a Pocket PC. It works great, but there must be something left undone because none of the programs that (seem to) depend upon the .NET Compact Framework will run. And that includes XnView. I installed the EXE while Actively Synced to my Mio, and it installed, but when I run it I get an error.

If I install the 1.0 edition, SP3, I get an error stating that this version of .NET isn't new enough to support XnView.

If I install the 2.0 edition on my PC, it appears to install on my Mio but a window flashes only briefly on my Mio screen and then vanishes. I don't think it installs because it's not listed as a removable program in the Control Panel. When I run XnView after installing .NET 2.0 I get an error, but it's not the "this version isn't new enough." The error I get is "cannot find XnPocket".

Can someone tell me exactly which version of .NET is required for XnView? And how can I get 2.0 to install on my C310x?

Thanks!

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: .NET Compact Framework problem

Postby xnview » Fri Dec 01, 2006 7:00 am

MioC310x wrote:I bought a Mio C310x and hacked it so I can use it as a Pocket PC. It works great, but there must be something left undone because none of the programs that (seem to) depend upon the .NET Compact Framework will run. And that includes XnView. I installed the EXE while Actively Synced to my Mio, and it installed, but when I run it I get an error.

If I install the 1.0 edition, SP3, I get an error stating that this version of .NET isn't new enough to support XnView.

If I install the 2.0 edition on my PC, it appears to install on my Mio but a window flashes only briefly on my Mio screen and then vanishes. I don't think it installs because it's not listed as a removable program in the Control Panel. When I run XnView after installing .NET 2.0 I get an error, but it's not the "this version isn't new enough." The error I get is "cannot find XnPocket".

Can someone tell me exactly which version of .NET is required for XnView? And how can I get 2.0 to install on my C310x?

Thanks!

XnView doesn't use .NET!! Is it an ARM processor?
Pierre.

MioC310x
Posts: 3
Joined: Fri Dec 01, 2006 3:43 am

Postby MioC310x » Fri Dec 01, 2006 12:27 pm

Hmmm...yes, it's an ARM. Is that good or bad? lol

MioC310x
Posts: 3
Joined: Fri Dec 01, 2006 3:43 am

Re: .NET Compact Framework problem

Postby MioC310x » Fri Dec 01, 2006 12:29 pm

XnView doesn't use .NET!! Is it an ARM processor?


Why does it tell me that "this version of .NET isn't new enough to support XnView" if it doesn't use it?

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: .NET Compact Framework problem

Postby xnview » Fri Dec 01, 2006 1:35 pm

MioC310x wrote:
XnView doesn't use .NET!! Is it an ARM processor?


Why does it tell me that "this version of .NET isn't new enough to support XnView" if it doesn't use it?

Sorry but i don't know...
Pierre.


Return to “XnView Pocket”

Who is online

Users browsing this forum: No registered users and 1 guest