Images not opened when launched by Statistic program

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
Graham Smith

Images not opened when launched by Statistic program

Post by Graham Smith » Mon Nov 17, 2003 12:03 am

I have a strange problem using a statistics program that creates JPEGS of graphs which should then automatically launch the program that the registry has associated with jpgs.

However, when the stats program tries to open the jpeg, XnView opens and then gives an error "error opening file graph.jpg".

But if I then go to the directory where the stats program has stored the jpeg, and double click on it, XnView opens the jpeg without any problems.

Equally, if I change the file association for jpegs from XnView to Kodak Imaging, then Kodak Imaging does open the file from within the statistics program.

For comparison, I have also tried this with irfanview and it has exactly the same problem as XnView. So it seems to be related to the way both these programs work, which must be different to Kodak Imaging.

I am using WIN98SE, and the problem doesn't occur with WIN XP or Win2000.

Can anyone suggest a work around for this?

many thanks,

Graham S

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Problem opening JPEGs

Post by helmut » Mon Nov 17, 2003 7:07 am

Graham Smith wrote:...
However, when the stats program tries to open the jpeg, XnView opens and then gives an error "error opening file graph.jpg". ...
I think the reason for the problem opening files are spaces in the filenames and/or file path. Please have a look at the post Opening files with spaces in names, you'll find a solution posted, too.

Graham Smith

Re: Problem opening JPEGs

Post by Graham Smith » Mon Nov 17, 2003 8:42 am

Fraid not, I've checked and the full path is:

C:\Program Files\Stats\Brodgar\fish\graph1.jpg

Thanks for the suggestion, but it seems the problem is elsewhere.

Graham

Graham Smith

Re: Problem opening JPEGs

Post by Graham Smith » Mon Nov 17, 2003 10:17 am

Oh I am an idiot, there is of course a space in "Program Files".

However, starting from scratch in a new directory D:\Brodgar hasn't helped so the space doesn't seem to be the problem.

XnView opens the Jpgs when double clicked in Explorer, and they are selected under Options/associations.

Graham

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Problem opening JPEGs

Post by helmut » Mon Nov 17, 2003 10:50 pm

The reason for your problem is really not the spaces in the path, but the fact that your stat program does not pass the path of the image file to the program that is called (here XnView). This can be clearly seen in the error message that XnView displays: "Error opening file 'graph.jpg'".

Not quite sure, but I think that XnView and IrfanView both search for the image file "graph.jpg" in the current directory and will not find it there.
The Kodak Imaging seems to work differently, perhaps this one uses the current directory or the last directory.

Think we understand the problem, now. Time for solutions...

Perhaps, the stats program (btw which stats program do you use?) has options to set how the imaging software is called.

Guest

Re: Problem opening JPEGs

Post by Guest » Tue Nov 18, 2003 11:19 am

The stats program is Brodgar (www.brodgar.com), and I am sure, if you would like to email Alain Zuur (highstat@highstat.com) he would be able to discuss exactly what Brodgar is doing.

He is currently reviewing how the graphics are dealt with in Brodgar, I have discussed this problem with him and he knows I have asked the question here. He, however, cannot replicate the problem with WIN2000 and WINXP so either it is a WIN98SE problem, or it is something peculiar to my set up.

However, I am confident that he would appreciate you making contact with him, to discuss this specific problem and possibly some other aspects of XnView.

Graham

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Problem opening JPEGs

Post by helmut » Tue Nov 18, 2003 10:23 pm

Currently, Alain, Pierre and I investigate the problem, which is specific to the statistic program "Brodgar". Once we have a solution we will post here, again.

Guest

Re: Problem opening JPEGs

Post by Guest » Wed Nov 19, 2003 9:50 pm

helmut wrote:Currently, Alain, Pierre and I investigate the problem, which is specific to the statistic program "Brodgar". Once we have a solution we will post here, again.
Thanks, I will wait and see your solution.

Graham

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Problem opening JPEGs

Post by helmut » Fri Nov 28, 2003 6:52 am

Alain, the author of the statistics program "Brodgar" could find the problem. It was the way Brodgar invoked the graphic viewer. Alain will fix this and provide a version which will work with XnView.

Post Reply