Gain Control: No decimal numbers in info

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
viewfan
Posts: 11
Joined: Thu Oct 10, 2013 2:43 pm

Gain Control: No decimal numbers in info

Post by viewfan » Thu Oct 10, 2013 2:52 pm

German, see English translation in next post.

___
Hi, habe vor kurzem XnViewMP auf Bodhi Linux (auf Ubuntu 12.4 basierend) installiert.
Habe zuvor schon lange die normale Version auf Windows benutzt.
Bin ganz froh darum, leider hat es einige Bugs:

Die Anzeige der Signalverstärkung funktioniert nicht richtig:
(F12 > Ansicht> Informationen > Einfügen>>
EXIF- BILD > VERSTÄRKERREGELUNG {EXIF:Gain Control}:

„Low Gain Up“ und „High Gain Up“, da werden keine Dezimalwerte angezeigt, das heißt bei einer Signalverstärkung von 0.3 wird irrtümlich nichts angezeigt, bei 0.7 wird 1 angezeigt, bei 1.3 auch nur 1, bei -2 wird auch nur Low Gain Up (1) angezeigt.

Auch die Bildbearbeitung innerhalb der Stapelbearbeitung hat Bugs, z.B. Die Bildgröße, bzw. 'Proportionen erhalten' ist etwas wackelig. Ebenso die Filterfunktion (Vorschaubereich) und die Kennzeichnungsmöglichkeit verschwindet manchmal im Vorschaubereich.

Frames (z.B. in PSD-Dateien) werden auch nicht angezeigt.

Thanks a lot for the version for linux. Sorry for german writing but it is to much in english. :)

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Gain Control, Signalverstärkung in der Info Anzeige ohn

Post by helmut » Tue Oct 22, 2013 9:03 pm

viewfan (English translation) wrote:Hello, recently I've installed XnView MP on Bodhi Linux (bases on Ubuntu 12.4).

I've been using the normal version of XnView on Windows for a long time.
I'm quite happy but it has some bugs:

The display of the gain control does not work properly:
(F12 > View > Info > Insert >> EXIF - Image > Gain Control {EXIF:Gain Control}:

For "Low Gain up" und "High Gain Up", no decimal values are displayed, this means that for a gain control of 0.3 erroneously nothing is display. For 0.7 it displays 1, for 1.3 also 1, for -2 only Low Gain Up (1).

Also, the image processing within the batch processing is buggy, e.g. the image size or Keep ratio is a bit shacky. Also the filter function (preview area) and the tagging sometimes disappears in the preview area.

Frames (e.g. in PSD files) are not displayed either.

Thanks a lot for the version for linux. Sorry for german writing but it is to much in english. :)

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Gain Control, Signalverstärkung in der Info Anzeige ohn

Post by helmut » Tue Oct 22, 2013 9:09 pm

Thanks for your feedback, viewfan. Just to make sure: The problems you describe are with XnView MP on Bhodi Linux, right? (Originally, you posted in the XnView Classic section, this is why I'm asking). Before answering in more detailed this should be clarified. Which version of XnView do you use?

For translating answers and posts, please use an automatic translator like Bing. English (and French) is prefered in this forum, but you can write in German, if needed. I'll translate your answers, then.

___ GERMAN ___
Bitte verwende einen automatischen Übersetzer wie Bing um die Beiträge auf Englisch zu lesen. In diesem Forum wird nur Englisch und Französisch geschrieben. Wenn nicht anders möglich kannst du ausnahmsweise auf deutsch schreiben, ich werde deine Antworten dann übersetzen.

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Gain Control, Signalverstärkung in der Info Anzeige ohn

Post by helmut » Tue Oct 22, 2013 9:27 pm

No decimal numbers in Gain control
I just tried to reproduce your problem with the gain control and found out that the EXIF specification allows for integer values only:
0 = None
1 = Low gain up
2 = High gain up
3 = Low gain down
4 = High gain down
See http://www.awaresystems.be/imaging/tiff ... ntrol.html for example.

When taking the picture the camera maps the decimal values to one of the five possible EXIF values for gain control and saves it in the EXIF data of the image. XnView just displays the stored EXIF value together with the appropriate text.

viewfan
Posts: 11
Joined: Thu Oct 10, 2013 2:43 pm

Re: Gain Control: No decimal numbers in info

Post by viewfan » Sat Aug 25, 2018 9:43 am

:shock: Embarrassing: five years later I've notice I confused the {EXIF:Gain Control} with {EXIF:Exposure Bias}, exposure compensation.
And for that decimal numbers are displayed. :)

The Gain Control relates to the ISO setting:
If ISO is more than 64 it's displayed 1, up from 400 it's 2.
(with an Olympus SP565UZ camera)

Post Reply