Change Icon after changing a file association

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
steffen

Change Icon after changing a file association

Post by steffen » Sat Oct 08, 2005 12:48 pm

I searched the internet and this forum for answers on my question, without luck. The closest I got was this post by another guy who has the exact same problem as I. Therefore I will show you an edited version of his post, as he explained the problem quite well.

---

(Newsgroups: alt.os.windows2000)

Why can't I Change Icon after changing a file association?
Try this:

1) Bring up the Folder Options dialog under Windows Explorer and
select the File Types tab.

2) Change one of the file associations (like TIF) to a different
application.

3) Notice how the "Advanced" button changes to "Restore".

Without access to the Advanced button, you can't change the icon
used to display files of a given type. What's up with that?

I like to have Xnview open TIF files instead of the
Kodak ImageVue app. I also want TIF files to have a different icon, than lets say JPG files. But after changing the association, I can't go in
and pick a different icon since the "Advanced" button is
gone. Is there a workaround for this? NT4 didn't have this limitation.

Thanks,

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Using TC…

Post by Clo » Sat Oct 08, 2005 4:56 pm

:) Hello !

- This is true, Win XP is very obstinate about the associations / icons changes, it's a well known issue…
- Normally, I use the Total Commander File Menu >> "Associate with…" features to set / change associations and file-types icons; with XP, it's really boring… Many times, I had to suppress totally the file-type in Windows, reboot the PC, then reset it in Total Commander.
- My (greedy) 2-CPU XP-Pro machine is put off at this moment, but I could retest in the detail later if you don't succeed…

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

raga
Posts: 19
Joined: Tue Jun 21, 2005 6:16 pm

Post by raga » Tue Oct 11, 2005 4:17 pm

Handling file associations under Windows is very annoying. Almost every version since Windows 95 changed the way to do it a little bit. But it got even more confusing. Sometimes the easiest way is to edit the registry directly. But as always you should be very careful when editing the registry:

0) Before you begin, use the restore button in folder options
1) Start regedit.
2) On the left side navigate to the key "HKEY_CLASSES_ROOT\.png"
3) On the right side select the entry "(Standard)"
4) Change the value of this entry to "XnView.png"

Hope, it works.

steffen

Post by steffen » Tue Oct 11, 2005 8:54 pm

In my registry it says this on the right hand side: *note I tried to change .jpg instead of .png

name | type | data
(default) | REG_SZ | OISjpegfile

raga
Posts: 19
Joined: Tue Jun 21, 2005 6:16 pm

Post by raga » Tue Oct 11, 2005 9:56 pm

Yes, this is the right place: Just double click at this value and change the data from "OISjpegfile" to "XnView.jpg".

steffen

Post by steffen » Wed Oct 12, 2005 4:29 pm

Ok that enables me to change the icon which is great, but it wont open the files.

in "open" under actions I have this setting "C:\Program Files\XnView\xnview.exe" %1
Ive also tried "C:\Progr~2\XnView\xnview.exe" %1

What happens if I doubbleclick a jpg file is that I get an error box saying <error opening the file c:\documents">
regardless of where the jpg im trying to open is located. Then the Xnview browser is launched.

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed Oct 12, 2005 4:56 pm

steffen wrote:Ok that enables me to change the icon which is great, but it wont open the files.

in "open" under actions I have this setting "C:\Program Files\XnView\xnview.exe" %1
Ive also tried "C:\Progr~2\XnView\xnview.exe" %1

What happens if I doubbleclick a jpg file is that I get an error box saying <error opening the file c:\documents">
regardless of where the jpg im trying to open is located. Then the Xnview browser is launched.
Your entry must be

Code: Select all

"C:\Program Files\XnView\xnview.exe" "%1"
Please note the double quotes around the %1, these are needed for filenames and paths with spaces, you can see that in your error message: "C:\documents".

steffen

Problem solved!

Post by steffen » Thu Oct 13, 2005 12:58 am

Thank you all for some great help, those doubble quotemarks did the trick!

:D

Post Reply