Photo viewing background

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
photog01
Posts: 7
Joined: Fri Nov 01, 2019 7:05 pm

Photo viewing background

Post by photog01 » Fri Nov 01, 2019 7:14 pm

When I am reviewing photos, they all appear against a white background. Can the background be changed to gray?

cday
XnThusiast
Posts: 2231
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Photo viewing background

Post by cday » Fri Nov 01, 2019 7:58 pm

photog01 wrote:
Fri Nov 01, 2019 7:14 pm
When I am reviewing photos, they all appear against a white background. Can the background be changed to gray?
XnView MP or XnView Classic?

If you are using XnView MP you can change the background colour in Tools > Settings... > View -- View tab .

There's probably an equivalent setting in XnView Classic, but I can't easily check at the moment.

photog01
Posts: 7
Joined: Fri Nov 01, 2019 7:05 pm

Re: Photo viewing background

Post by photog01 » Fri Nov 01, 2019 9:35 pm

Well, … I have found Tools; Settings; View; View (tab). I have set Background Color to black. Everything else in that section is unchecked. That change to black is confirmed by the icon behind the Background color label.

WONDERFULL!! I have a lovely white background. Shows I don't know what I am going. For 55 years now computers have demonstrated I don't know what I am doing. Perhaps this software does not understand my language.

Maybe I don't have XnView MP, but the tab confirms I am using XnView MP.

Any suggestions?

cday
XnThusiast
Posts: 2231
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Photo viewing background

Post by cday » Fri Nov 01, 2019 9:58 pm

photog01 wrote:
Fri Nov 01, 2019 9:35 pm
Well, … I have found Tools; Settings; View; View (tab). I have set Background Color to black. Everything else in that section is unchecked. That change to black is confirmed by the icon behind the Background color label.

WONDERFULL!! I have a lovely white background. Shows I don't know what I am going. For 55 years now computers have demonstrated I don't know what I am doing. Perhaps this software does not understand my language.

Maybe I don't have XnView MP, but the tab confirms I am using XnView MP.

Any suggestions?
It works correctly for me using XnView MP 0.93 on Linux and I'm not aware of any known issue, which version are you using as shown in Help > About and which operating system?

photog01
Posts: 7
Joined: Fri Nov 01, 2019 7:05 pm

Re: Photo viewing background

Post by photog01 » Fri Nov 01, 2019 10:48 pm

WEll, there is the problem. I am using XnView MP Windows - version 0.93.1 64-bits (Mar 6 20 2019) Libformat version 7.30 XnViewer apparently only understands Linux (with a Red Hat?).

I much appreciate your help. I just need to hope someone else can show me how to get XnViewer to understand MS language.

Could it be that something else is checked which is causing my problem? Do I need to do a RESTART in order for the change to take effect?

cday
XnThusiast
Posts: 2231
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Photo viewing background

Post by cday » Sat Nov 02, 2019 8:04 am

photog01 wrote:
Fri Nov 01, 2019 10:48 pm
WEll, there is the problem. I am using XnView MP Windows - version 0.93.1 64-bits (Mar 6 20 2019) Libformat version 7.30 XnViewer apparently only understands Linux (with a Red Hat?).

I much appreciate your help. I just need to hope someone else can show me how to get XnViewer to understand MS language.

Could it be that something else is checked which is causing my problem? Do I need to do a RESTART in order for the change to take effect?

Unlikely to be related to Windows/Linux or to require a restart, more likely a misunderstanding: are you referring to viewing images in the viewer or possibly to viewing thumbnails in the file browser? It might be helpful if you could post a screenshot...

photog01
Posts: 7
Joined: Fri Nov 01, 2019 7:05 pm

Re: Photo viewing background

Post by photog01 » Sat Nov 02, 2019 12:44 pm

I have been invoking XnView by calling up the file using File Explorer then right clicking a photo and selecting Open With and then selecting XnViewer

I find that if I call up XnView and then select the file using XnView I get a dark background.

I remember years ago the doc said I could use any character in column 2. Turned out I could use any character un column 2 as long it was a blank. So, computers have been doing it to me for decades.

Thank you all for your help.

cday
XnThusiast
Posts: 2231
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Photo viewing background

Post by cday » Sat Nov 02, 2019 1:02 pm

photog01 wrote:
Sat Nov 02, 2019 12:44 pm
I have been invoking XnView by calling up the file using File Explorer then right clicking a photo and selecting Open With and then selecting XnViewer
And what colour background do you have then?

I find that if I call up XnView and then select the file using XnView I get a dark background.
If you launch XnView and open the file from the file browser, you get the black background, regardless of the setting above?

photog01
Posts: 7
Joined: Fri Nov 01, 2019 7:05 pm

Re: Photo viewing background

Post by photog01 » Sat Nov 02, 2019 2:57 pm

When I invoke XnView from File Explorer, I get a white background. It does not seem to matter whet I set View at.

When I invoke XnView from the desktop, I get the black background which is the setting in the View entry. If I set the View entry to blue, I open the photo with a blue background.

photog01
Posts: 7
Joined: Fri Nov 01, 2019 7:05 pm

Re: Photo viewing background

Post by photog01 » Sat Nov 02, 2019 3:10 pm

When I launch XnView from the desktop, the photos are displayed with the background color I have set in View.

cday
XnThusiast
Posts: 2231
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Photo viewing background

Post by cday » Sat Nov 02, 2019 3:18 pm

photog01 wrote:
Sat Nov 02, 2019 2:57 pm
When I invoke XnView from File Explorer, I get a white background. It does not seem to matter [which background color I set].

When I invoke XnView from the desktop, I get [the background color set in the settings options].
So the problem is only when you open an image from Windows using right-click 'Open with...' ?

User avatar
XnTriq
Moderator & Librarian
Posts: 5463
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Photo viewing background

Post by XnTriq » Sun Nov 03, 2019 3:30 am

photog01 wrote:
Sat Nov 02, 2019 12:44 pm
I have been invoking XnView by calling up the file using File Explorer then right clicking a photo and selecting Open With and then selecting XnViewer

I find that if I call up XnView and then select the file using XnView I get a dark background.
I'm assuming that …
  • ToolsSettings…GeneralGeneralStartupMode when starting with a file
… is set to Fullscreen - Browser or Fullscreen - Viewer.

If you want the background to be a certain color in all modes, both of the following settings have to adjusted accordingly:
  1. ToolsSettings…ViewViewBackground color
  2. ToolsSettings…FullscreenFullscreenBackground color

photog01
Posts: 7
Joined: Fri Nov 01, 2019 7:05 pm

Re: Photo viewing background

Post by photog01 » Sun Nov 03, 2019 10:53 am

Thank you!

Very helpful!

Leowu
Posts: 1
Joined: Mon Dec 02, 2019 4:05 pm

Re: Photo viewing background

Post by Leowu » Mon Dec 02, 2019 4:12 pm

Can I set changing of background on a set of keys?

Post Reply