color fault in preview of Sony ARW files since version 2.44

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
stargazer7
Posts: 2
Joined: Wed Jul 11, 2018 7:33 am

color fault in preview of Sony ARW files since version 2.44

Post by stargazer7 » Wed Jul 11, 2018 7:56 am

Hello,
since version 2.44 there is a color fault in preview of Sony RAW files (.ARW), see attached screenshot.
Current version 2.45 is also affected, but it worked up to version 2.43.
Only the preview is affected, if I open the photo the colors are normal.
It is independent from any xnview.ini settings.
I extracted the embedded preview image in ARW file using "exiftool -b -PreviewImage file.arw > file.jpg" and the generated JPG shows correct colors in preview.
All my Sony ARW files are affected, but no other RAW files (I only have access to Panasonic files).
If necessary I can provide ARW files.
Attachments
color-fault.JPG

User avatar
xnview
Author of XnView
Posts: 30122
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: color fault in preview of Sony ARW files since version 2.44

Post by xnview » Sun Jul 15, 2018 2:32 pm

could you send me a file?
Pierre.

User avatar
xnview
Author of XnView
Posts: 30122
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: color fault in preview of Sony ARW files since version 2.44

Post by xnview » Wed Jul 18, 2018 10:08 am

ok, it will be fixed in next version
Pierre.

stargazer7
Posts: 2
Joined: Wed Jul 11, 2018 7:33 am

Re: color fault in preview of Sony ARW files since version 2.44

Post by stargazer7 » Thu Jul 19, 2018 7:27 am

thank you!

Post Reply