Inconsistent highlighting of pane separators

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Inconsistent highlighting of pane separators

Post by helmut »

When moving the mouse on one of the new symbols ">" for hiding/showing the pane separator, the symbol will be shown in red. Nothing else happens.

When doing the same for the separator which separates preview pane and properties pane, then the whole separator will be displayed in dark grey. Since this is inconsistent behaviour I consider this as a bug.

V 1.90 B3
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Strange here

Post by Clo »

:) Hi !

• Here, when displaying as layout #4 :

• For the horizontal separator Thumb nails ¦ Preview, only the half of the arrow point is shown in red, funny !

For the vertical separator, no red at all for the arrow, and a strange behaviour with the Image cursor,
which shows a red bar outside the separator (far in the zones).

:mrgreen: G.
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
ckit
XnThusiast
Posts: 2446
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Re: B3: Inconsistent highlighting of pane separators

Post by ckit »

helmut wrote:When moving the mouse on one of the new symbols ">" for hiding/showing the pane separator, the symbol will be shown in red. Nothing else happens.

When doing the same for the separator which separates preview pane and properties pane, then the whole separator will be displayed in dark grey. Since this is inconsistent behaviour I consider this as a bug.
Confirmed.
XnViewMP 64bits and Windows 10 Pro x64 2004
PhotoFiltre Studio X
ckit
XnThusiast
Posts: 2446
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Re: Strange here

Post by ckit »

Clo wrote::) Hi !

• Here, when displaying as layout #4 :

• For the horizontal separator Thumb nails ¦ Preview, only the half of the arrow point is shown in red, funny !

For the vertical separator, no red at all for the arrow, and a strange behaviour with the Image cursor,
which shows a red bar outside the separator (far in the zones).

:mrgreen: G.
Claude
Clo
Confirmed.
XnViewMP 64bits and Windows 10 Pro x64 2004
PhotoFiltre Studio X
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: B3: Inconsistent highlighting of pane separators

Post by xnview »

helmut wrote:When moving the mouse on one of the new symbols ">" for hiding/showing the pane separator, the symbol will be shown in red. Nothing else happens.

When doing the same for the separator which separates preview pane and properties pane, then the whole separator will be displayed in dark grey. Since this is inconsistent behaviour I consider this as a bug.
Yes, i'll wait feedback for that. So if separator for preview/list is good, i'll mkae same thing for main separator!
Pierre.
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: B3: Inconsistent highlighting of pane separators

Post by helmut »

xnview wrote:Yes, i'll wait feedback for that. So if separator for preview/list is good, i'll mkae same thing for main separator!
What feedback are you waiting for? Is there a thread with a discussion somewhere?
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: B3: Inconsistent highlighting of pane separators

Post by xnview »

helmut wrote:
xnview wrote:Yes, i'll wait feedback for that. So if separator for preview/list is good, i'll mkae same thing for main separator!
What feedback are you waiting for? Is there a thread with a discussion somewhere?
Yes, there is a thread but don't find it...
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

My thread ?

Post by Clo »

:arrow: Pierre

:) Hello !

• Maybe do you mean THIS ONE ? ;)

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

Re: B3: Inconsistent highlighting of pane separators

Post by Olivier_G »

xnview wrote:Yes, there is a thread but don't find it...
Or this one? :)
Olivier
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: B3: Inconsistent highlighting of pane separators

Post by xnview »

Olivier_G wrote:
xnview wrote:Yes, there is a thread but don't find it...
Or this one? :)
So i change higlighting like preview separator?
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Grrrr…

Post by Clo »

:arrow: Pierre

:) Hi !

• Still not fixed up in ß-5, we have only the half of the arrow point as red for the small buttons in the splitters… etc.
- All same defects as I described above are there.

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Grrrr…

Post by xnview »

Clo wrote::arrow: Pierre

:) Hi !

• Still not fixed up in ß-5, we have only the half of the arrow point as red for the small buttons in the splitters… etc.
- All same defects as I described above are there.
I have not your problems with layout 4.... A screenshot perhaps?
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

See by yourself !

Post by Clo »

:arrow: Pierre

:) Hello !

• Below are the buttons of the splitters :

    Image    Image

- Only the half of the point is red… Not easy to spot !
- With this vertical adjustment cursor Image, I have a red bar in the cursor while it's far inside the area,
that is strange and useless…
- Sorry, this can't be captured, it needs a video…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: See by yourself !

Post by xnview »

Clo wrote::arrow: Pierre

:) Hello !

• Below are the buttons of the splitters :

Image Image

- Only the half of the point is red… Not easy to spot !
- With this vertical adjustment cursor Image, I have a red bar in the cursor while it's far inside the area,
that is strange and useless…
- Sorry, this can't be captured, it needs a video…
Half of the point??? Sorry but in don't understand your problem!
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

In other words…

Post by Clo »

:) Well, more precisely : The half of the “arrow”, since it has no shaft !

- My problem is that I'm 25 years older than you, and my eyes too ! :D

- So, why don't you paint the whole blue small arrow into red when the mouse hovers it ?

   Image Like this…

- Also, what is this cursor Image useful for ? With the minimal hard-coded width of the pane (with tabs), this adjustment-cursor could simply disappear, to show this one is confusing…
- It appears when one is on the "wrong" strip to adjust the width…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
Post Reply