little problem installing ShellExtension x64 1.6

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Henry_Jones
Posts: 20
Joined: Sat Mar 17, 2007 10:18 am

little problem installing ShellExtension x64 1.6

Post by Henry_Jones » Fri May 18, 2007 4:24 pm

Hello

I downloaded the version 1.6 of the x64 ShellExtension today but there is a little problem with the setup.

During the setup the following message appers (using a german Vista x64):
-->
C:\Program Files (x86)\XnView\ShellEx\XnViewShellExt.dll

Unable to register the DLL/OCX: LoadLibrary failed: Code 193.
%1 ist keine zulässige Win32-Anwendung.

Click retry to try again, Ignore to proceed anyway (not recommended),
or Abort to cancel installation
-->

retry does nothing beside showing the message again.
abort does what it says, rolling back the setup
ignore continues the setup and finishes it, but the Extension is not working.

Trying to register the dll myself with:
regsvr32 C:\Program Files (x86)\XnView\ShellEx\XnViewShellExt.dll
from a console with admin rights solves the problem.

The %1 in the first message seems to me that some parameter in the setup did not get its data.

Beside that, great work, this is to my knowledge the first PicPreview in ContextMenu for x64 systems. 8) 8)

User avatar
xnview
Author of XnView
Posts: 31891
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: little problem installing ShellExtension x64 1.6

Post by xnview » Sat May 19, 2007 8:50 am

Someone with the same problem? Only with x64 setup?
Pierre.

Holger

Re: little problem installing ShellExtension x64 1.6

Post by Holger » Sun May 20, 2007 12:38 pm

xnview wrote:Someone with the same problem? Only with x64 setup?
Yes, I do have the same problem on Vista 64 Business

Torsten

Re: little problem installing ShellExtension x64 1.6

Post by Torsten » Fri May 25, 2007 7:20 am

xnview wrote:Someone with the same problem? Only with x64 setup?
Yes, I just installed the full version of 1.91 on Windows 2000 PC and got the same error message and same phenomenon.

Torsten

Re: little problem installing ShellExtension x64 1.6

Post by Torsten » Fri May 25, 2007 7:31 am

Torsten wrote:
xnview wrote:Someone with the same problem? Only with x64 setup?
Yes, I just installed the full version of 1.91 on Windows 2000 PC and got the same error message and same phenomenon.
Fogot to add the writtings on the scrren, as theya re slightly different

****************

C:\Program Files\XnView\ShellEx\XnViewShellExt.dll

Unable to register the DLL/OCX: DllRegisterServer failed: Code 0x8002801D.

Click retry to try again, Ignore to proceed anyway (not recommended),
or Abort to cancel installation

****************

Guest

Post by Guest » Fri May 25, 2007 7:36 am

Just tried on Vista x86 Ultimate, did work without problems.

invité

same

Post by invité » Wed Jun 27, 2007 6:00 pm

same for me on Windows XP professional x64 Edition

Guest

Post by Guest » Sun Jul 01, 2007 7:53 pm

Same like Torsten here,

OS: W2K SP4

Guest

Post by Guest » Fri Jul 13, 2007 2:44 pm

xnview...

what´s wrong with this install...why don´t you give a short reply please...this is really not reported the first time...only to know...

thank you

thomes

User avatar
xnview
Author of XnView
Posts: 31891
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Jul 19, 2007 2:12 pm

Anonymous wrote:xnview...

what´s wrong with this install...why don´t you give a short reply please...this is really not reported the first time...only to know...
The problem is that i don't know why? I can't reproduce...
Pierre.

Jsp
Posts: 1
Joined: Thu Sep 20, 2007 11:32 pm

x64 Shell Problems

Post by Jsp » Fri Sep 21, 2007 12:05 am

I have the same problem. I can´t install the 64 bits Shell Extension.
(I have Windows on drive D). I get:

D:\Program Files (x86)\XnView\ShellEx\XnViewShellExt.dll

Unable to register the DLL/OCX: LoadLibrary failed: Code 193.
%1 is not a valid Win32 application.

Click Retry to try again, Ignore to proceed anyway (not recommended), or Abort to cancel installation.

Image
Of course none of the options above make the Shell Extension work.

I also tried to place it in the 64 bit Program Files folder with the same result.
Am I doing something wrong, or doesn´t the XnView Shell Extension Setup 64bits run on Windows x64?

Any thoughts on a completely 64 bit XN-View?
Thanx so far
Make it work!

User avatar
foxyshadis
Posts: 384
Joined: Sat Nov 18, 2006 8:57 am

Post by foxyshadis » Fri Sep 21, 2007 8:55 am

You have to register with
%systemroot%\syswow64\regsvr32 "path"

You can only use it in 32-bit explorer, if there even is such a thing (never used 64-bit, sorry), a 32-bit shell extension won't work in a 64-bit host.

Guest

found a fix ! i guess...

Post by Guest » Sat Oct 27, 2007 7:50 pm

Ok,

I had exactly the same problem (Windows vista Business 64 bit French).

Did not manage to make the executable work, same message as yours saying it's not a valid win32 file (no wonder since i'm installing the 64 bit version, i wonder why it expects a 32 bit file anyways ! )
By the way, why does it want to install it by default in "program files (x86)" when it's a 64 bit dll ? Is there a probleme in the detection of 32/64 bit ?

Tried to register the dll manually with (%windir%\system32\regsvr32 "..path to the file"), which is the correct regsvr32 to register a 64 bit dll as far as i know, the one in syswow64 being for 32 bit dlls (i know, the names are incredibly misleading, if i'm wrong please tell me) and got an error message.
Something about "sidebyside" and a missing file Microsoft.VC80.ATL

Looked around a little and found a link to "Microsoft Visual C++ 2005 SP1 Redistributable Package (x64)" you can dowlaod here : http://www.microsoft.com/downloads/deta ... layLang=en

With this package installed i tried to register the dll again, and this time it worked ! Hurray !

But.... I still don't have the thumbnails of the images in windows explorer ! (PSD files)
I only have a thumbnail of the file in the contextual menu that appears when i right click on it. Not directly in the thumbnail view in explorer !

Is this normal ? Or is the dll not installed properly ?

How can i see the thumnails of my files directly in explorer ?

Merci pour toute aide

User avatar
xnview
Author of XnView
Posts: 31891
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: found a fix ! i guess...

Post by xnview » Mon Oct 29, 2007 7:40 am

Anonymous wrote: Is this normal ? Or is the dll not installed properly ?
Yes, you would like to have the thumbnails in explorer too
Pierre.

Guest

Post by Guest » Mon Oct 29, 2007 5:12 pm

Yes, i want to be able to see the thumbnails in explorer.

Certain file types (PSD files are the one i want to see most) don't appear in windows vista 64 bit's explorer.

Are there is no fix for this with vista 64 bit. The psicon.dll fix that works with the 32 bit version of windows doesn't on the 64 bit one because psicon.dll is 32 bits.

So right now there is no way to see thumbnails of PSD files (and AI files etc..) in vista 64 bit's explorer (set in thumbnail view of course - icones moyennes).

If Xnview could fix this problem it would be great !

Post Reply