IPTC annoying display bug

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

IPTC annoying display bug

Post by Jarda » Tue Jul 15, 2008 9:33 pm

This bug is reproducible, i am using XnView v. 1.93.6 under Windows 2000 SP4:
Use long IPTC captions in JPG files (160+ chars). Open XnView image manager first, then doubleclick to switch to image browser. Use fullscreen button (you should previously set to display IPTC caption data but no another item in fullscreen mode) - the first image loads correct with full IPTC caption text. The next image is displayed well but IPTC caption text from previous image is *not* entire cleared from display - appears new text for the second image and stays part of text from the first image (in my case the chars in position 153 and all following).

The third image will be displayed with text related to third image plus part (end) of text related to the second image and part of text related to the first image etc.

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: IPTC annoying display bug

Post by xnview » Wed Jul 16, 2008 6:54 am

Could you send me 2 pictures to test, and tell me font, size used?
Pierre.

Jarda_free

Re: IPTC annoying display bug

Post by Jarda_free » Wed Jul 16, 2008 7:13 pm

xnview wrote:Could you send me 2 pictures to test, and tell me font, size used?
Font @Arial Unicode MS, normal, size 14, green color, bg color not specified (black set but unchecked).

The bug appears as the text mixture (see second line on the screenshot):
http://www.klatovsko.cz/www/j353840/opera/iptc_text.jpg

Sample pic 1:
http://www.klatovsko.cz/www/j353840/opera/p7150184.jpg
Sample pic 2:
http://www.klatovsko.cz/www/j353840/opera/p7150182.jpg

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

Post by Jarda » Sun Jul 20, 2008 10:10 pm

Confirmed under WinXP SP2 too. Can you reproduce this bug using the linked images?

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

1.94 still affected

Post by Jarda » Mon Jul 21, 2008 8:13 pm

This bug is still present in 1.94 final. Are "Jarda_free" examples useful?

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.94 still affected

Post by xnview » Tue Jul 22, 2008 9:12 am

Jarda wrote:This bug is still present in 1.94 final. Are "Jarda_free" examples useful?
Yes, will be fixed in next release
Pierre.

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

Re: 1.94 still affected

Post by Jarda » Tue Jul 22, 2008 2:43 pm

xnview wrote:
Jarda wrote:This bug is still present in 1.94 final. Are "Jarda_free" examples useful?
Yes, will be fixed in next release
Thanks! :)

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

Post by Jarda » Sun Jul 27, 2008 6:21 pm

The bug is unfortunately still present in 1.94.1 and 1.94.2 :(

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

Post by Jarda » Fri Sep 12, 2008 5:48 pm

I can confirm 1.95 b1 is OK. Thanks!

Post Reply